Jump to content


Photo

Upgrade from 4.0 to 6.1 and samba password KO.


  • Please log in to reply
62 replies to this topic

#1 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 11 April 2018 - 22:15

I make upgrade from open pli 4.0 to open pli 6.1 but my samba server on a vuduo2 won't work since this upgrade, just after restart samba work great with NO password and users guest on, but if i make a "smbpasswd -a root" my pc can't or ojther device (android) can't connect to the shared folder.

 

 

 

 



Re: Upgrade from 4.0 to 6.1 and samba password KO. #2 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 10:39

Nobody ?



Re: Upgrade from 4.0 to 6.1 and samba password KO. #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 11:25

Why would you need smbpasswd? I'm not sure that even works, Samba is configured to use the linux users and passwords?


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #4 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 12:09

Yes, smb.conf is configured with security = user and the path to the password file, all worked very fine since long year with open pli 4.0 but not after upgrade to 6.1.

 

I try to use the special smb.conf for OP 6.1 and add the security = user but when I enter the password from other device = acces denied.


Edited by mackguil, 12 April 2018 - 12:12.


Re: Upgrade from 4.0 to 6.1 and samba password KO. #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 12:28

"security=user" is default in the config.

 

You are sure samba runs? Check the output of "/etc/init.d/samba.sh restart". You didn't restore your smb.conf from OpenPLi 4 (which is not compatible with OpenPLi 6)?

 

I don't have any issue here:

[wanwizard@catwoman] $ sudo mount -t cifs //172.16.1.49/Harddisk /mnt -o user=root
Password for root@//172.16.1.49/root:  ********
[wanwizard@catwoman] $ mount | grep /mnt
//172.16.1.49/Harddisk on /mnt type cifs (rw,relatime,vers=default,cache=strict,username=root,domain=,uid=0,noforceuid,gid=0,noforcegid,addr=172.16.1.49,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1,user=root)
[wanwizard@catwoman] $ 

This is 6.2-rc. but that shouldn't matter, it has the same samba version and default config.


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #6 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 13:28

Yes samba run fine with guest account all device can mount the share but with security and user root + password, not possible.

 

In my smb.conf from old 4.0, parameter for security = share, IN OP 6.1 samba won't start,

 

With security= user, Samba start but acces denied.



Re: Upgrade from 4.0 to 6.1 and samba password KO. #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 13:58

I didn't use the guest account here, I created the mount as user root. I have "guest ok = no" on the shares in smb.conf.

 

Again, you can't use the smb.conf from OpenPLi 4, it is made for samba v3, which doesn't work in OpenPLi 6 (which runs samba v4).


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #8 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 14:22

Again, you can't use the smb.conf from OpenPLi 4, it is made for samba v3, which doesn't work in OpenPLi 6 (which runs samba v4).

 

I have understand, I use this one:

[global]
workgroup = WORKGROUP
deadtime = 15
max smbd processes = 6
max log size = 5
guest account = root
load printers = no
show add printer wizard = no
printcap name = /dev/null
disable spoolss = yes
map to guest = Bad Password
security = user
server role = standalone server
unix password sync = yes
local master = yes
preferred master = yes
oplocks = yes
kernel oplocks = yes
socket options = IPTOS_LOWDELAY TCP_NODELAY
smb passwd file = /etc/samba/private/smbpasswd

[Root]
  comment = Everything - take care!
  path = /
  read only = no
  public = yes
  guest ok = no
  valid users = root

[Harddisk]
  comment = The harddisk
  path = /media/hdd
  read only = no
  public = yes
  guest ok = yes




Re: Upgrade from 4.0 to 6.1 and samba password KO. #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 14:30

I've replaced my smb.conf with yours, changed the workgroup name, restarted samba on the box, and still, it mounts without problems.

 

But I haven't been fiddling with smbpasswd, so it would probably work fine if you remove

smb passwd file = /etc/samba/private/smbpasswd

which isn't needed.

 

p.s. this is the default file: https://raw.githubus.../samba/smb.conf


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #10 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 14:47

I've replaced my smb.conf with yours, changed the workgroup name, restarted samba on the box, and still, it mounts without problems.

 

But I haven't been fiddling with smbpasswd, so it would probably work fine if you remove

smb passwd file = /etc/samba/private/smbpasswd

which isn't needed.

 

p.s. this is the default file: https://raw.githubus.../samba/smb.conf

Lol, it's my problem since the start, all work fine without password.



Re: Upgrade from 4.0 to 6.1 and samba password KO. #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 15:30

It's difficult to comment if it can't be reproduced.


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #12 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 16:36

It's difficult to comment if it can't be reproduced.

I have this error message:

 

Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE

 

 



Re: Upgrade from 4.0 to 6.1 and samba password KO. #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 17:11

Where? what?

 

What is your client? What command do you exactly execute?


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #14 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 17:50

Error message from /var/log/messages with a client windows7, when i try a \\ip from vuduo2.

 

But can't connect from a debian with a smb://ip from the box, when i enter user and password immediately the box request user and pass.

 

From android the same thing, like debian.


Edited by mackguil, 12 April 2018 - 17:51.


Re: Upgrade from 4.0 to 6.1 and samba password KO. #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 17:53

Again, I can't reproduce. smb://ip connects without issues here:

 

Attached File  Screenshot from 2018-04-12 17-52-42.png   18.11KB   9 downloads


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #16 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 18:32

Again, I can't reproduce. smb://ip connects without issues here:

 

attachicon.gifScreenshot from 2018-04-12 17-52-42.png

Without password, all work fine.



Re: Upgrade from 4.0 to 6.1 and samba password KO. #17 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 18:38

This was with a password. I never have boxes without password.


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #18 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 19:11

This was with a password. I never have boxes without password.

Samba password.



Re: Upgrade from 4.0 to 6.1 and samba password KO. #19 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,723 posts

+715
Excellent

Posted 12 April 2018 - 20:01

You don't need a samba password, samba uses the linux password. I already wrote that in post #3.


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Upgrade from 4.0 to 6.1 and samba password KO. #20 mackguil

  • Senior Member
  • 158 posts

0
Neutral

Posted 12 April 2018 - 20:05

Ok how can i reinstall completly Samba from scratch ?

 

opkg remove samba

opkg install samba

 

Or

 

opkg install samba --force-reinstall






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users