Jump to content


Photo

The box restarts time to time


  • Please log in to reply
9 replies to this topic

#1 BoniBo

  • Member
  • 5 posts

0
Neutral

Posted 29 April 2018 - 15:29

Hello, I'm using VU Zero with OpenPli 6.1 and it happens to restarts itself a few times now giving me this text:

OpenPLi Enigma2 crash log
 
crashdate=нд апр 29 17:24:34 2018
compiledate=Feb 19 2018
skin=SkyQ/skin.xml
sourcedate=2018-02-18
branch=release-6.1
rev=34dd341
component=enigma2


stbmodel=zero
stbmodel=dm8000
kernelcmdline=ubiroot rootflags=sync bmem=192M@64M ubi.mtd=rootfs rootfstype=ubifs root=ubi0:rootfs libata.force=1:1.5Gbps
nimsockets=NIM Socket 0:
imageissue=openpli 6.1-release %h




REMOVE Peer vuzero
[eDVBPESReader] Created. Opening demux
[eDVBPESReader] Created. Opening demux
[eDVBPESReader] Created. Opening demux
[eDVBPESReader] Created. Opening demux
[eDVBPESReader] Created. Opening demux
Unhandled Error
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/twisted/protocols/basic.py", line 571, in dataReceived
  File "/usr/lib/python2.7/site-packages/twisted/web/http.py", line 1655, in lineReceived
  File "/usr/lib/python2.7/site-packages/twisted/web/http.py", line 1730, in allContentReceived
  File "/usr/lib/python2.7/site-packages/twisted/web/http.py", line 826, in requestReceived
--- <exception caught here> ---
  File "/usr/lib/python2.7/site-packages/twisted/web/server.py", line 189, in process
  File "/usr/lib/python2.7/site-packages/twisted/web/server.py", line 238, in render
  File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/base.py", line 140, in render
    data = func(request)
  File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/web.py", line 115, in P_statusinfo
    return getStatusInfo(self)
  File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/info.py", line 739, in getStatusInfo
    if len(curEvent[3].decode('utf-8')) > 220:
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    
exceptions.UnicodeDecodeError: 'utf8' codec can't decode byte 0xd0 in position 248: unexpected end of data
[eDVBPESReader] Created. Opening demux
[eDVBPESReader] Created. Opening demux
../../git/lib/gui/ewidget.cpp:337 ASSERTION t FAILED!

Edited by WanWizard, 29 April 2018 - 22:28.
reduced post size


Re: The box restarts time to time #2 Frenske

  • Forum Moderator
    PLi® Core member
  • 23,063 posts

+213
Excellent

Posted 29 April 2018 - 15:35

As far as I can see it seems an issue with the webif. Don’t know what you tried to do. Was it webif related?
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: The box restarts time to time #3 BoniBo

  • Member
  • 5 posts

0
Neutral

Posted 29 April 2018 - 15:39

I've opened a port on my router to access the box from outside my local network, but the port is opened from a few months now and I have this issue for a few days



Re: The box restarts time to time #4 betacentauri

  • PLi® Core member
  • 5,811 posts

+261
Excellent

Posted 29 April 2018 - 15:58

I guess problem with epg data. Providers sometimes broadcast bad data. Maybe webif guys can fix or workaround this.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: The box restarts time to time #5 BoniBo

  • Member
  • 5 posts

0
Neutral

Posted 29 April 2018 - 22:31

And now it happened after switching channels



Re: The box restarts time to time #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,718 posts

+924
Excellent

Posted 29 April 2018 - 22:41

Quite possible if your EPG data is corrupt.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: The box restarts time to time #7 BoniBo

  • Member
  • 5 posts

0
Neutral

Posted 30 April 2018 - 04:41

How can i fix that or I shoud call my cable provider...



Re: The box restarts time to time #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,718 posts

+924
Excellent

Posted 30 April 2018 - 13:04

I doubt they are going to fix it, especially if their own hardware doesn't have a problem.

 

 

Anyway, even if the data is incorrect, the box shouldn't crash. If if does, you need to report the error to the correct place, so it can be fixed. In case of the WebIf, this is not on this forum, but here: https://github.com/E...penWebif/issues

 

Before you do, flash a 6.2-rc image in your box, so you are sure you test a recent OpenWebIf version, and you are not reporting an issue that has already been solved.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: The box restarts time to time #9 Erik Slagter

  • PLi® Core member
  • 45,454 posts

+504
Excellent

Posted 1 May 2018 - 18:52

Yes the UTF-8 handling in enigma isn't that robust.

 

Actually I think, on invalid code sequences, the renderer should substitute some "invalid codepoint" character (just like any other system does), instead of throwing an exception. That's meant for programming errors, not for invalid inputs (which can always happen).


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: The box restarts time to time #10 Aliraza63

  • Member
  • 16 posts

+1
Neutral

Posted 2 May 2018 - 14:15

How can i fix that or I shoud call my cable provider...

 Do u use any 3rd party plugin for epg ?  if its so  then remove it  and restart box and check it 


Vu+Duo2, Vu+Solo4k, Vu+Uno4k
Vu+Solo2 , Vu+Ultimo4k, Zegmma H9S





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users