Jump to content


Photo

ssl ca-certificates issues on openpli 4


  • Please log in to reply
3 replies to this topic

#1 serdeliuk

  • Senior Member
  • 53 posts

+1
Neutral

Posted 30 April 2018 - 07:37

Hello,

 

I have an issue with HTTPS connection from cli, curl and python. The issue is with local ca-certificates storage which is not updated.

I have a DM800HD and VuSolo4K devices, both with OpenPli4 and both have the same issue.

 

I tried to update all files/certificates by hand from a working server but i was unsuccessful.

 

Can you please let me know where i can find a ca-certificates package to update my OpenPLi4.

 

Below is how you can check

 

root@dm800:~# curl -vvv https://pypi.python....imple/requests/

*   Trying 151.101.12.223...

* Connected to pypi.python.org (151.101.12.223) port 443 (#0)

* found 166 certificates in /etc/ssl/certs/ca-certificates.crt

* server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

* Closing connection 0

curl: (60) server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

More details here: http://curl.haxx.se/docs/sslcerts.html

 
Best regards,
 
 
Marc

init 2 && init 3


Re: ssl ca-certificates issues on openpli 4 #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 41,562 posts

+662
Excellent

Posted 30 April 2018 - 12:59

The source of the ca-certificates is https://www.mozilla....ty-group/certs/


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: ssl ca-certificates issues on openpli 4 #3 betacentauri

  • PLi® Core member
  • 4,276 posts

+208
Excellent

Posted 30 April 2018 - 14:22

Better use a current 6.1 or rc6.2 image. And also check whether system time is set properly.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: ssl ca-certificates issues on openpli 4 #4 serdeliuk

  • Senior Member
  • 53 posts

+1
Neutral

Posted 30 April 2018 - 14:35

Oh my god, i completely forgot about time/date and ssl related issues and that's why my update didn't worked :)))) many thanks @betacentauri

It seems that i need to upgrade my memory, do you know a remedy for this too? :D


init 2 && init 3





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users