Jump to content


Photo

Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door


  • Please log in to reply
31 replies to this topic

#1 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 18:16

Na updaten van de Ultimo 4k startte de box niet meer 'door'. Hij startte op in een soort standby-modus die niet met de afstandsbediening op te lossen was (zette de box in standby en weer 'on' maar er gebeurde niks)

 

Ik kwam erachter dat je via openwebif dan de box wel aan kunt krijgen. Daarna de box herstart en toen startte die wel gewoon goed door.

 

Overigens moet je 3x achter elkaar in een telnetsessie 'opkg update && opkg upgrade' doen anders update de decoder maar voor een gedeelte. Dit laatste viel me bij andere decoders ook op.

 



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 18:22

Drie keer is nieuw, ik had wel graag geweten welke er nog open stonden.

 

Het probleem hier is de bizarre manier waarop opkg upgrades doet. Die de-installeert eerst alles, om daarna alles weer te installeren. In plaats van package voor package, rekening  houdend met dependencies.

 

Zo klopt het dat je met deze update zeker twee keer moet upgraden, omdat de kernel modules vernieuwd zijn bij de meeste boxen, je daarvoor de tool "depmod" nodig hebt, en die heeft opkg reeds weggegooid op het moment dat de kernel packages die nodig hebben om de modules netjes te kunnen verwijderen.

 

Dit soort dingen zien we pas als we zelf een upgrade gaan testen, en dan is het al te laat om er iets aan te doen, want dat moet dan in de oude versie. Dus de "depmod" issue is gefixt voor een volgende upgrade.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #3 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 20:00

Dit is bij de eerste keer:

 

 * opkg_install_pkg: Failed to download python-audio. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-pycparser. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libldb. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libexpat1. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download gstreamer1.0-plugins-bad-dashdemux. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...89a-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-systemplugins-hdmicec. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...411-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-lc-1. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...411-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-lc-2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...411-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-lc-3. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download alsa-utils-alsactl. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...411-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-lc-4. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download pam-plugin-faildelay. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-plistlib. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libasound2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...89a-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-systemplugins-skinselector. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope....0-r9.2_all.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download run-postinsts. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libnfsidmap0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-misc. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-compression. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-twisted-protocols. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download init-ifupdown. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download ntpdate. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libfaad2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libltdl7. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libdw1. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-html. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libflac8. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-pickle. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libtirpc3. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope..._2-r0.2_all.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download volatile-media. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download e2fsprogs-mke2fs. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download gstreamer1.0-plugins-base-audioconvert. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope....12-.0.4_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-rt2800usb. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-cryptography. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download gstreamer1.0-plugins-good-apetag. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download wpa-supplicant-passphrase. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download aio-grab. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...89a-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-extensions-graphmultiepg. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libgstsdp-1.0-0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libtuxtxt0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download sysvinit. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libpopt0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download wireless-tools. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libe2p2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download vsftpd. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download mpg123. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libdaemon0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libfuse2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-zlib. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...89a-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-systemplugins-satfinder. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope....0-r83.2_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download packagegroup-machine-base. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libogg0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libjpeg62. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope....12-.0.4_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download kernel-module-mt7601u. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libgstrtsp-1.0-0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download opencore-amr. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-twisted-core. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download util-linux-sulogin. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libnss-mdns. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libgstriff-1.0-0. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download gstreamer1.0-plugins-good-avi. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download python-contextlib. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libavahi-core7. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download libfreetype6. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download pam-plugin-shells. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...89a-r0.0_lc.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-systemplugins-videotune. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download gstreamer1.0-plugins-good-flv. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download modutils-loadscript. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mips32el-nf.ipk, wget returned 255.
 * opkg_install_pkg: Failed to download enigma2-plugin-extensions-audiosync. Perhaps you need to run 'opkg update'?
 * pkg_run_script: package "busybox-syslog" postinst script returned status 1.
 * opkg_configure: busybox-syslog.postinst returned 1.

 

Eigenlijk zijn het er nog meer maar die kan ik niet terughalen in de telnetsessie, de lijst is zo enorm lang...


Edited by Dimmie, 12 May 2018 - 20:03.


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 20:06

Er gaan hier een aantal dingen mis.

 

Om te beginnen doe jij vast een upgrade op de commandline, and dat miet je NIET doen bij een image versie upgrade. Want dan loop je nog veel meer tegen de opkg problemen om dat als je het via het menu doet. Daar zijn er een heleboel van afgevangen namelijk. Dus: NIET DOEN. Ten tweede, de error hierboven is dat hij files niet vinden kan. En dat komt vast omdat je lokaal nog een oude packages file hebt.  

 

Dit is dus allemaal niet zo relevant.

 

Als je er op staat om het via de commandline te doen, gebruik dan minstens de commandline uit /usr/bin/enigma2.sh.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #5 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 20:09

Daar sta ik niet op maar als je via het menu update dan starten de boxen niet meer door en moet je alsnog via een commandline verder upgraden.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 20:23

Dat is blijkbaar zo bij sommige boxen. Ik heb er een berg getest, en bij geen dat probleem gehad.

 

Maar feit blijft, een algemene upgrade lost het probleem niet op, omdat dat nu juist het probleem veroorzaakt. Je moet dus exact weten wat er fout gaat, om uit te zoeken waarom het fout gaat, zodat je dat kunt voorkomen. Die veroorzakers zijn in /usr/bin/enigma2.sh er uit gevist, maar blijkbaar moeten er nog meer uitgevist worden.

 

Wat er derhalve nodig is, is dat er op de boxen die een probleem hebben, een test wordt uitgevoerd. Dat betekent 6.1-release flashen, en dan op de commandline dit uitvoeren:

( opkg upgrade sysvinit && opkg upgrade sysvinit-pidof && opkg upgrade initscripts-functions && opkg upgrade busybox && opkg upgrade kmod && opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade ) 2>&1 | tee /home/root/ipkgupgrade.log

en die ipkupgrade.log hier posten zodat we die kunnen analyseren en op basis daarvan dit commando verfijnen.

 

Ik heb zelf een XP1000 (die een van de probleem gevallen lijkt), dus die kan ik morgen wel doen, maar anderen zullen de andere probleemgevallen moeten bekijken.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #7 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 20:38

Die regel zojuist uitgevoerd op een 6.1 installatie op een zgemma lc, maar dan krijg je na een tijdje dit:

 

wget: short write



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #8 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 21:27

Op de Zgemma LC heb ik het zo voor elkaar gekregen:

 

init 4
opkg update
opkg upgrade sysvinit && opkg upgrade sysvinit-pidof && opkg upgrade initscripts-functions && opkg upgrade busybox && opkg upgrade kmod

reboot

 

init4

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

reboot

 

init4

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

reboot

 

init4

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

reboot

 

 

Daarna was de box pas volledig geupdated.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 21:55

wget: short write

 

Is een busybox error meestal veroorzaakt door of out of disk space of out of inodes. Dat zou te maken kunnen hebben dat /tmp een tmpfs is en het memory van een low-end box niet al te veel is.

 

Jammer echter dat we nu wel weten hoe je een update gedaan hebt, maar niet wat er nu fout gaat. En dus ook niets kunnen fixen.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #10 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 21:59

Zgemma H4:

 

Update via het menu resulteert in een box die niet meer opstart

 

Update via de commandline die jij gaf geeft het volgende resultaat:

 

opkg: unknown sub-command kernel-module-rt2x00usb
usage: opkg [options...] sub-command [arguments...]
where sub-command is one of:

Package Manipulation:
        update                          Update list of available packages
        upgrade                         Upgrade installed packages
        install <pkgs>                  Install package(s)
        configure <pkgs>                Configure unpacked package(s)
        remove <pkgs|glob>              Remove package(s)
        clean                           Clean internal cache
        flag <flag> <pkgs>              Flag package(s)
         <flag>=hold|noprune|user|ok|installed|unpacked (one per invocation)

Informational Commands:
        list                            List available packages
        list-installed                  List installed packages
        list-upgradable                 List installed and upgradable packages
        list-changed-conffiles          List user modified configuration files
        files <pkg>                     List files belonging to <pkg>
        search <file|glob>              List package providing <file>
        info [pkg|glob]                 Display all info for <pkg>
        status [pkg|glob]               Display all status for <pkg>
        download <pkg>                  Download <pkg> to current directory
        compare-versions <v1> <op> <v2>
                                        compare versions using <= < > >= = << >>
        print-architecture              List installable package architectures
        depends [-A] [pkgname|glob]+
        whatdepends [-A] [pkgname|glob]+
        whatdependsrec [-A] [pkgname|glob]+
        whatrecommends[-A] [pkgname|glob]+
        whatsuggests[-A] [pkgname|glob]+
        whatprovides [-A] [pkgname|glob]+
        whatconflicts [-A] [pkgname|glob]+
        whatreplaces [-A] [pkgname|glob]+

Options:
        -A                              Query all packages not just those installed
        -V[<level>]                     Set verbosity level to <level>.
        --verbosity[=<level>]           Verbosity levels:
                                          0 errors only
                                          1 normal messages (default)
                                          2 informative messages
                                          3 debug
                                          4 debug level 2
        -f <conf_file>                  Use <conf_file> as the opkg configuration file
        --conf <conf_file>
        -d <dest_name>                  Use <dest_name> as the the root directory for
        --dest <dest_name>              package installation, removal, upgrading.
                                        <dest_name> should be a defined dest name from
                                        the configuration file, (but can also be a
                                        directory name in a pinch).
        -o <dir>                        Use <dir> as the root directory for
        --offline-root <dir>            offline installation of packages.
        --add-arch <arch>:<prio>        Register architecture with given priority
        --add-dest <name>:<path>        Register destination with given path
        --add-exclude <name>            Register package to be excluded from install
        --prefer-arch-to-version        Use the architecture priority package rather
                                        than the higher version one if more
                                        than one candidate is found.
        --combine                       Combine upgrade and install operations, this
                                        may be needed to resolve dependency issues.
                                        Only available for the internal solver backend.

Force Options:
        --force-depends                 Install/remove despite failed dependencies
        --force-maintainer              Overwrite preexisting config files
        --force-reinstall               Reinstall package(s)
        --force-overwrite               Overwrite files from other package(s)
        --force-downgrade               Allow opkg to downgrade packages
        --force-space                   Disable free space checks
        --force-postinstall             Run postinstall scripts even in offline mode
        --force-remove                  Remove package even if prerm script fails
        --noaction                      No action -- test only
        --download-only                 No action -- download only
        --nodeps                        Do not follow dependencies
        --no-install-recommends         Do not install any recommended packages
        --force-removal-of-dependent-packages
                                        Remove package and all dependencies
        --autoremove                    Remove packages that were installed
                                        automatically to satisfy dependencies
        -t                              Specify tmp-dir.
        --tmp-dir                       Specify tmp-dir.
        --cache-dir <path>              Specify cache directory.
        --host-cache-dir                Don't place cache in offline root dir.
        --volatile-cache                Use volatile cache.
                                        Volatile cache will be cleared on exit

 glob could be something like 'pkgname*' '*file*' or similar
 e.g. opkg info 'libstd*' or opkg search '*libop*' or opkg remove 'libncur*'


Edited by Dimmie, 12 May 2018 - 22:00.


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 22:07

Dan moet er iets fout gegaan zijn met de copy en paste, want dit is de exacte regel die Enigma zelf uit voert.

opkg: unknown sub-command kernel-module-rt2x00usb

suggereert dat je ergens een "upgrade" vergeten bent.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #12 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 22:21

Nog een keer op nieuw gedaan en denk dat je gelijk had.

 

Op de Zgemma H4 heb ik het zo voor elkaar gekregen:

 

init 4
opkg update
opkg upgrade sysvinit && opkg upgrade sysvinit-pidof && opkg upgrade initscripts-functions && opkg upgrade busybox && opkg upgrade kmod

reboot

 

init4

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

reboot

 

init4

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

reboot

 

Daarna was de Zgemma H4 geupdated.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 22:29

Welke waren er na de eerste list-upgradable dan nog mislukt? Die log had ik dan graag gehad, want dat betekent dat er in de eerste lijst nog een package ontbreekt.
 

Ik zal morgen kijken of ik dit met een H3 kan reproduceren. Wordt niks meer vandaag, ik sta op instorten...


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #14 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 12 May 2018 - 22:44

Gewoon gaan pitten, morgen weer een dag Dit is hobby he, geen must. :D

 

Wat er bij de H4 en de LC gebeurd is inderdaad dat ze vol lopen. Dus dan geef je een reboot en doe je opnieuw dat commando en dan wordt de rest geïnstalleerd.

 

Opnieuw doen voor de Ultimo 4k wordt een beetje lastig omdat die box in de woonkamer wordt gebruikt en tevens als hoofd-opname apparaat. En aangezien dr hier nog meer wonen in het gezin kan ik daar nu ff niet mee rommelen.

Ik ga zo / morgen verder testen met nog wat andere boxen; als daarbij iets anders naar voren komt dan te weinig memory dan post ik dat hier met de logs.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 12 May 2018 - 22:58

Snap ik. Ik kijk wat wat ik nog getest krijg. Druk morgen, F1 gaat voor. ;)


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #16 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 13 May 2018 - 00:14

De Zgemma H.2H en H3.2TC geven de volgende error bij de 1e keer:

 

* opkg_solver_upgrade: Package libattr1 not installed.

 

Als je daarna reboot en nog een keer de update doet dan wordt libattr1 ook niet meer gevonden/geïnstalleerd ?



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #17 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 13 May 2018 - 00:51

Bij de Xsarius Pure HD SE krijg je dezelfde error bij de 1e keer:

 

Collected errors:
 * opkg_solver_upgrade: Package libattr1 not installed.

 

En hierbij ook weer: als je daarna reboot en nog een keer de update doet dan wordt libattr1 ook niet meer gevonden/geïnstalleerd.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #18 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 13 May 2018 - 01:33

Zgemma H7C, error bij eerste keer:

 

Collected errors:
 * opkg_solver_upgrade: Package libattr1 not installed.
 * opkg_download_backend: Failed to download http://downloads.ope...409-r0.1_h7.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download qtbase. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...409-r0.1_h7.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download qtbase-plugins. Perhaps you need to run 'opkg update'?
xargs: opkg: exited with status 255; aborting

 

 

Na rebooten blijft de error m.b.t. qtbase terug komen:

 

Upgrading qtbase from 5.8.0+git0+49dc9aa409-r0.0 to 5.8.0+git0+49dc9aa409-r0.1 on root.
qtbase: unsatisfied recommendation for qtbase-qmlplugins
Upgrading qtbase (5.8.0+git0+49dc9aa409) on root.
Downloading http://downloads.ope...409-r0.1_h7.ipk.
wget: server returned error: HTTP/1.1 404 Not Found
Upgrading qtbase-plugins from 5.8.0+git0+49dc9aa409-r0.0 to 5.8.0+git0+49dc9aa409-r0.1 on root.
Upgrading qtbase-plugins (5.8.0+git0+49dc9aa409) on root.
Downloading http://downloads.ope...409-r0.1_h7.ipk.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download_backend: Failed to download http://downloads.ope...409-r0.1_h7.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download qtbase. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...409-r0.1_h7.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download qtbase-plugins. Perhaps you need to run 'opkg update'?
xargs: opkg: exited with status 255; aborting


Edited by Dimmie, 13 May 2018 - 01:34.


Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #19 Dimmie

  • Senior Member
  • 1,738 posts

+17
Neutral

Posted 13 May 2018 - 02:11

Na het updaten krijg je Stalker ook met geen mogelijkheid meer aan de praat, en dat is 'raar' omdat die in 6.1 en 6.2RC gewoon werkte.



Re: Updaten gaat niet in 1 keer en na updaten start de box ook niet uit zichzelf door #20 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,843 posts

+685
Excellent

Posted 13 May 2018 - 11:26

Dat kan, want ik heb gisteren om de qt handel te testen een rebuild gedaan voor de HD51. Maar omdat dit een shared package is moet je wachten op de rebuild, en die loopt nog.

 

Die andere bekijk ik even, maar aangezien de build nog loopt zou het ook daar mee te maken kunnen hebben.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users