Jump to content


Photo

MKV wil niet afspelen


  • Please log in to reply
8 replies to this topic

#1 doglover

  • Rytec EPG Team
  • 11,531 posts

+320
Excellent

Posted 25 May 2018 - 09:20

Ik heb hier een mkv file welke niet wil afspelen.

In VLC speelt ie perfect af.  Ook via Chromecast kan ik hem op de TV afspelen.  Echter met OpenPLI 6.0 en 6.2 wil ie niet.

Nu begrijp ik dat niet alles afspeelt op een enigma2 machine.  En gaat mij ook niet om hier support voor te krijgen.

 

Alleen zou ik willen begrijpen waarom hij niet wil afspelen, zodat ik dit in de toekmst kan vemijden>

 

De mediainfo:

Algemeen
UniqueID/String                          : 309087867717958591419837054808542084631 (0xE8882871EEE22D04EBD9BFA4CABAFE17)
Volledige naam                           :
Formaat                                  : Matroska
Formaatversie                            : Version 4 / Version 2
Bestandsgrootte                          : 1 008 MiB
Duur                                     : 58 min 30s
Totale bitrate                           : 2 408 kb/s
Datum codering                           : UTC 2018-05-11 07:44:05
Gebruikt programma                       : mkvmerge v22.0.0 ('At The End Of The World') 64-bit
Gebruikte encoderbibliotheek             : libebml v1.3.5 + libmatroska v1.4.8

Video
ID                                       : 1
Formaat                                  : AVC
Formaat/Info                             : Advanced Video Codec
Formaatprofiel                           : High@L3.1
Formaatinstellingen                      : CABAC / 5 Ref Frames
Formaatinstellingen, CABAC               : Ja
Formaatinstellingen, RefFrames           : 5 frames
Codec-ID                                 : V_MPEG4/ISO/AVC
Duur                                     : 58 min 30s
Bitrate                                  : 2 250 kb/s
Breedte                                  : 1 280 pixels
Hoogte                                   : 720 pixels
Beeldverhouding                          : 16:9
Frameratemodus                           : Constant
Framerate                                : 25,000 FPS
ColorSpace                               : YUV
ChromaSubsampling/String                 : 4:2:0
BitDepth/String                          : 8 bits
Scansoort                                : Progressief
Bits/(Pixel*Frame)                       : 0.098
Stroomgrootte                            : 940 MiB (93%)
Gebruikte encoderbibliotheek             : x264 core 146
Instellingen codering                    : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=7 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / paff=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=125 / keyint_min=12 / scenecut=0 / intra_refresh=0 / rc_lookahead=60 / rc=abr / mbtree=1 / bitrate=2250 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=2812 / vbv_bufsize=4500 / nal_hrd=none / filler=0 / ip_ratio=1.00 / aq=2:1.00
Taal                                     : Zweeds
Default                                  : Ja
Forced                                   : Nee

Audio
ID                                       : 2
Formaat                                  : AAC
Formaat/Info                             : Advanced Audio Codec
Formaatprofiel                           : LC
Codec-ID                                 : A_AAC-2
Duur                                     : 58 min 29s
Bitrate                                  : 160 kb/s
Kanaal(en)                               : 2 kanalen
Kanaalposities                           : Front: L R
Samplerate                               : 48,0 kHz
Framerate                                : 46,875 FPS (1024 SPF)
Video vertraging                         : -80 ms
Stroomgrootte                            : 67,0 MiB (7%)
Taal                                     : Zweeds
Default                                  : Ja
Forced                                   : Nee

Tekst #1
ID                                       : 3
Formaat                                  : UTF-8
Codec-ID                                 : S_TEXT/UTF8
Codec-ID/Info                            : UTF-8 Plain Text
Duur                                     : 58 min 14s
Bitrate                                  : 54 b/s
ElementCount                             : 579
Stroomgrootte                            : 23,0 KiB (0%)
Taal                                     : Nederlands
Default                                  : Ja
Forced                                   : Nee

Tekst #2
ID                                       : 4
Formaat                                  : UTF-8
Codec-ID                                 : S_TEXT/UTF8
Codec-ID/Info                            : UTF-8 Plain Text
Duur                                     : 58 min 3s
Bitrate                                  : 50 b/s
ElementCount                             : 494
Stroomgrootte                            : 21,5 KiB (0%)
Taal                                     : Noors
Default                                  : Nee
Forced                                   : Nee

Kan iemand die meer begrijpt van al deze parameters mij het licht doen aangaan?

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: MKV wil niet afspelen #2 40H3X

  • Senior Member
  • 2,627 posts

+94
Good

Posted 25 May 2018 - 10:49

Ik zie het zo niet, in je signature staat  "Xtrend ET6000 OpenPli (used as mediaplayer)", kan je deze file met geen enkele Enigma2 machine afspelen?


Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 3TB RAID 1
Software : OpenPLi 6.x - OSCam r11xxx - Settings van Hans


Re: MKV wil niet afspelen #3 doglover

  • Rytec EPG Team
  • 11,531 posts

+320
Excellent

Posted 25 May 2018 - 12:31

Kan hem niet afspelen met zowel de HD2400 (openPLi 6.0) als met de Xtrend ET-6500 (openPLi 6.2)

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: MKV wil niet afspelen #4 40H3X

  • Senior Member
  • 2,627 posts

+94
Good

Posted 25 May 2018 - 12:44

Helaas,zie ik niks waarom "gstreamer" deze file niet zou kunnen afspelen, maar er zijn ongetwijfeld anderen die een veel betere blik hierop kunnen werpen.


Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 3TB RAID 1
Software : OpenPLi 6.x - OSCam r11xxx - Settings van Hans


Re: MKV wil niet afspelen #5 doglover

  • Rytec EPG Team
  • 11,531 posts

+320
Excellent

Posted 25 May 2018 - 13:19

Heb wat geprobeerd.

 

1.De MKV geremuxed met MKVtoolnix. MKV geladen en nieuwe file laten aanmaken.  ==>  Speelt niet af

 

2.De MKV geremuxed met MKVtoolnix. MKV geladen, ondertitles gewist en nieuwe file laten aanmaken.  ==>  Speelt niet af

 

2.De MKV uit elkaar getrokken in een videobestand, audiobestand en ondertitel bestanden.

Alle enkelvoudige files spelen af op gstreamer.

 

3.Een nieuwe MKV file aangemaakt vanuit de enklevoudige files (video, audio, en ondertitel - Noorse ondertitle weggelaten)

Deze file speelt af. 

 

Conclusie:  In de originele MKV container zit iets wat gstreamer niet lust.

Ik kan echter niet bedenken wat juist.

 

Willy

 

Hier de mediinfo van de MKV file welke wel afspeelt.

Algemeen
UniqueID/String                          : 295405767852360492359005041187029109631 (0xDE3D14D6F7E50AEB50E5331CB2D9CB7F)
Volledige naam                           :
Formaat                                  : Matroska
Formaatversie                            : Version 4 / Version 2
Bestandsgrootte                          : 1 008 MiB
Duur                                     : 58 min 30s
Totale bitrate                           : 2 408 kb/s
Datum codering                           : UTC 2018-05-25 11:57:07
Gebruikt programma                       : mkvmerge v22.0.0 ('At The End Of The World') 64-bit
Gebruikte encoderbibliotheek             : libebml v1.3.5 + libmatroska v1.4.8

Video
ID                                       : 1
Formaat                                  : AVC
Formaat/Info                             : Advanced Video Codec
Formaatprofiel                           : High@L3.1
Formaatinstellingen                      : CABAC / 5 Ref Frames
Formaatinstellingen, CABAC               : Ja
Formaatinstellingen, RefFrames           : 5 frames
Codec-ID                                 : V_MPEG4/ISO/AVC
Duur                                     : 58 min 30s
Bitrate                                  : 2 250 kb/s
Breedte                                  : 1 280 pixels
Hoogte                                   : 720 pixels
Beeldverhouding                          : 16:9
Frameratemodus                           : Constant
Framerate                                : 25,000 FPS
ColorSpace                               : YUV
ChromaSubsampling/String                 : 4:2:0
BitDepth/String                          : 8 bits
Scansoort                                : Progressief
Bits/(Pixel*Frame)                       : 0.098
Stroomgrootte                            : 940 MiB (93%)
Gebruikte encoderbibliotheek             : x264 core 146
Instellingen codering                    : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=7 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / paff=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=125 / keyint_min=12 / scenecut=0 / intra_refresh=0 / rc_lookahead=60 / rc=abr / mbtree=1 / bitrate=2250 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=2812 / vbv_bufsize=4500 / nal_hrd=none / filler=0 / ip_ratio=1.00 / aq=2:1.00
Default                                  : Ja
Forced                                   : Nee

Audio
ID                                       : 2
Formaat                                  : AAC
Formaat/Info                             : Advanced Audio Codec
Formaatprofiel                           : LC
Codec-ID                                 : A_AAC-2
Duur                                     : 58 min 29s
Bitrate                                  : 160 kb/s
Kanaal(en)                               : 2 kanalen
Kanaalposities                           : Front: L R
Samplerate                               : 48,0 kHz
Framerate                                : 46,875 FPS (1024 SPF)
Video vertraging                         : 5 ms
Stroomgrootte                            : 67,0 MiB (7%)
Default                                  : Ja
Forced                                   : Nee

Tekst
ID                                       : 3
Formaat                                  : UTF-8
Codec-ID                                 : S_TEXT/UTF8
Codec-ID/Info                            : UTF-8 Plain Text
Duur                                     : 58 min 14s
Bitrate                                  : 54 b/s
ElementCount                             : 579
Stroomgrootte                            : 23,0 KiB (0%)
Taal                                     : Nederlands
Default                                  : Ja
Forced                                   : Nee

Edited by doglover, 25 May 2018 - 13:52.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: MKV wil niet afspelen #6 40H3X

  • Senior Member
  • 2,627 posts

+94
Good

Posted 25 May 2018 - 13:41

Buiten de video vertraging van -80 ms naar +5 ms en geen Noorse ondertitels meer is er IMO geen verschil, ik kan me voorstellen dat de orginele MKV niet lekker is gemuxt, door de container uit elkaar te trekken en te remuxen kan het een betere hapklare brok zijn geworden ;)


Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 3TB RAID 1
Software : OpenPLi 6.x - OSCam r11xxx - Settings van Hans


Re: MKV wil niet afspelen #7 Erik Slagter

  • PLi® Core member
  • 42,678 posts

+461
Excellent

Posted 8 June 2018 - 14:50

Waarschijnlijk de timestamps. Door alles los te trekken en weer los toe te voegen zijn de timestamps weg. Dat betekent wel dat de video waarschijnlijk na enige tijd steeds verder uit de pas gaat lopen met het geluid en/of de ondertitels.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.


Re: MKV wil niet afspelen #8 doglover

  • Rytec EPG Team
  • 11,531 posts

+320
Excellent

Posted 9 June 2018 - 06:16

Ik kan dat niet meer controleren.  De file is ondertussen gewist.

 

In eerste instantie kon ik de file wel afspelen via de chromecast.  Heb hem via dat apparaat bekeken.

Vervolgens wou ik wel weten waaraan het probleem lag. 
Ik heb wel de nieuwe file dan eens afgespeeld op de HD2400, en ook ook naar een 4 tal plaatsen geskipt (begin midden en ergens naar het einde).  Hierbij is mij geen desynchronisatie opgevallen.  Maar ik begrijp dat dit skippen, de desynchronisatie kan verdoezelen.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: MKV wil niet afspelen #9 Erik Slagter

  • PLi® Core member
  • 42,678 posts

+461
Excellent

Posted 9 June 2018 - 10:31

Je zult het straks vanzelf merken ;) En wie weet mazzel....


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users