Jump to content


Photo

Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base:


  • Please log in to reply
7 replies to this topic

#1 pietjepuk

  • Member
  • 12 posts

0
Neutral

Posted 11 June 2018 - 14:28

I am seeing the following error in the ipkgupgrade.log

 

Configuring eniCollected errors:

 * calculate_dependencies_for: Cannot satisfy the following dependencies for packagegroup-machine-base:

 * gstreamer (>= 0.10.36.1+git12092+1bcabb9) * libgstvideo-0.10-0 (>= 0.10.36.1+git10186+bdb3316) * libjpeg8 (>= 8d) * 

gma2-plugin-systemplugins-skinselector.

Configuring kernel-module-rt2800usb.

Configuring enigma2-plugin-extensions-graphmultiepg.

Configuring enigma2-plugin-systemplugins-satfinder.

Configuring enigma2-plugin-systemplugins-videotune.

 

xargs: opkg: exited with status 255; aborting

 

Is this a known issue?

 

Regards

 



Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #2 pietjepuk

  • Member
  • 12 posts

0
Neutral

Posted 11 June 2018 - 14:45

The odd thing is that I cannot find any reference of the gstreamer version nor the libgstvideo version as listed in the error message in the installed package list. Is there a rogue entry in the package list somewhere?

box info:

 

Brand & Model: Vu+ Duo² Chipset: Broadcom 7424 Main Memory: 1260428 kB free / 1408712 kB total Box Uptime: 0:20 Software System OE: PLi-OE Firmware version: OpenPLi 6.2-release (2018-06-01-release-6.2) Kernel / Drivers: 3.13.5 / 3.13.5+20180319-r0.0


Edited by pietjepuk, 11 June 2018 - 14:49.


Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #3 pietjepuk

  • Member
  • 12 posts

0
Neutral

Posted 11 June 2018 - 14:56

Error is caused by trying to upgrade packagegroup-machine-base

Upgrading packagegroup-machine-base from 1.0-r83.2 to 1.0-r83.3 on root.

 

 

Is it possible that the package gma2-plugin-systemplugins-skinselector is linked and older version of the underlying libraries.

I noticed that libjpeg8 is not installed but libjpeg62 is, could this cause the issue?


Edited by pietjepuk, 11 June 2018 - 15:00.


Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,820 posts

+642
Excellent

Posted 11 June 2018 - 15:05

What box and what OpenPli release is this? 


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #5 pietjepuk

  • Member
  • 12 posts

0
Neutral

Posted 11 June 2018 - 18:40

What box and what OpenPli release is this? 

Please see second post



Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,820 posts

+642
Excellent

Posted 11 June 2018 - 18:57

OpenPLi 6 doesn't use gstreamer 0.10, that is from OpenPLi 4. Did you install some plugin that might have this as a dependency?


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #7 pietjepuk

  • Member
  • 12 posts

0
Neutral

Posted 11 June 2018 - 19:26

OpenPLi 6 doesn't use gstreamer 0.10, that is from OpenPLi 4. Did you install some plugin that might have this as a dependency?

Most info is in the previous posts, no I did not install gstreamer 0.10.36 nor is it installed on the system.

Here is the opkg command showing the error:

opkg install packagegroup-machine-base

Upgrading packagegroup-machine-base from 1.0-r83.2 to 1.0-r83.3 on root.

Collected errors:

 * calculate_dependencies_for: Cannot satisfy the following dependencies for packagegroup-machine-base:

 * gstreamer (>= 0.10.36.1+git12092+1bcabb9) * libgstvideo-0.10-0 (>= 0.10.36.1+git10186+bdb3316) * libjpeg8 (>= 8d) * 

 * opkg_solver_install: Cannot install package packagegroup-machine-base.

 

None of the packages listed in the error message is installed ( checked with 'opkg list-installed' )

 

 

opkg list-installed | fgrep  gstreamer

gstreamer1.0 - 1.12.4+git17579+a6653b6-r0.0

gstreamer1.0-libav - 1.12.4+git2090+326c741-r0.0

gstreamer1.0-plugin-dvbmediasink - 1.0+git82+16cae1a-r0.0

gstreamer1.0-plugin-subsink - 1.0+git7+2c4288b-r0.3

 

rest of output deleted

 

To me it looks like the package packagegroup-machine-base contains the wrong ( old ) library links.


Edited by pietjepuk, 11 June 2018 - 19:28.


Re: Upgrade error: Cannot satisfy the following dependencies for packagegroup-machine-base: #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,820 posts

+642
Excellent

Posted 11 June 2018 - 20:55

After a bit of digging, according to the control file:

  • packagegroup-machine-base depends on enigma2-plugins-extensions-hbbtv
  • enigma2-plugins-extensions-hbbtv depends on vuplus-hbbtv-dumpait and vuplus-opera-browser
  • vuplus-opera-browser depends on gstreamer 0.10.

enigma2-plugins-extensions-hbbtv and vuplus-opera-browser are both in the 3rd-party feeds for the Duo2, are from 2014, and are clearly not compatible with OpenPL 6.x.

 

From a quick look in the BSP it does look like defines a native browser, so someone needs to look at why it isn't build. And to get the old junk out of the VU+ feeds.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users