Jump to content


Photo

Edision Nino Openpli 6.2 Openvpn


  • Please log in to reply
4 replies to this topic

#1 dr_virus

  • Member
  • 19 posts

0
Neutral

Posted 28 June 2018 - 16:35

After 6.2 release for Edision Nino openvpn doesnt seems to work at all .

root@osnino:~# opkg update
Downloading http://downloads.ope...rty/Packages.gz.
Updated source 'openpli-3rd-party'.
Downloading http://downloads.ope...ino/Packages.gz.
Updated source 'openpli-3rd-party-osnino'.
Downloading http://downloads.ope...all/Packages.gz.
Updated source 'openpli-all'.
Downloading http://downloads.ope...2el/Packages.gz.
Updated source 'openpli-mips32el'.
Downloading http://downloads.ope...ino/Packages.gz.
Updated source 'openpli-osnino'.
root@osnino:~# opkg install openvpn
Installing liblzo2-2 (2.09) on root.
Downloading http://downloads.ope....2_mips32el.ipk.
Installing kernel-module-tun (4.8.17) on root.
Downloading http://downloads.ope...r0.4_osnino.ipk.
Installing openvpn (2.3.9) on root.
Downloading http://downloads.ope....0_mips32el.ipk.
Removing any system startup links for openvpn ...
Configuring liblzo2-2.
Configuring kernel-module-tun.
Configuring openvpn.
Adding system startup for /etc/init.d/openvpn.

 

The logs saws that openvpn is installed but there is on openvpn file in /etc even after receivers reboot .

 

In 6.1 version works normal .

 

Can someone has any idea ?



Re: Edision Nino Openpli 6.2 Openvpn #2 dr_virus

  • Member
  • 19 posts

0
Neutral

Posted 28 June 2018 - 16:50

Update

 

Openvpn seems to be installed correct  in /etc/init.d also in /usr/sbin but for some reason there there is no config file in /etc

 

I did one manually /etc/openvpn and it worked . Seems strange



Re: Edision Nino Openpli 6.2 Openvpn #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 41,216 posts

+651
Excellent

Posted 28 June 2018 - 16:58

There is no such thing as a (default) config file, you need to create your own.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: Edision Nino Openpli 6.2 Openvpn #4 dr_virus

  • Member
  • 19 posts

0
Neutral

Posted 28 June 2018 - 17:05

Sorry correction , i meant config direction
 
From openvpn in init.d

CONFIG_DIR=/etc/openvpn
 

In 6.1 this direction is setup after installation of openvpn , in 6.2 you have to do it manually .



Re: Edision Nino Openpli 6.2 Openvpn #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 41,216 posts

+651
Excellent

Posted 28 June 2018 - 17:20

Ok, I understand. Had a look, it looks like a change in the OpenEmbedded recipe (6.1-release had v2.3.2, 6.2-release has v2.3.9). There is a separate package called "openvpn-sample" which you may install manually.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users