Jump to content


Photo

Download for swedish channels not working ("unknown channel: ...)


  • Please log in to reply
8 replies to this topic

#1 SebastianM

  • Member
  • 11 posts

0
Neutral

Posted 30 June 2018 - 19:45

Hey there,

first of all, I want to thank you for this great plugin.  Good Work!

 

I am using epgimport on a vu solo2 with the VTI Image

Unfortunately, I am having problems to download EPG for swedish channels.

It does not download any items, and the log tells me "unknown channel" all the time..

 

Is my sources-file outdated?

 

any help is appreciated...

Attached Files



Re: Download for swedish channels not working ("unknown channel: ...) #2 doglover

  • Rytec EPG Team
  • 11,846 posts

+336
Excellent

Posted 1 July 2018 - 06:55

The log indicates, the epgimport plug-in is working normally.

However there is nothing imported.

It cannot find any channels to attach EPG to.

 

How is this possible?

The "unknown channel" remark is a warning that it cannot find this channel in the lamedb

The plug-in imports only EPG for channels which are present in the lamedb file.  So none of the channels are present in your lamedb file.

Several reasons for this to happen:

 

1. EPG is linked to a channel via the service ref. 

f.i.  <!-- 0.8W --><channel id="SVT1.se">1:0:19:1D7F:1B:46:E080000:0:0:0:</channel><!-- SVT1 -->

If the reference on your receiver for SVT1 is something different, no EPG

This can happen when you you use a dodgy setting list  which has been produced with a non-standard satellite.xml file.  Or your receiver has a non-standard satellite.xml in the image, so you when  you scanned the channels, it produced the abnormal service refs.

Can you give me the service ref for SVT 1 on your receiver?  This will tell me if this is the case here.

 

2. You are using a cable provider, which service refs are not included yet.

Again the service ref of SVT 1 will give indications to this.

 

3. Use of IPTV where all the channels have the same service ref: 4097:0:0:0:0:0:0:0:0:0:

In this case I have to point you to the stickies:

https://forums.openp...-iptv-channels/

https://forums.openp...g-epg-for-iptv/

 

Willy

 

PS:  Try also setting the entry in the epgimport config to NO :  Import only EPG for channels in bouquets


Edited by doglover, 1 July 2018 - 06:57.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Download for swedish channels not working ("unknown channel: ...) #3 SebastianM

  • Member
  • 11 posts

0
Neutral

Posted 4 July 2018 - 18:50

hey willy, thx for your reply... But I still dont really get it...

 

Example:

Lets say I want to assign the EPG of any satellite channel (example HORORFILM.cz on 23.5E from your channels list) to an IPTV Stream.

 

I looked up the ref-ID of HORORFILM.cz from your channels.xml (1:0:1:3350:C93:3:EB0000:0:0:0:) and copied it to my IPTV-Stream Bouquet.

Then it looks like this:

 

#SERVICE 1:0:19:643:10:1:FFFF0000:0:0:0:http%3a//example.com...:Hororfilm CZ

#DESCRIPTION Hororfilm CZ

 

But no EPG will showup... what am I doing wrong? Do I have to have "hororfilm cz" in my lamedb (because I haven't)?

 

thx!

 

PS: I read the other 2 topics...


Edited by SebastianM, 4 July 2018 - 18:50.


Re: Download for swedish channels not working ("unknown channel: ...) #4 doglover

  • Rytec EPG Team
  • 11,846 posts

+336
Excellent

Posted 5 July 2018 - 06:52

So IPTV it is.  I am not surprised.

Let me remind you to read this sticky: https://forums.openp...g-epg-for-iptv/

 

About the problem you have listed here above.  You try to hussle 2 methods.

The first method only works for channels which are listed in the lamedb.

FFFF0000 is cable reference.  I will be very surprised if this reference is in your lamedb.

 

Also you cannot read.  If you read the first paragraph of this sticky:  https://forums.openp...-iptv-channels/ (Edit 24-04-2018) you should have known there is a method to do this all semi-automatic.  It is not bullet-proof but at least it takes the pain out of this.

 

Last of all:  IPTV is largely illegal.  There are legal channels, but these are free on the internet.  The one I am aware of are listed here: https://forums.openp...ls-service-ref/
This list is maintained and EPG provided for, if I am pointed out to any changes.

 

 

Willy


Edited by doglover, 5 July 2018 - 06:57.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Download for swedish channels not working ("unknown channel: ...) #5 SebastianM

  • Member
  • 11 posts

0
Neutral

Posted 5 July 2018 - 10:16

Hi willy,

I tried both methods.

 

Even with a "own.channels.xml" and "own.sources.xml" it does not work (see attachments).

 

And yes, I can read, but as I only have a macbook, I cannot use E-Channelizer.

 

PS: This is not an illegal iptv stream for swedish residents.

Attached Files


Edited by SebastianM, 5 July 2018 - 10:16.


Re: Download for swedish channels not working ("unknown channel: ...) #6 doglover

  • Rytec EPG Team
  • 11,846 posts

+336
Excellent

Posted 5 July 2018 - 12:45

You can also use EPGimport Filter plug-in.  https://forums.openp...r-v100-by-acds/

It is a bit more work, but it works also.  (Works on the enigma2 machine)

 

As for the own.channels.xml file.  Try the attached.

Do forgot to select your ownSE.

 

Willy

 

 

 

Attached Files


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Download for swedish channels not working ("unknown channel: ...) #7 SebastianM

  • Member
  • 11 posts

0
Neutral

Posted 5 July 2018 - 12:51

thx. I will try this later at home.

 

EPGImport Filter does the same as I did (creating custom channels.xml), correct?



Re: Download for swedish channels not working ("unknown channel: ...) #8 doglover

  • Rytec EPG Team
  • 11,846 posts

+336
Excellent

Posted 5 July 2018 - 12:54

Yes, It does.

 

But the sources file needs now the <sourcecat> tag.  (Which I added the file I submitted)

 

Willy

 

PS: Why in GOD's heaven are you using the crap of Steve Jobs????


Edited by doglover, 5 July 2018 - 12:55.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Download for swedish channels not working ("unknown channel: ...) #9 SebastianM

  • Member
  • 11 posts

0
Neutral

Posted 5 July 2018 - 18:48

thx! your own.sources.xml did the trick!

 

great support. !!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users