Jump to content


Photo

Netwerk gerelateerde problemen


  • Please log in to reply
38 replies to this topic

#1 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 6 July 2018 - 16:03

Vroegere configuratie : 

VU+duo2 + DM8000 + NAS + PC: verbonden met elkaar via local network.

OpenPLI 4 geïnstalleerd op beide ontvangers.

==> Deze setup werkte zonder problemen

 

Huidige configuratie :

VU+duo2 + Mut@nt HD51 + NAS + PC: verbonden met elkaar via local network.

OpenPLI 6.2 geïnstalleerd op beide ontvangers.

==> Deze setup kent een aantal problemen.

  • VU+duo2 niet meer toegankelijk via PC
    • remedy :
      • root@vuduo2:~# /etc/init.d/samba.sh stop
        Stopping Samba: smbd nmbd wsdd.
        root@vuduo2:~# /etc/init.d/samba.sh start
        Starting Samba: smbd nmbd wsdd.
    • Dit is tot nu toe een aantal keren voorgekomen
    • Niet duidelijk wat de problemen heeft veroorzaakt.
  • VU+duo2 niet meer toegankelijk via HD51
    • Toegang vanuit PC was nog OK.
    • remedy :
      • root@vuduo2:~# /etc/init.d/samba.sh stop
        Stopping Samba: smbd nmbd wsdd.
        root@vuduo2:~# /etc/init.d/samba.sh start
        Starting Samba: smbd nmbd wsdd.
    • Dit is tot nu toe een aantal keren voorgekomen
    • Niet duidelijk wat de problemen heeft veroorzaakt.
  • HD51 hangt met draaiend wieltje links boven na raadpleging opnames over het netwerk.
    • Indien je opnames voor het eerst raadpleegt via het netwerk (door 'list' te drukken op de afstandsbediening) kan je de locatie veranderen. Na het selecteren van een netwerk locatie gaat alles goed en kan je opnames afspelen. Als je dan opnieuw op 'list' drukt, krijg je terug de lijst met opnames te zien. So far so good.
    • Als je 's anderendaags de opnames opnieuw wil raadplegen doen de problemen zich voor :
      • Het wieltje links boven draait continue
      • HD51 reageert niet meer op de afstandsbediening
      • HD51 komt hier niet meer uit
    • Remedy : via telnet HD51 rebooten.

Heeft er nog iemand gelijkaardige problemen ervaren?

Is dit gerelateerd met openpli 6.2?

Zijn er netwerk gerelateerde problemen gekend voor de HD51?

 

 

MVG

Pasquenel

 

 



Re: Netwerk gerelateerde problemen #2 Erik Slagter

  • PLi® Core member
  • 42,835 posts

+462
Excellent

Posted 7 July 2018 - 08:39

Werkt ping?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.


Re: Netwerk gerelateerde problemen #3 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 10:30

op het moment dat de HD51 hangt met draaiend wieltje :

- werkt ping vanop PC en VU+.

- Vanop PC kan je nog steeds opgenomen bestanden bekijken

- webinterface werkt niet meer

- Geen reactie op de afstandsbediening

- Als ik 's avonds de HD51 in stby zet met de locatie van 'list' wijzend naar de VU+ en 's anderendaags de HD51 weer gebruik, werkt de ontvanger normaal zolang je rechtstreeks TV kijkt. Vanaf je via de afstandsbediening op 'list' drukt, verschijnt het wieltje (forever) en is er geen reactie meer via webinterface en RC. Na HD51 reboot is dit weer in orde.

- Ik heb ook al eens voorgehad dat wanneer de HD51 hangt, er tegelijkertijd een probleem was op de vu+. Files browsen vanop PC was niet meer mogelijk. Stop/Start samba op de vu+ (via telnet) loste dat probleem op maar HD51 hangt dan nog steeds. Dit heeft zich enkele malen voorgedaan maar niet stelselmatig.

- HD51 reboot is dagelijks nodig ...



Re: Netwerk gerelateerde problemen #4 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 10:39

Ik heb de indruk (zonder dit echt te kunnen hard maken) dat de HD51 problemen zich voordoen na in stby te hebben gestaan voor een langere tijd.  Na een nachtje heb ik steeds prijs ....



Re: Netwerk gerelateerde problemen #5 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 10:42

Is er een manier om action logs aan te maken om te weten te komen waar de HD51 mee bezig is ( of op wacht)?



Re: Netwerk gerelateerde problemen #6 mimisiku

  • Senior Member
  • 1,564 posts

+20
Neutral

Posted 7 July 2018 - 11:00

Misschien heb je gewoon een 'rotte' HD51??? Wellicht een tukje kapot geheugen. 't Zal de eerste niet zijn.
VU+ Solo SE v2 Optus NZ

Re: Netwerk gerelateerde problemen #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,496 posts

+629
Excellent

Posted 7 July 2018 - 11:02

Dan is Enigma ergens mee bezig dan wel wacht ergens op. Dat kan best een hangende mount zijn, maar die moet op een gegeven moment wel in een timeout vallen. Dat is waarschijnlijk ook de oorzaak, als het gebeurd bij het opvragen van de file list.

 

Als het netwerk dan zelf nog wel werkt, kun je vanaf je PC met telnet (bv met PuTTY) inloggen op de box, en dan de volgende commando's geven:

init 4
ENIGMA_DEBUG_LVL=4 enigma2

dan start Enigma in de voorgrond en loopt de log over het scherm. Je kunt dan precies zien waar hij mee bezig is.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: Netwerk gerelateerde problemen #8 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 12:18

Dag WanWizard,

 

Ik ga proberen een trace te nemen de volgende keer dat hij hangt.

 

Uw vermoeden van een hangende mount is ook iets dat ik in gedachte had.

Vooral omdat ik access problemen gehad heb op mijn vu+ waarvoor een samba stop/start nodig was.

 

Met openpli 4.x heb ik (voor zover ik mij herinner) geen blokkerende samba meegemaakt. Dit heb ik enkel gezien met openpli 6.2.

 

Ik heb ook 1 keer gezien dat 'list' vanop hd51 (waar de locatie wees naar vu+) nog werkte, maar vanop de PC had ik geen explorer access meer naar de VU+.

Ook toen was dit opgelost met een samba stop/start op de vu+. 

Blijkbaar was samba toen maar gedeeltelijk gecrashed / hangend op de vu+....

 

BTW, de VU+ is ook minder stabiel met openpli6.2. 

Het is al een paar keer voorgevallen dat bij het afspelen van een opname opeens de box blokkeert, ook met een draaiend wieltje.

Ik weet zeker dat dit is voorgevallen tijdens afspelen over het netwerk.

Of het ook gebeurt bij het afspelen van HD kan ik niet met zekerheid zeggen.

Hierbij zit ik te denken in de richting van een memory leak omdat het probleem zich steeds heeft voorgedaan na verschillende dagen correct te hebben gedraaid.



Re: Netwerk gerelateerde problemen #9 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 20:54

In attachments vind je de log file van een error case.

 

Lijn 700 : go to stby

lijn 818 : power up.

 

Daartussen is een tijdspanne van iets meer dan 5 uren.

In deze periode gebeurt er iets waardoor er achteraf problemen zijn.



Re: Netwerk gerelateerde problemen #10 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 7 July 2018 - 21:02

Ditmaal met attachment

Attached Files



Re: Netwerk gerelateerde problemen #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,496 posts

+629
Excellent

Posted 7 July 2018 - 22:32

Wat heb je nu precies allemaal staan, en van waar naar waar heb je nu allemaal verbinding? En wat is van die verbindingen nu de server en de client?


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: Netwerk gerelateerde problemen #12 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 8 July 2018 - 09:44

10.0.0.25 : NAS

  <ip>10.0.0.25</ip>
  <sharename>dreambox1513RWDISKSTATION</sharename>
  <sharedir>dreamboxRW</sharedir>
  <ip>10.0.0.25</ip>
  <sharename>dreambox1513DISKSTATIONhd</sharename>
  <sharedir>dreamboxHD</sharedir>
  <ip>10.0.0.25</ip>
  <sharename>dreambox1513DVDDISKSTATION</sharename>
  <sharedir>dreamboxDVD</sharedir>
  <ip>10.0.0.25</ip>
  <sharename>dreambox1513DISKSTATIONsd</sharename>
  <sharedir>dreamboxSD</sharedir>
 

10.0.0.21 : VU+

  <ip>10.0.0.21</ip>
  <sharename>RecordingsVUDUO2</sharename>
  <sharedir>Recordings</sharedir>

 

10.0.0.20 : HD51



Re: Netwerk gerelateerde problemen #13 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 8 July 2018 - 11:17

In attachments vind je nog een trace van een foutgeval.
Als je 30' wacht nadat de HD51 in stby gaat, wie je dat er blijkbaar RTC problemen zijn.
Vanaf je dit ziet in de trace, heb je nadien het probleem met de hanging main thread.
 
MVG
 
**************************************************************************************************
 
 
[08/07/18 - 11:06:54:687] [ActionMap] Keymap 'StandbyActions' -> Action = 'power'
[08/07/18 - 11:06:54:687] [Standby] leave standby
...
[08/07/18 - 11:06:59:959] [ActionMap] Keymap 'InfobarActions' -> Action = 'showMovies'
[08/07/18 - 11:06:59:999] [eDVBServicePlay] timeshift
[08/07/18 - 11:06:59:999] [Skin] Processing screen: MovieSelection
[08/07/18 - 11:06:59:999] [Skin] Processing screen: MovieSelectionSummary
[08/07/18 - 11:07:04:286] [ActionMap] Keymap 'OkCancelActions' -> Action = 'cancel'
...
[08/07/18 - 11:07:19:563] [ActionMap] Keymap 'GlobalActions' -> Action = 'power_down'
[08/07/18 - 11:07:19:777] [Standby] enter standby
...
[08/07/18 - 11:07:25:814] [eDVBFrontend] close frontend 0
[08/07/18 - 11:37:22:826] [eDVBLocalTimerHandler] no transponder tuned... or no TDT/TOT avail .. try to use
[08/07/18 - 11:37:22:826]  RTC :)
[08/07/18 - 11:37:22:867] [eDVBLocalTimerHandler]    getRTC returned time=0. RTC problem?
[08/07/18 - 11:44:24:018] [ActionMap] Keymap 'StandbyActions' -> Action = 'power'
...
[08/07/18 - 11:44:42:911] [ActionMap] Keymap 'InfobarActions' -> Action = 'showMovies'
[08/07/18 - 11:44:42:952] [eDVBServicePlay] timeshift
[08/07/18 - 11:44:46:622] [gRC] main thread is non-idle! display spinner!
 

 

Attached Files



Re: Netwerk gerelateerde problemen #14 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 9 July 2018 - 12:33

Wat ik ook merk is dat samba op de VU+ om één of andere reden ook in de problemen komt als de HD51 begint te sputteren.

Samba stop/start is dan nodig op de VU+.



Re: Netwerk gerelateerde problemen #15 Erik Slagter

  • PLi® Core member
  • 42,835 posts

+462
Excellent

Posted 9 July 2018 - 20:06

Bij radertjes willen we ook altijd even de laatste 20 regels van de dmesg output hebben.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.


Re: Netwerk gerelateerde problemen #16 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 9 July 2018 - 20:58

Wat bedoel je met "de laatste 20 regels van de dmesg output " ?

De trace die ik heb gegeven was de volledige output (niet in geknipt of zo)



Re: Netwerk gerelateerde problemen #17 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 9 July 2018 - 23:13

Hi,

 

Attached you can find the requested info.

 

Kind Regards,

Pasquenel

Attached Files



Re: Netwerk gerelateerde problemen #18 catastrofus

  • Senior Member
  • 2,475 posts

+30
Good

Posted 10 July 2018 - 07:44

fs corrupt? (ext4_mb_generate_buddy)


Sorry, I'm a member of the "react above quote" community! :ph34r:

2 x et10k (CCCS. PLi-6.2-r) met een Synology ds214+ (2 x 6 TB) ziggo oost (voormalig @Home) + A1/A2/A3/HB (TechniSat)
 


Re: Netwerk gerelateerde problemen #19 pasquenel

  • Senior Member
  • 61 posts

0
Neutral

Posted 10 July 2018 - 18:18

executed e2fsck /dev/sda1 (harddisk) and reported clean ... 



Re: Netwerk gerelateerde problemen #20 Erik Slagter

  • PLi® Core member
  • 42,835 posts

+462
Excellent

Posted 10 July 2018 - 18:36

Wat bedoel je met "de laatste 20 regels van de dmesg output " ?

De trace die ik heb gegeven was de volledige output (niet in geknipt of zo)

- inloggen

- type "dmesg"

- laatste twintig regels copy & paste


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users