Jump to content


Photo

problem to build an image


  • Please log in to reply
3 replies to this topic

#1 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 24 July 2018 - 11:18

i try to build an image for dm800 i get this error :

 

NOTE: Your conf/bblayers.conf has been automatically updated.
NOTE: Your conf/bblayers.conf has been automatically updated.
NOTE: /home/blinkosm/openpli-oe-core/pli-extras/meta-fulan/recipes-core/glibc/glibc_2.23.bb: glibc doesn't build cleanly with -Os, adding -Wno-error to SELECTED_OPTIMIZATION
NOTE: /home/blinkosm/openpli-oe-core/pli-extras/meta-fulan/recipes-core/glibc/glibc-initial_2.23.bb: glibc-initial doesn't build cleanly with -Os, adding -Wno-error to SELECTED_OPTIMIZATION

 

and there is some links down like : ncurses.git

 

WARNING: libmpc-native-1.0.3-r0 do_fetch: Failed to fetch URL http://www.multiprec... <span>1</span>. tar.gz, attempting MIRRORS if available

 

 

 

 



Re: problem to build an image #2 betacentauri

  • PLi® Core member
  • 4,561 posts

+221
Excellent

Posted 24 July 2018 - 11:45

Notes and warnings can be ignored.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: problem to build an image #3 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 24 July 2018 - 12:04

Thanks

Re: problem to build an image #4 christophecvr

  • Senior Member
  • 3,131 posts

+139
Excellent

Posted 8 August 2018 - 10:05

ncurses is indeed the wrong URI.

The reason is quit simple . Since end of 2017 debian git did changed. the aloith debian still provided automated mirroring from the old UR5I's to the new ones. but the debian aloith server is broken sin March 2018

2 very important packages are concerned

 

1) ncurses

2) ca-certificate

 

and there could be more.

 

Take note that if you require very old ncurses maybe to build dm800 you will have to google around to find a mirror.

 

But for modern build who are using open-embedded version revision older then +- 28-03-2018 You just need to adapt the URI for ncurses from :

SRC_URI = "git://anonscm.debian.org/collab-maint/ncurses.git"

// to :

SRC_URI = "git://salsa.debian.org/debian/ncurses.git;protocol=https"

// for ca-certificates from :

SRC_URI = "git://anonscm.debian.org/collab-maint/ca-certificates.git"

// to

SRC_URI = "git://salsa.debian.org/debian/ca-certificates.git;protocol=https"

small note : openembedded after 28-03-2018 has the new uri's for debian packages.


Edited by christophecvr, 8 August 2018 - 10:08.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users