Jump to content


Photo

What version of Ubuntu should I use


  • Please log in to reply
6 replies to this topic

#1 bihsound

  • Member
  • 8 posts

0
Neutral

Posted 14 August 2018 - 15:36

Could you please tell me what version of Ubuntu should I use to cleanly compile the latest stable OpenPLi image from github?

 

I am a bit confused in regards to this. I see posts and tutorials mentioning all kinds of versions: 10.xx, 11.xx, 12.xx, 14.xx, 16.xx

 

What version is best to use as of today, to get the least amount of errors compiling the image as it is from github?

 

Thank you

 

 

 

 



Re: What version of Ubuntu should I use #2 Persian Prince

  • Senior Member
  • 1,602 posts

+219
Excellent

Posted 14 August 2018 - 16:50

I'm using ubuntu 18.04 LTS: https://github.com/P...-1804-lts-setup

For develop branch ;)
If you like my post click on green arrow :)

Re: What version of Ubuntu should I use #3 MiLo

  • PLi® Core member
  • 13,803 posts

+290
Excellent

Posted 14 August 2018 - 17:21

For older images I'd recommend 16 (LTS).

On current development, 18 should work fine. It'll probably work with older versions too, though you might run into things that you'll need to patch.
Real musicians never die - they just decompose

Re: What version of Ubuntu should I use #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 42,270 posts

+675
Excellent

Posted 14 August 2018 - 18:48

Or use CentOS in combination with devtoolsets. It allows you to pick devtoolset-4 for OpenPLi 4, devtoolset-6 for OpenPLi 6, and devtoolset-7 for develop.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: What version of Ubuntu should I use #5 catastrofus

  • Senior Member
  • 2,506 posts

+30
Good

Posted 14 August 2018 - 19:14

I build the development images, for an et10k & osmini, on an ubuntu server wiith 16.04 LTS.


Edited by catastrofus, 14 August 2018 - 19:15.

Sorry, I'm a member of the "react above quote" community! :ph34r:

2 x et10k (CCCS. PLi-6.2-r) met een Synology ds214+ (2 x 6 TB) ziggo oost (voormalig @Home) + A1/A2/A3/HB (TechniSat)
 


Re: What version of Ubuntu should I use #6 Budiarno

  • Senior Member
  • 49 posts

0
Neutral

Posted 15 August 2018 - 05:42

Attached File  Screenshot from 2018-08-15 11-40-29.png   24.04KB   1 downloads

 

I use Linux Mint 18.3 Cinnamon 64bit. So far so good.



Re: What version of Ubuntu should I use #7 bihsound

  • Member
  • 8 posts

0
Neutral

Posted 15 August 2018 - 19:49

Thank you all so much for your answers, really appreciate your help






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users