Jump to content


Photo

help please xml guide


  • Please log in to reply
21 replies to this topic

#1 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 20 August 2018 - 22:07

since a week i try make an epg for the french channels and i'm confused how many files i have to create Channels.xml sources.xml guide.xml and where i have to locate them and from where i 'll get the sources epg help please thankss



Re: help please xml guide #2 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 21 August 2018 - 08:15

This looks like IPTV.

Read this: https://forums.openp...-iptv-channels/

 

And since IPTV is mostly illegal, no furhter help can be provided.

You can have a look at this:  https://www.suls.co....a2-iptv-plugin/

 

Willy


Edited by doglover, 21 August 2018 - 08:15.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #3 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 21 August 2018 - 12:45

no i'm just looking for ordinary channels like W9 france 2.... no IPTV



Re: help please xml guide #4 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 21 August 2018 - 13:33

Sorry, I do not understand your problem.

Because for the regular channels obtained from sat, on some cable providers, on a enigma2 receivers, it is just a matter of installing EPGimport from the feed of the image.

Selecting the appropriate sources in the EPGimport plug-in.  And importing.

There are no files to be created.  For the sat at least (and for some cable providers) all the files are ready created.

 

If this does not work for you, start with telling what system, you are using.  Receiver, image.  Provider, etc....

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #5 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 21 August 2018 - 17:53

hi willy i read the FAQ and i try to upload EPG for france 2 but no success i need help please

 

Attached File  1_0_19_245A_440_1_C00000_0_0_0.jpg   90.43KB   0 downloadsAttached File  Capture.PNG   80.57KB   0 downloads

 

 

and here is the files in the attechements:

Attached Files



Re: help please xml guide #6 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 07:48

You are trying to make your own!!!

OK.

 

Change this to the france.sources.xml file

<?xml version="1.0" encoding="latin-1"?>
<sources>
<sourcecat sourcecatname="Own France XMLTV">
<source type="gen_xmltv" channels="/etc/epgimport/f2.channels.xml">
<description>France 2</description>
<url>/etc/epgimport/guide.xml</url>
</source>
</sourcecat>
</sources>

And do not forget to select you own source - Here France 2

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #7 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 13:07

hi willy i'm not trying do my own but i already selected the xmltv FRANCE in the epg import sources and 0 event and even with my owm france 2 still 0 event i got dm800 openpli4 i change epg location to config.misc.epgcache_filename=/media/usb/epg.dat

 

after 20 min and still 0 event as you can see in the image

 

 

Attached File  bnm.jpg   39.64KB   0 downloads


Edited by blinkosm, 22 August 2018 - 13:07.


Re: help please xml guide #8 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 14:29

The epg.dat has nothing to do with it.  It is only used tos tore EPG when you shut down the receiver.

EPG is stored into memory!!!!

 

A DM 800 has only OpenPLi2.1.  As this image is not updated anymore.  Probably the import does not work anymore.  (Too much cahnges not catered for in the image)

On a DM800 SE you install OpenPLi4.0.  This image is updated and should work.

 

You say you have OpenPLi 4.  So let's try to figure out what is wrong.

Restart your receiver (to clear anything previous imports) Perform a manual import, and request the log.

To obtain the log, when still in the import plug-in window, press menu on the remote.  Now proceed to the log.  You can save the log.  The file is then located in /tmp/ of your receiver.

Fish it out.  (use DCC or a direct mount on your PC) Post this log here.

Secondly post the rytec.sources.xml file from the /etc/epgimport/ folder.

 

One last question:  What is the date of the image you installed on your receiver?

Maybe it needs an update?

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #9 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 15:23

i upgrade the image to openpli 6.2 and here is the log:

 

 

Attached Files



Re: help please xml guide #10 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 15:35

How long did you wait before you asked the log.

If you did it immediately, wait 5 minutes.  And ask it again.

Or just ask the log now, if you did not restarted.

(The log is just the beginning, I need to see more)

 

Willy

 

I tried downloading the file mentioned in the log, and that is the correct file.  So that part is working.


Edited by doglover, 22 August 2018 - 15:39.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #11 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 15:44

There is no image for a DM800 or DM800SE.

So I wonder what you really have.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #12 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 15:46

here is the log of my own xml france 2:

 

 

Attached Files



Re: help please xml guide #13 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 15:49

There is no image for a DM800 or DM800SE.

So I wonder what you really have.

 

Willy

no, there's lately masterG and persian prince have made image for non supported boxes and i build this image myself

https://forums.openp...orted-receiver/

https://github.com/P...etas/pli-extras



Re: help please xml guide #14 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 16:00

 

There is no image for a DM800 or DM800SE.

So I wonder what you really have.

 

Willy

no, there's lately masterG and persian prince have made image for non supported boxes and i build this image myself

https://forums.openp...orted-receiver/

https://github.com/P...etas/pli-extras

 

 

after more than 5 min the log still the same and take a look at france2 log:

Attached Files



Re: help please xml guide #15 Pr2

  • PLi® Contributor
  • 2,865 posts

+119
Excellent

Posted 22 August 2018 - 16:00

The problem is that EPGimport change the compression algorithm it was using, we switch from gz to xz to have better compression rate.

So you need to install packages that support xz format on your old image and also update EPGimport to its very latest version.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.

If you think that my answer helps you, you can press the up arrow in bottom right the answer.

 

Octagon SF-4008: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W (+DVB-C)
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)
Amiko Viper Combo: 1*DVB-S2 + 1*DVB-C

Zgemma H7C: 1*DVB-S2 + 2*DVB-C


Re: help please xml guide #16 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 16:12

[EPGImport] failed to parse /etc/epgimport/f2.channels.xml Error: no element found: line 31, column 30

 

extra tag in the f2.channels.xml

 

remove <sources>

 

Willy


Edited by doglover, 22 August 2018 - 16:32.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #17 doglover

  • Rytec EPG Team
  • 12,030 posts

+349
Excellent

Posted 22 August 2018 - 16:30

The problem is that EPGimport change the compression algorithm it was using, we switch from gz to xz to have better compression rate.

So you need to install packages that support xz format on your old image and also update EPGimport to its very latest version.

 

Or alternatively try OpenATV:  http://images.mynonp...hp?open=dm800se

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: help please xml guide #18 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 16:44

The problem is that EPGimport change the compression algorithm it was using, we switch from gz to xz to have better compression rate.

So you need to install packages that support xz format on your old image and also update EPGimport to its very latest version.

in the download link they already xz



Re: help please xml guide #19 blinkosm

  • Senior Member
  • 118 posts

+1
Neutral

Posted 22 August 2018 - 16:48

it works thanks willy :) :) it working with retyc.sources and france2 source problem solve i think after editing in the plugin folder epgimport the file file epgdat_importer.py  and change the line tmppath = '/tmp' to tmppath = '/media/usb' so after the restart the epgdata still in drive



Re: help please xml guide #20 Pr2

  • PLi® Contributor
  • 2,865 posts

+119
Excellent

Posted 22 August 2018 - 16:54

 

The problem is that EPGimport change the compression algorithm it was using, we switch from gz to xz to have better compression rate.

So you need to install packages that support xz format on your old image and also update EPGimport to its very latest version.

in the download link they already xz

 

 

Of course but your version doesn't support them, so no unzip so 0 event loaded!


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.

If you think that my answer helps you, you can press the up arrow in bottom right the answer.

 

Octagon SF-4008: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W (+DVB-C)
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)
Amiko Viper Combo: 1*DVB-S2 + 1*DVB-C

Zgemma H7C: 1*DVB-S2 + 2*DVB-C





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users