Jump to content


Photo

Auto wakeup from deepstandby to standby

OpenPLI 6.2

  • Please log in to reply
19 replies to this topic

#1 Youpla

  • Senior Member
  • 25 posts

0
Neutral

Posted 26 August 2018 - 12:06

I configured sleep timers so that my device goes to deep standby at night, and then wakeup on morning. I did this because the DUO² stays hot even in standby mode (and it consumes power for nothing).

 

But instead of waking up to standby mode, it goes straight to active mode.

Any way to configure this ?


VU+ DUO²  - OpenPLI 6.2


Re: Auto wakeup from deepstandby to standby #2 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 26 August 2018 - 12:11

Why do you need the wake up in the first place?

However there is an option to startup the box in standby mode...
Maybe we should consider also to add this option in the sleep timer config. Now it is somewhere hidden in a menu

Edited by littlesat, 26 August 2018 - 12:13.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #3 Youpla

  • Senior Member
  • 25 posts

0
Neutral

Posted 26 August 2018 - 12:32

I want to wake up because I don't want to wait for my device to boot when I need it. Ideally I would leave it in standby mode all the time, if it wasn't for the heat.

 

 

I already tried the option you are talking about (system -> setup ->  customize -> startup to standby), but this morning my device woke up in normal mode (although the option works when booting manually).


VU+ DUO²  - OpenPLI 6.2


Re: Auto wakeup from deepstandby to standby #4 Trial

  • Senior Member
  • 956 posts

+29
Good

Posted 26 August 2018 - 17:50

Hi,

I think the solution is more or less easy.  Create a zap timer with the OpenWebIF. There it is possible to set the after event state for zap timer directly. I do not know if it still works.

 

ciao



Re: Auto wakeup from deepstandby to standby #5 Youpla

  • Senior Member
  • 25 posts

0
Neutral

Posted 28 August 2018 - 22:55

Hi,

I think the solution is more or less easy.  Create a zap timer with the OpenWebIF. There it is possible to set the after event state for zap timer directly. I do not know if it still works.

 

ciao

 

It's more a workaround than a solution, but thanks anyway for the idea.

 

Did anybody manage to set a wake-up to deep standby timer ?


VU+ DUO²  - OpenPLI 6.2


Re: Auto wakeup from deepstandby to standby #6 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 06:41

Wake up before using it also uses energy... and the box will boot within a minute or so...

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #7 Pr2

  • PLi® Contributor
  • 3,368 posts

+146
Excellent

Posted 29 August 2018 - 09:57

Hi,

 

Youpla is correct this is clearly a bug, I have done many test and here is how it works today.

 

I defined a wake-up timer and put the Zgemma H7C into deep standby.

2 minutes before the scheduled wake up time the box start itself and is put into Standy (which is nice), the earlier startup is nice because it ensure that at the specified time the box is fully ready.

 

So the box is in standy (what is expected) but at the precise schedule time the box wakeup itself without taking care of the wake in standby parameter.

 

So this is clearly a bug because I second Youpla in its approach of using wakeup timer, I never use it because I also want that my box start immediately when I press the button.

If this option is fixed I will also consider to put my box into deep-standby.

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Auto wakeup from deepstandby to standby #8 Pr2

  • PLi® Contributor
  • 3,368 posts

+146
Excellent

Posted 29 August 2018 - 10:04

Hi,

 

Ticket created:

 

https://devtools.ope....org/issues/361

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Auto wakeup from deepstandby to standby #9 Youpla

  • Senior Member
  • 25 posts

0
Neutral

Posted 29 August 2018 - 12:44

It's definitely a bug. I tried the tip given in the screenshot below (which is supposed to fix my exact problem) and it doesn't work.

 

QprIOdZ.jpg


Edited by Youpla, 29 August 2018 - 12:44.

VU+ DUO²  - OpenPLI 6.2


Re: Auto wakeup from deepstandby to standby #10 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 12:56

Sorry I don't understand the issue....


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #11 Pr2

  • PLi® Contributor
  • 3,368 posts

+146
Excellent

Posted 29 August 2018 - 13:20

The issue is very simple:

 

There is an option that specify the OpenPLi state when it starts.

If enabled OpenPLi is supposed to stay in standby mode (for exemple after a power outage, a crash, an init 4/init 3,...)

 

When you use Deep-standby  you expect that this parameter is properly taken into account.

So when waking up from deep-standby with a timer (as foreseen by default) I expect my mox to stay in standby until I use the remote control to turn it on.

 

This is not the case!  The box start itself 2 minutes before the defined time to be fully ready at the specified time (this is really nice) and stay in standby (until there that's what we expect).  But some some reason at the precise wake-up time the box turn itself on.

This is not the expected behavior since we explicitly ask that it always start into standby.

 

We want that the box wake-up from the deep standby at the specified time, not at it start playing a service and turn on the TV (if HDMI-CEC is enabled).

 

Please check the ticket on devtools I have explained how to reproduce the bug.

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Auto wakeup from deepstandby to standby #12 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 13:24

Could also be bug depended... as for some boxes it cannot be predicted if it was a wakeup on timer -or- a manual wakeup....


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #13 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 13:25

Sounds like someone need a huge amount of time to find the cullpit here....

But you say the box booted 2 min before and goes to standby and than wakes up again later... First we really need some log data...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #14 Pr2

  • PLi® Contributor
  • 3,368 posts

+146
Excellent

Posted 29 August 2018 - 14:28

Hi have understood what the logic was when creating this wakeup screen:

The screen was designed for people that want to be awake by the TV!  It was not designed just to "wake up the stb" from the deep-standby.

 

So in fact, what is missing is an option to just wake up the box from deep-standby.

 

But yes I can confirm for sure that it 1st it goes into standby and then wake up so there are 2 timers involved, the 1st one is sent to the front-end (it seems to me that it is define 2 minutes before the real timer) and another one, I think within OpenPLi that this time turn on the the box. 


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Auto wakeup from deepstandby to standby #15 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 14:40

It should be caused by the timer spaghetti code in RecordTimer.py... And because it is not easy to create log data after a reboot difficult to troubleshoot. It might even be triggered by one of the latest changes in the code here.


Edited by littlesat, 29 August 2018 - 14:41.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #16 Dimitrij

  • PLi® Core member
  • 6,417 posts

+208
Excellent

Posted 29 August 2018 - 14:55

When use wakeup timer --> "Yes, only from deep standby"/"yes" and not wakeup TV:

don't use option "Regard deep standby as standby" HDMI-CEC setup

or

option "Startup to Standby"  use "No, except Wakeup timer"


Formuler1/VU+solo4k(thanks guys to gisclub.tv)


Re: Auto wakeup from deepstandby to standby #17 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 15:14

Indeed except should keep it...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #18 Pr2

  • PLi® Contributor
  • 3,368 posts

+146
Excellent

Posted 29 August 2018 - 15:24

When use wakeup timer --> "Yes, only from deep standby"/"yes" and not wakeup TV:
don't use option "Regard deep standby as standby" HDMI-CEC setup
or
option "Startup to Standby"  use "No, except Wakeup timer"

 
Sorry but I need to set: Regard deep standby as standby otherwise when I go in the menu and choose Deep standby my TV stay on which is not what I expect.

Yes the parameter you mention: option "Startup to Standby"  use "No, except Wakeup timer" should do its job but it doesn't seem to at least when I test it.

Anyway my choice is:  "Startup to Standby" : "Yes"

Since I often update my box remotely from telnet I don't want the box to be on after restart.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Auto wakeup from deepstandby to standby #19 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 15:38

Sounds like a new option needs to be added....


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto wakeup from deepstandby to standby #20 littlesat

  • PLi® Core member
  • 47,580 posts

+497
Excellent

Posted 29 August 2018 - 15:41

This is the inital commit of this feature...

https://github.com/O...7872b6c6fe2d13a

Sounds like we need to add an option always... and when we check yes also include always.... or something like that...


Edited by littlesat, 29 August 2018 - 15:43.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W






Also tagged with one or more of these keywords: OpenPLI 6.2

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users