Jump to content


Photo

Crash with 4K channels


  • Please log in to reply
5 replies to this topic

#1 wawa16

  • Member
  • 7 posts

0
Neutral

Posted 27 November 2018 - 20:44

When installing any skin on the image openpli 7 After When you run 4K channels, a crash occurs ......  Vu+ zero 4k

 

I processed the problem by modifying the file  ( ServiceInfoEX.py )

 

Please fix the problem in the future

 

Thank you........

 

 

 

 

Attached Files



Re: Crash with 4K channels #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 27 November 2018 - 20:46

Can you just post the log files next time, so I don't have to install rar to look at them? 


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Crash with 4K channels #3 Taapat

  • PLi® Core member
  • 1,721 posts

+71
Good

Posted 27 November 2018 - 20:53

Traceback (most recent call last):
  File "/usr/lib/enigma2/python/Navigation.py", line 69, in dispatchEvent
  File "/usr/lib/enigma2/python/Components/PerServiceDisplay.py", line 17, in event
  File "/usr/lib/enigma2/python/Components/Sources/CurrentService.py", line 26, in serviceEvent
  File "/usr/lib/enigma2/python/Components/Element.py", line 86, in changed
  File "/usr/lib/enigma2/python/Tools/CList.py", line 7, in __call__
  File "/usr/lib/enigma2/python/Components/Converter/ServiceInfoEX.py", line 372, in changed
    Converter.changed(self, what)
  File "/usr/lib/enigma2/python/Components/Element.py", line 86, in changed
  File "/usr/lib/enigma2/python/Tools/CList.py", line 7, in __call__
  File "/usr/lib/enigma2/python/Components/Renderer/Label.py", line 24, in changed
  File "/usr/lib/enigma2/python/Components/Element.py", line 15, in wrapper
  File "/usr/lib/enigma2/python/Components/Converter/ServiceInfoEX.py", line 215, in getText
    self.stream['vtype'] = ('MPEG2', 'MPEG4', 'MPEG1', 'MPEG4-II', 'VC1', 'VC1-SM', '')[info.getInfo(iServiceInformation.sVideoType)]
IndexError: tuple index out of range

ServiceInfoEX.py is an external component that does not support 4K channel encoding.

So fix requires in ServiceInfoEX.py instead of something in Openpli image.


Edited by Taapat, 27 November 2018 - 20:54.


Re: Crash with 4K channels #4 littlesat

  • PLi® Core member
  • 47,854 posts

+499
Excellent

Posted 27 November 2018 - 20:58

This is not related to openpli but by a bug in a converter from your skin. Your skin converter ServiceInfoEx is not aware of 4K resolution... This can happen with skins that add their own converters... I would recommend to use the standard skin and try again. Did you download your skin from our feeds? If so let us know which skin so we can remove it. Or maybe the skin should change to the normal ServiceInfo renderer... including python code in skins is waiting for problems...

Edited by littlesat, 27 November 2018 - 21:16.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Crash with 4K channels #5 wawa16

  • Member
  • 7 posts

0
Neutral

Posted 27 November 2018 - 21:20

For standard skin work perfect 100%

No
Other external skin..download from other forum



Re: Crash with 4K channels #6 littlesat

  • PLi® Core member
  • 47,854 posts

+499
Excellent

Posted 27 November 2018 - 21:22

The skin from the other forum is ancient it does not know hevc encoding (and probably more).... it needs an update or swap to the standaard converters that are already included in the image

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users