Jump to content


Photo

some key delays with installed HBBTV on uno4kse


  • Please log in to reply
19 replies to this topic

#1 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 22 December 2018 - 11:19

I´ve seen a little problem after installing HBBTV openpli7.0rc with uno4kse

 

the HBBTV works fine, If installed the webkithbbtv 1.1-20170105.r0.0)

 

After zapping to a hbbtv channel and receiving the video and audio there is a little delay after pressing a key on the remote control. I think the reason maybe that the hbbtv plugin makes some actions on the channel with hbbtv and  blocks  the enigma process therefor.

 

Is that possible?

 

Do you think this delay can be optimize in future are is there noch chance?

 

 


Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 22 December 2018 - 17:30

Unfortunately, HbbTV browsers are supplied by the manufacturer (in this case VU+) as a binary package, we don't have any control over it, it either works, or it doesn't.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: some key delays with installed HBBTV on uno4kse #3 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 19:56

Today I´ve made some additional tests with HBBTV on my unok4se. I told you I see a delay in the reaction of remote control keys after switching to an HBBTV channel. 

The reason is that the hbbtc plugin gets an callback from channelswitching if hbbtv is on that channel, The plugin would like to detect the hbbt items to build the menu entries.

But this action blocks enigma

 

Now I have made some code changes to the /usr/lib/enigma2/python/Plugins/Extensions/WebkitHbbTV/plugin,py. My idea was that detecting the hbbt items for build to menu entries is only need if a user would like to use the hbbtv. After the code changes there is no delay by using the box in normal mode. But if I press the blue key for the menu hbbt or long the red key the hbbty plugin now scans the channel for the hbbts items and build the menu entries. That works much better and for me know ok.

 

Here are the lines which I have changed. I´ve comment out the get:autostart:application() that produces the delay by every channel switch

	def _cb_ait_detected(self):
		vbcfg.g_channel_info = None
		self._applicationList = None
#		self._app_info = self.get_autostart_application()
		vbcfg.DEBUG("detected AIT")

and 

 

here the line 2,3,4 are new

1	def menu_hbbtv_applications(self):
2		vbcfg.g_channel_info = None
3		self._applicationList = None
4		self._app_info = self.get_autostart_application()
5               applications = []
6		if self._applicationList is not None:
7			for x in self._applicationList:
8				applications.append((x["name"], x))
9		else:
10			applications.append((_("No detected HbbTV applications."), None))
11		self.session.openWithCallback(self.start_application_selected, ChoiceBox, title=_("Please choose an HbbTV application."), list=applications)

if you like you can merge this changes to you git


Edited by anudanan, 30 December 2018 - 19:59.

Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #4 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 20:17

One more optimization. Now the delay is only there, if you enter the first time HBBTV on a channel

 

Only the lines 2,3 are new in difference to the original one. Thar work better than my changes in the last post

1	def menu_hbbtv_applications(self):
2		if self._applicationList is None:
3			self._app_info = self.get_autostart_application()
4		applications = []
5		if self._applicationList is not None:
6			for x in self._applicationList:
7				applications.append((x["name"], x))
8		else:
9			applications.append((_("No detected HbbTV applications."), None))
10		self.session.openWithCallback(self.start_application_selected, ChoiceBox, title=_("Please choose an HbbTV application."), list=applications)


Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 30 December 2018 - 20:21

This isn't in our git, it is in the BSP repo which is maintained by VU+, we don't have write access to it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: some key delays with installed HBBTV on uno4kse #6 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 20:27

Thanks for that info.

 

I will report that in the VTI forum. Hopefully they can give that idea to VU

 

I will change these line by hand for my installation here and do it again if I will update in future


Edited by anudanan, 30 December 2018 - 20:30.

Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #7 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 30 December 2018 - 22:37

Better create a pull request in github.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: some key delays with installed HBBTV on uno4kse #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 30 December 2018 - 22:41

I wonder if that is possible. afaik the hbbtv stuff is pulled in in binary from VU's ftp server.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: some key delays with installed HBBTV on uno4kse #9 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 22:42

Where exactly? I‘m not so familiar with the different repros there

Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #10 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 22:44

In the WebKit Extension Plugin directory there are files in Python source code

Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 30 December 2018 - 22:49

On the box, yes.

 

According to the recipe, the data comes from a non-public VU+ git repo: https://github.com/O...-gtk_git.bb#L22


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: some key delays with installed HBBTV on uno4kse #12 athoik

  • PLi® Core member
  • 7,840 posts

+288
Excellent

Posted 30 December 2018 - 22:52

I think he refers to this: https://github.com/O...-webkithbbtv.bb
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: some key delays with installed HBBTV on uno4kse #13 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 30 December 2018 - 22:53

Is it possible to make a pull request on a non public repro?

Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,690 posts

+766
Excellent

Posted 30 December 2018 - 23:16

I think he refers to this: https://github.com/O...-webkithbbtv.bb

 

Ah, ok. That is a tarball which is pulled in, not even a repo.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: some key delays with installed HBBTV on uno4kse #15 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 31 December 2018 - 00:28

So no it’s not possible. Tar file is on VU server and not in the git.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: some key delays with installed HBBTV on uno4kse #16 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 31 December 2018 - 12:00

So the only why to get a fix in the tar file is to inform VTI and they inform VU? Or is there a better way to do that?

 

Or can you patch the tarfile with a fixed version of plugin.py?


Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #17 Erik Slagter

  • PLi® Core member
  • 45,155 posts

+495
Excellent

Posted 31 December 2018 - 12:55

(TS) you will find that either Kodi or HbbTV implementations for all vendors are both at least partly closed source and also implemented poorly, which makes supporting it in OpenPLi hard in various ways.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: some key delays with installed HBBTV on uno4kse #18 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 31 December 2018 - 13:06

Yes, you are right, the implemtations are poor ;-)

 

happy new year


Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX


Re: some key delays with installed HBBTV on uno4kse #19 Erik Slagter

  • PLi® Core member
  • 45,155 posts

+495
Excellent

Posted 31 December 2018 - 13:13

They tend to implement just about enough to be able to support their claim for support and anything more than that. It's frustrating for us. For every new version of OpenPLi we struggle and fight to yet again get it all working. There will be a moment, though, where we can't workaround any more and we either must drop support for those for certain vendors or the vendor must fix their product.


Edited by Erik Slagter, 31 December 2018 - 13:14.

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: some key delays with installed HBBTV on uno4kse #20 anudanan

  • Senior Member
  • 976 posts

+14
Neutral

Posted 31 December 2018 - 13:17

For myelf it is ok, I have a solution for me.

 

Other users may edit this plugin if they have also problems


Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 50PS8000, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users