Jump to content


Photo

Transparantie probleem PliFullHD

Skin

  • Please log in to reply
31 replies to this topic

#1 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 30 December 2018 - 14:06

Hoi,

 

Ik ben weer eens aan het 'skinnen' gegaan. Ik kwam ergens een opmerking van WanWizzard tegen over de afwijkende skin van de movieplayer, ik vond dat dat ie daar wel een punt had. Het past gewoon niet goed bij het skin thema. Nou ja, toch maar geprobeerd om er wat van te maken. En het is me eerlijk gezegt al aardig gelukt, echter heb ik problemen met versneld spoelen symbolen. In de skin.xml heet de screen PVRstate. Het vreemde is dat deze skin tevens de playerinfobar screen tevoorschijn tovert, maar dat is in de skin niet te vinden en dat gebeurt klaarblijkelijk in python.

Het werkelijke probleem zit het nu in het feit dat als ik de PVRstate op de infobar projecteer wordt de achtergrond weer transparant, als ik transparence weg haal wordt het blokje volledig gedekt zwart, eigenlijk wil ik de PVRstate in de infobar verwerken waarbij de infobar behouden wordt.

 

Dit is de code:

 

 

 <!-- PVR State -->
 <screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent" zPosition="2" flags="wfNoBorder">
  <widget name="state" position="0,0" size="225,45" backgroundColor="transparent" borderWidth="2" font="Regular;37" borderColor="black" halign="left"/>
 </screen>

 

 

Attached File  screenshot player.png   213.25KB   22 downloads

 

Attached File  screenshot player2.png   293.23KB   12 downloads



Re: Transparantie probleem PliFullHD #2 Loui (PD1LOI)

  • Senior Member
  • 2,850 posts

+61
Good

Posted 30 December 2018 - 15:21

Hoi,

 

Ik ben weer eens aan het 'skinnen' gegaan. Ik kwam ergens een opmerking van WanWizzard tegen over de afwijkende skin van de movieplayer, ik vond dat dat ie daar wel een punt had. Het past gewoon niet goed bij het skin thema. Nou ja, toch maar geprobeerd om er wat van te maken. En het is me eerlijk gezegt al aardig gelukt, echter heb ik problemen met versneld spoelen symbolen. In de skin.xml heet de screen PVRstate. Het vreemde is dat deze skin tevens de playerinfobar screen tevoorschijn tovert, maar dat is in de skin niet te vinden en dat gebeurt klaarblijkelijk in python.

Het werkelijke probleem zit het nu in het feit dat als ik de PVRstate op de infobar projecteer wordt de achtergrond weer transparant, als ik transparence weg haal wordt het blokje volledig gedekt zwart, eigenlijk wil ik de PVRstate in de infobar verwerken waarbij de infobar behouden wordt.

 

Dit is de code:

 

 

 <!-- PVR State -->
 <screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent" zPosition="2" flags="wfNoBorder">
  <widget name="state" position="0,0" size="225,45" backgroundColor="transparent" borderWidth="2" font="Regular;37" borderColor="black" halign="left"/>
 </screen>

 

 

attachicon.gifscreenshot player.png

 

attachicon.gifscreenshot player2.png

Probeer deze code eens.

 

<screen name="PVRState" position="147,880" size="225,195" backgroundColor="transparent" zPosition="2" flags="wfNoBorder">
    <widget name="state" position="0,0" size="225,195" backgroundColor="transparent" borderWidth="2" font="Regular;37" borderColor="black" halign="left" />
  </screen>

Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli v7.0. 

Bereikbaar op BM 204 NL-DMR


Re: Transparantie probleem PliFullHD #3 Loui (PD1LOI)

  • Senior Member
  • 2,850 posts

+61
Good

Posted 30 December 2018 - 15:28

Stuur anders mij de hele code van jou mediaplayer (Movieplayer).


Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli v7.0. 

Bereikbaar op BM 204 NL-DMR


Re: Transparantie probleem PliFullHD #4 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 30 December 2018 - 16:35

@Loui,

 

Ik heb mijn hele userskin naar je PM gestuurt.



Re: Transparantie probleem PliFullHD #5 Loui (PD1LOI)

  • Senior Member
  • 2,850 posts

+61
Good

Posted 31 December 2018 - 09:24

Ik denk dat dit probleem toch even door de experts moet worden beantwoord. Wij (ik) prutsers komen hier niet uit. ;)  :)


Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli v7.0. 

Bereikbaar op BM 204 NL-DMR


Re: Transparantie probleem PliFullHD #6 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 31 December 2018 - 12:38

Hoi Loui,

 

Ik heb ondertussen zelf een work-a-round bedacht, die natuurlijk alleen voor mijn eigen skin een oplossing is.

 

 

<!-- PVR State -->
 <screen name="PVRState" position="20,978" size="200,45" flags="wfNoBorder">
   <widget name="state" position="0,0" size="200,45" backgroundColor="#2d101214" borderWidth="2" font="Regular;37" borderColor="black" halign="left"/>
 </screen>

 

De BackgroundColor van het speedvakje heeft nu dezelfde kleur en transparantie als de rest van de infobalk, zodat je het niet ziet. Ik geloof nog steeds niet dat er normaal gesproken 2 screens tegelijkertijd actief kunnen zijn.



Re: Transparantie probleem PliFullHD #7 Loui (PD1LOI)

  • Senior Member
  • 2,850 posts

+61
Good

Posted 31 December 2018 - 17:35

Ik ga na het nieuwe jaar eens duiken in dit item, fijne jaarwisseling voor allen daar.

Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli v7.0. 

Bereikbaar op BM 204 NL-DMR


Re: Transparantie probleem PliFullHD #8 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 10 January 2019 - 07:21

Is dit op te lossen met een ConditionalShowHide binnen de Playerscreen?

Re: Transparantie probleem PliFullHD #9 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 10 January 2019 - 07:22

Euh bedoelde Moviescreen.

Re: Transparantie probleem PliFullHD #10 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 10 January 2019 - 11:56

Try this but i have not test.

 

 

 

<widget name="state" position="0,0" size="200,45" backgroundColor="#2d101214" borderWidth="2" font="Regular;37" borderColor="black" halign="left" transparent="1"/>

 

of this

 

<widget name="state" position="0,0" size="225,45" backgroundColor="transparent" borderWidth="2" font="Regular;37" borderColor="black" halign="left"  transparent="1"/>

 

and this if on movieplayer background

 

<widget name="state" position="0,0" size="225,45" backgroundColor="transparent" borderWidth="2" font="Regular;37" borderColor="black" halign="left"  zPosition="10"  transparent="1"/>


Edited by Matrix10, 10 January 2019 - 12:01.


Re: Transparantie probleem PliFullHD #11 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 10 January 2019 - 12:04

you have to remove backgroundColor="transparent" or use not transparent color example transpblack backgroundColor="#10000000"

 

 

like this

 

<widget name="state" position="0,0" size="225,45"  backgroundColor="#10000000"  borderWidth="2" font="Regular;37" borderColor="black" halign="left"  transparent="1"/>

 

and this if on movieplayer background

 

<widget name="state" position="0,0" size="225,45"  backgroundColor="#10000000"  borderWidth="2" font="Regular;37" borderColor="black" halign="left"  zPosition="10"  transparent="1"/>


Edited by Matrix10, 10 January 2019 - 12:08.


Re: Transparantie probleem PliFullHD #12 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 11 January 2019 - 18:27

@Matrix,

 

I tried out all your options, sorry to tell but they all lead to the same result.

 

Attached File  optie1.png   456.93KB   5 downloads

 

I think the problem is the fact that 2 seperate screens are projected over each other. This is an exeption in Enigma construction, it never happens only in this case.

I seems it handels transparency like 1+1=2 and 1+0=0. Do not forget the black smoke in PliFullHD is a picture with tranparency.

 



Re: Transparantie probleem PliFullHD #13 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 12 January 2019 - 11:29

@Matrix,

 

I tried out all your options, sorry to tell but they all lead to the same result.

 

attachicon.gifoptie1.png

 

I think the problem is the fact that 2 seperate screens are projected over each other. This is an exeption in Enigma construction, it never happens only in this case.

I seems it handels transparency like 1+1=2 and 1+0=0. Do not forget the black smoke in PliFullHD is a picture with tranparency.

 

Can you give me the image version
and the full name of the skin in skins download ?
I installed RC7 but I do not get that movie player.


Re: Transparantie probleem PliFullHD #14 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 12 January 2019 - 11:38

I installed the image on a multiboot but the movie player is completely transparent with 

PD1LOI PliFullHD

 

You have test this ???

 

 <screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent" zPosition="2" flags="wfNoBorder">

  <widget name="state" position="0,0" size="225,45"  backgroundColor="#10000000"  font="Regular;37"  halign="left"  transparent="1"/>
 </screen>

Edited by Matrix10, 12 January 2019 - 11:42.


Re: Transparantie probleem PliFullHD #15 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 12 January 2019 - 22:41

Ah listen, this my own skinned version of PliFullHD skin.
It's based on standard PliFullHD i adapt with userskin.
I'll send tot PM

Re: Transparantie probleem PliFullHD #16 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 13 January 2019 - 02:33

Ah listen, this my own skinned version of PliFullHD skin.
It's based on standard PliFullHD i adapt with userskin.
I'll send tot PM

 

I sent an answer
The only way in this case is to use the background
pixmap of the same color and transparency as movieplayer background.
 
<screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent"  flags="wfNoBorder">
                <ePixmap position="0,0" size="225,45" pixmap="/var/etc/enigma2/Graphics2skin/pvrbg.png" zPosition="11" alphatest="off" />
<widget name="state" position="0,0" size="225,45" backgroundColor="#10000000"  font="Regular;37" zPosition="12" halign="left" transparent="1"/>
</screen>
 
of course your option is also possible
but the problem is finding good transparency
 
<screen name="PVRState" position="20,978" size="200,45" flags="wfNoBorder">
   <widget name="state" position="0,0" size="200,45" backgroundColor="#2d101214" borderWidth="2" font="Regular;37" borderColor="black" halign="left"/>
 </screen>

Edited by Matrix10, 13 January 2019 - 02:37.


Re: Transparantie probleem PliFullHD #17 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 13 January 2019 - 08:58

Hey Metrix10,

 

Thanks I tried the widget code 'speed' in movieplayerscreen but it does nothing.

 

tried your code:

 

 

<screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent"  flags="wfNoBorder">
                <ePixmap position="0,0" size="225,45" pixmap="/var/etc/enigma2/Graphics2skin/pvrbg.png" zPosition="11" alphatest="off" />
<widget name="state" position="0,0" size="225,45" backgroundColor="#10000000"  font="Regular;37" zPosition="12" halign="left" transparent="1"/>
</screen>

 

result:

Attached File  p12.png   606.44KB   0 downloads

 

So now I use my own solution although it's not universal i'm satisfied for now.


Edited by hulkman, 13 January 2019 - 08:59.


Re: Transparantie probleem PliFullHD #18 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 13 January 2019 - 11:32

You did not try what I have sent you in the ZIP file.

On your picture is missing a png file ?? from my zip.

 

<screen name="PVRState" position="20,987" size="225,45" backgroundColor="transparent"  flags="wfNoBorder">
                <ePixmap position="0,0" size="225,45" pixmap="/var/etc/enigma2/Graphics2skin/pvrbg.png" zPosition="11" alphatest="off" />
<widget name="state" position="0,0" size="225,45" backgroundColor="#10000000"  font="Regular;37" zPosition="12" halign="left" transparent="1"/>
</screen>

Edited by Matrix10, 13 January 2019 - 11:34.


Re: Transparantie probleem PliFullHD #19 hulkman

  • Senior Member
  • 442 posts

+5
Neutral

Posted 13 January 2019 - 11:51

Ok Matrix10 i missed that part.

 

However it's pretty much the same solotion as mine. You making a new background with picture. I'm using a black box with transparency. As the background of the skin in this part of the skin is equal my solution is good enough for me.

 

When the background is an complex picture one should consider cutting this part out of the skin-picture en re-inster it as an background as it can be your solution.

 

All the way both are work-arounds, in mine opinion the PVR state screen should be independed from MoviePlayerScreen skin builder kan use template Playerscreen at will. This solution is made before skins were able to use templates (2016-2017 ????)



Re: Transparantie probleem PliFullHD #20 Matrix10

  • Senior Member
  • 302 posts

+23
Neutral

Posted 13 January 2019 - 12:13

Ok Matrix10 i missed that part.

 

However it's pretty much the same solotion as mine. You making a new background with picture. I'm using a black box with transparency. As the background of the skin in this part of the skin is equal my solution is good enough for me.

 

When the background is an complex picture one should consider cutting this part out of the skin-picture en re-inster it as an background as it can be your solution.

 

All the way both are work-arounds, in mine opinion the PVR state screen should be independed from MoviePlayerScreen skin builder kan use template Playerscreen at will. This solution is made before skins were able to use templates (2016-2017 ????)

 

 

Exactly.
 
There are different ways to Rome....
 
If I remember well
OE-A images coding has both possibilities
for movieplayer speeds,PVRstate and speed within movieplayer coding.






Also tagged with one or more of these keywords: Skin

4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users