Jump to content


Photo

creating release-4 build environment failed


  • Please log in to reply
7 replies to this topic

#1 kallquk

  • Member
  • 18 posts

0
Neutral

Posted 7 January 2019 - 15:16

Hello,

 

 

I have a dm800se with openpli4, and works ok.

 

Now I am trying to create a build environment on pc centos7 64bit.

 

It is successful for latest git, but I d not want that, because: 1) It has not MACHINE=dm800se, (it is clear that latest openplis are not supported in this box), 2) I want the same  environment on pc as version image on box.

 

So, I tried to do the same with release-4, but it fails:

 

-bash-4.2$ pwd
/opt/openpli4
-bash-4.2$ git clone  --branch release-4 https://github.com/O...pli-oe-core.git
Cloning into 'openpli-oe-core'...
remote: Enumerating objects: 12, done.
remote: Counting objects: 100% (12/12), done.
remote: Compressing objects: 100% (10/10), done.
remote: Total 27195 (delta 4), reused 8 (delta 2), pack-reused 27183
Receiving objects: 100% (27195/27195), 45.56 MiB | 1011.00 KiB/s, done.
Resolving deltas: 100% (17543/17543), done.
-bash-4.2$ ls
openpli-oe-core
-bash-4.2$ cd openpli-oe-core
-bash-4.2$ make
[ -d /opt/openpli4/openpli-oe-core/meta-openembedded/meta-oe ] || make  update
make[1]: Entering directory `/opt/openpli4/openpli-oe-core'
Updating Git repositories...
Already up-to-date.
Submodule 'bitbake' (git://git.openembedded.org/bitbake) registered for path 'bitbake'
Submodule 'meta-edision' (http://github.com/op...eta-edision.git) registered for path 'meta-edision'
Submodule 'meta-formuler' (https://github.com/f...ta-formuler.git) registered for path 'meta-formuler'
Submodule 'meta-gi-4' (http://github.com/GI...m/meta-gi-4.git) registered for path 'meta-gi-4'
Submodule 'meta-hd' (https://github.com/H...tal/meta-hd.git) registered for path 'meta-hd'
Submodule 'meta-miraclebox' (http://github.com/mi...-miraclebox.git) registered for path 'meta-miraclebox'
Submodule 'meta-openembedded' (git://git.openembedded.org/meta-openembedded) registered for path 'meta-openembedded'
Submodule 'meta-openpli/recipes-openpli/e2openplugins' (git://github.com/E2OpenPlugins/e2openplugins.git) registered for path 'meta-openpli/recipes-openpli/e2openplugins'
Submodule 'meta-sab' (http://github.com/ma...r2/meta-sab.git) registered for path 'meta-sab'
Submodule 'meta-spycat' (https://github.com/o...meta-spycat.git) registered for path 'meta-spycat'
Submodule 'meta-vuplus' (http://github.com/vu...meta-vuplus.git) registered for path 'meta-vuplus'
Submodule 'meta-wetek' (http://github.com/we.../meta-wetek.git) registered for path 'meta-wetek'
Submodule 'meta-xp' (https://github.com/X...ter/meta-xp.git) registered for path 'meta-xp'
Submodule 'meta-xpeedc-4' (http://github.com/Xp...ta-xpeedc-4.git) registered for path 'meta-xpeedc-4'
Submodule 'meta-xsarius' (https://github.com/p...eta-xsarius.git) registered for path 'meta-xsarius'
Submodule 'meta-xtrend-4' (http://github.com/XT...ta-xtrend-4.git) registered for path 'meta-xtrend-4'
Submodule 'meta-zgemma-4' (http://github.com/zg...ta-zgemma-4.git) registered for path 'meta-zgemma-4'
Submodule 'openembedded-core' (git://git.openembedded.org/openembedded-core) registered for path 'openembedded-core'
Cloning into 'bitbake'...
remote: Counting objects: 51174, done.
remote: Compressing objects: 100% (14503/14503), done.
remote: Total 51174 (delta 38632), reused 46904 (delta 35217)
Receiving objects: 100% (51174/51174), 10.78 MiB | 1.62 MiB/s, done.
Resolving deltas: 100% (38632/38632), done.
Submodule path 'bitbake': checked out '207013b6dde82f9654f9be996695c8335b95a288'
Cloning into 'meta-edision'...
Username for 'http://github.com': kallquk
Password for 'http://kallquk@github.com':
remote: Repository not found.
fatal: repository 'http://github.com/op...ta-edision.git/' not found
Clone of 'http://github.com/op...eta-edision.git' into submodule path 'meta-edision' failed
make[1]: *** [update] Error 1
make[1]: Leaving directory `/opt/openpli4/openpli-oe-core'
make: *** [/opt/openpli4/openpli-oe-core/meta-openembedded/meta-oe] Error 2

 

 

It requires git account(not normal I think) at a certain point, after getting them, it fails also

 

Can anyone help me ?

thanks in advance!


Edited by kallquk, 7 January 2019 - 15:17.


Re: creating release-4 build environment failed #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,354 posts

+749
Excellent

Posted 7 January 2019 - 15:27

You need to edit the .submodules file, and change "open-edision" to "edision-open" in the git URL, they have changed their github account name in the meantime...

 

edit: I've fixed it in our repo.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: creating release-4 build environment failed #3 kallquk

  • Member
  • 18 posts

0
Neutral

Posted 8 January 2019 - 20:07

You need to edit the .submodules file, and change "open-edision" to "edision-open" in the git URL, they have changed their github account name in the meantime...

 

edit: I've fixed it in our repo.

 

yes, thanks

it works!

 

But fails somewhere in the middle:

 

WARNING: Failed to fetch URL git://anonscm.debian.org/collab-maint/libdca.git;protocol=git, attempting MIRRORS if available
ERROR: Fetcher failure: Fetch command failed with exit code 128, output:
Cloning into bare repository '/opt/openpli4/openpli-oe-core/sources/git2/anonscm.debian.org.collab-maint.libdca.git'...

fatal: unable to connect to anonscm.debian.org:
anonscm.debian.org[0: 194.177.211.202]: errno=Connection refused
anonscm.debian.org[1: 2001:648:2ffc:deb::211:202]: errno=Address family not supported by protocol


ERROR: Function failed: Fetcher failure for URL: 'git://anonscm.debian.org/collab-maint/libdca.git;protocol=git'. Unable to fetch URL from any source.
ERROR: Logfile of failure stored in: /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/libdca/0.0.5-5-r1/temp/log.do_fetch.7677
ERROR: Task 3665 (/opt/openpli4/openpli-oe-core/meta-openpli/recipes-multimedia/vlc/libdca_0.0.5-5.bb, do_fetch) failed with exit code '1'

 

I checked, this repository anonscm.debian.org is not anymore

 

what can I replace it with ? Or can I do a manual download of libdca, taking care that is this specific version , and then this step skipped by build ? how?


Edited by kallquk, 8 January 2019 - 20:09.


Re: creating release-4 build environment failed #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,354 posts

+749
Excellent

Posted 8 January 2019 - 22:23

You could change the recipe from a repo to a tarball like this one: http://download.vide...a-0.0.5.tar.bz2


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: creating release-4 build environment failed #5 kallquk

  • Member
  • 18 posts

0
Neutral

Posted 10 January 2019 - 17:10

thanks again

 

quite ending!, may be a version mismatch ?

 

ERROR: Function failed: do_install (log file is located at /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/opkg/1_0.2.4-r0/temp/log.do_install.7079)
ERROR: Logfile of failure stored in: /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/opkg/1_0.2.4-r0/temp/log.do_install.7079
Log data follows:
| DEBUG: SITE files ['endian-little', 'bit-32', 'mips-common', 'common-linux', 'common-glibc', 'mipsel-linux', 'common']
| DEBUG: Executing shell function do_install
| Usage: awk [POSIX or GNU style options] -f progfile [--] file ...
| Usage: awk [POSIX or GNU style options] [--] 'program' file ...
| POSIX options:                GNU long options: (standard)
|       -f progfile             --file=progfile
|       -F fs                   --field-separator=fs
|       -v var=val              --assign=var=val
| Short options:                GNU long options: (extensions)
|       -b                      --characters-as-bytes
|       -c                      --traditional
|       -C                      --copyright
|       -d[file]                --dump-variables[=file]
|       -e 'program-text'       --source='program-text'
|       -E file                 --exec=file
|       -g                      --gen-pot
|       -h                      --help
|       -L [fatal]              --lint[=fatal]
|       -n                      --non-decimal-data
|       -N                      --use-lc-numeric
|       -O                      --optimize
|       -p[file]                --profile[=file]
|       -P                      --posix
|       -r                      --re-interval
|       -S                      --sandbox
|       -t                      --lint-old
|       -V                      --version
|
| To report bugs, see node `Bugs' in `gawk.info', which is
| section `Reporting Problems and Bugs' in the printed version.
|
| gawk is a pattern scanning and processing language.
| By default it reads standard input and writes standard output.
|
| Examples:
|       gawk '{ sum += $1 }; END { print sum }' file
|       gawk -F: '{ print $1 }' /etc/passwd
| WARNING: /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/opkg/1_0.2.4-r0/temp/run.do_install.7079:1 exit 1 from
|   awk -i inplace '!x[$0]++' /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/opkg/1_0.2.4-r0/opkg.conf
| ERROR: Function failed: do_install (log file is located at /opt/openpli4/openpli-oe-core/build/tmp/work/mips32el-oe-linux/opkg/1_0.2.4-r0/temp/log.do_install.7079)
ERROR: Task 255 (/opt/openpli4/openpli-oe-core/openembedded-core/meta/recipes-devtools/opkg/opkg_0.2.4.bb, do_install) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3911 tasks of which 3909 didn't need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
  /opt/openpli4/openpli-oe-core/openembedded-core/meta/recipes-devtools/opkg/opkg_0.2.4.bb, do_install
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
make: *** [image] Error 1

 

 



Re: creating release-4 build environment failed #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,354 posts

+749
Excellent

Posted 10 January 2019 - 18:21

You seem to have an awk version that doesn't support '-i inline".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: creating release-4 build environment failed #7 kallquk

  • Member
  • 18 posts

0
Neutral

Posted 10 January 2019 - 23:38

why is detected this missing option by configure ?

can it be use without ?

 

I can't find where is gg optionenerated, can you help ?


Edited by kallquk, 10 January 2019 - 23:43.


Re: creating release-4 build environment failed #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,354 posts

+749
Excellent

Posted 10 January 2019 - 23:42

Probably not, because it's part of the OE recipe for opkg.

 

Instead of trying to build an image from ancient code, perhaps it might be better to build an image that does have up to date support for the DM800SE, for example OpenVision, which is based on OpenPLi.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users