Jump to content


Photo

Receiver locking up when recording many services


  • Please log in to reply
4 replies to this topic

#1 Abu Baniaz

  • Senior Member
  • 759 posts

+19
Neutral

Posted 11 January 2019 - 23:47

I have a strange issue to report. I'm using a GB UE 4K and solo 4k with two signal wires attached to a universal LNB pointing to 28.2.

 

If I start recording all the services I can, the GB UE 4K locks up after recording roughly 25 services. It does not respond to anything and I have to resort to "init 6" to restart the receiver. The Solo 4k can record 38 services without locking up. However, when I start to delete the timers, I can do a few and then it locks up. I then have to "init 6"

 

Can someone suggest where the problem lies? I have attached putty output.

 

 

For those curious about why I was doing this, I was  trying to demonstrate how many services you can record with a conventional LNB for those who keep associating FBC with unicable and saying there is no benefit with Universal LNB.

Secondly, when you restart E2 in debug mode, where is the debug log stored?

Attached Files



Re: Receiver locking up when recording many services #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,221 posts

+730
Excellent

Posted 12 January 2019 - 00:15

Afaik there is no option to save or write a debug log, never understood why that option is there as it is clearly not finished.

 

What I do is:

init 4
ENIGMA_DEBUG_LVL=4 enigma2 | tee /media/hdd/enigma.log

so you can follow what happens on the console, and still have a log on disk.

 

But I don't think you'll see much, you terminate a running timer, which triggers the spinner, meaning a call happened that never returned. Chances are that is a call into the driver...


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Receiver locking up when recording many services #3 littlesat

  • PLi® Core member
  • 46,852 posts

+490
Excellent

Posted 12 January 2019 - 09:56

[eDVBServicePlay] timeshift
[ActionMap] Keymap 'MsgBoxActions' -> Action = 'ok'
[Timer] Remove RecordTimerEntry(name=BBC News at Ten, begin=Fri Jan 11 23:22:53 2019, serviceref=1:0:1:193D:7FF:2:11A0000:0:0:0:, justplay=False)
time changed
[TIMER] activating state 3
[TIMER] stop recording on tuner: G
[eDVBServiceRecord] stop recording!
[eDVBServiceRecord] (was not recording)
[TIMER] record event 5
[TIMER] record event 1
[remove callback]
state:  3
in processed:  True
in running:  False
[eDVBServicePlay] timeshift
[eDVBServicePlay] timeshift
[ActionMap] Keymap 'ShortcutActions' -> Action = 'red'
[Skin] Processing screen: MessageBox
warning, skin is missing element WarningPixmap in <class 'Screens.MessageBox.MessageBox'>(Do you really want to delete BBC News at Ten?)
[Skin] Processing screen: MessageBox_summary
[eDVBServicePlay] timeshift
[eDVBServicePlay] timeshift
[ActionMap] Keymap 'MsgBoxActions' -> Action = 'ok'
[Timer] Remove RecordTimerEntry(name=BBC News at Ten, begin=Fri Jan 11 23:22:50 2019, serviceref=1:0:1:1947:7FF:2:11A0000:0:0:0:, justplay=False)
time changed
[TIMER] activating state 3
[TIMER] stop recording on tuner: G
[eDVBServiceRecord] stop recording!
[gRC] main thread is non-idle! display spinner!

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Receiver locking up when recording many services #4 Erik Slagter

  • PLi® Core member
  • 44,821 posts

+489
Excellent

Posted 12 January 2019 - 11:21

When this happens, type dmesg and you'll see either "OOPS" or "BUG" messages from the kernel, caused by the drivers or simply nothing, because the drivers from GB have debugging output off.

 

Either way this is not an OpenPLi issue.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Receiver locking up when recording many services #5 Abu Baniaz

  • Senior Member
  • 759 posts

+19
Neutral

Posted 20 January 2019 - 17:27

Thanks. As feedback, the error you mentioned is below. I got to 31 services before it locked up.

[ 358.837846] Internal error: Oops: 207 [#1] SMP ARM

Attached Files


Edited by Abu Baniaz, 20 January 2019 - 17:27.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users