Springen naar inhoud


Foto

UpdateProblem PLi-7.0-r


  • Please log in to reply
Er zijn 9 reacties in dit onderwerp

#1 ColinB

  • Senior Member
  • 703 berichten

+28
Good

Geplaatst op 29 januari 2019 - 12:21

Inoticed today when checking for any updates to openpli-7.0-release-et8000-20190121_usb it showed 201 and recomended a reflash.

 

Flashed openpli-7.0-release-et8000-20190128_usb and it now shows 168 updates. Most seem to relate to Samba4

 

Also "Update and ask to reboot" is missing from the menu.

 

Bijlage  Update screen.jpg   87,59K   6 Aantal bijlagen


Veranderd door ColinB, 29 januari 2019 - 12:21

Xtrend et8000 7.0-Release

2 x 8/1 DiSEqC  30w 13e 19e 23e 28e   

Astrometa USB Tuner Working DVB-T2 now on Kernel 4.10 ;)

WD10EARX 1TB

Sandisk 32GB USB for AFB, EPG, Picons & Timeshift

 

ZGemma Star S (6.2) Testing 7.0-RC

4/1 DiSEqC  30w 13e 19e 28e

Sandisk 8GB USB for AFB, EPG, Picons & Timeshift

 

LG 49UH610V UHD-HDR

UHF/Cable/Sat

 

E-Channelizer

 

 

 


Re: UpdateProblem PLi-7.0-r #2 ColinB

  • Senior Member
  • 703 berichten

+28
Good

Geplaatst op 29 januari 2019 - 12:43

Well it seems to have updated OK

 

I will wait till next time about the "Update and ask to reboot" .


Xtrend et8000 7.0-Release

2 x 8/1 DiSEqC  30w 13e 19e 23e 28e   

Astrometa USB Tuner Working DVB-T2 now on Kernel 4.10 ;)

WD10EARX 1TB

Sandisk 32GB USB for AFB, EPG, Picons & Timeshift

 

ZGemma Star S (6.2) Testing 7.0-RC

4/1 DiSEqC  30w 13e 19e 28e

Sandisk 8GB USB for AFB, EPG, Picons & Timeshift

 

LG 49UH610V UHD-HDR

UHF/Cable/Sat

 

E-Channelizer

 

 

 


Re: UpdateProblem PLi-7.0-r #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45196 berichten

+729
Excellent

Geplaatst op 29 januari 2019 - 17:28

That is absolutely odd.

 

When you flash an old image, I can understand there are updates, but not with yesterday's build.

 

The feed is rebuild together with the image, so those versions should be identical, after a flash you should only see a few max (bootlogo, picons, stuff like that).

 

Checked the buildserver, there wasn't even a rebuild of samba, so the version in the image of the 28th was the same as the version on the 21st. 

 

You don't have files in your backup that don't belong there, by any chance, so that the restore after flash overwrites the package management database with old information?


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: UpdateProblem PLi-7.0-r #4 timkvist

  • Senior Member
  • 45 berichten

0
Neutral

Geplaatst op 29 januari 2019 - 18:22

Samba stil not working for me on appletv with app INFUSE



Re: UpdateProblem PLi-7.0-r #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45196 berichten

+729
Excellent

Geplaatst op 29 januari 2019 - 18:47

It would be weird if it was otherwise.

 

Nothing was changed in relation to Samba, as we still don't know what your problem is. You said you could see the files but not play them, and that doesn't make any sense. If you meant you could see the shares but not connect to them, it would perhap be different...


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: UpdateProblem PLi-7.0-r #6 timkvist

  • Senior Member
  • 45 berichten

0
Neutral

Geplaatst op 29 januari 2019 - 19:38

It would be weird if it was otherwise.

 

Nothing was changed in relation to Samba, as we still don't know what your problem is. You said you could see the files but not play them, and that doesn't make any sense. If you meant you could see the shares but not connect to them, it would perhap be different...

 

Sorry i ment so  i can see the shares but not connect to them



Re: UpdateProblem PLi-7.0-r #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45196 berichten

+729
Excellent

Geplaatst op 29 januari 2019 - 19:41

Ah, that changes things a lot. There are plenty of topics about that, for example https://firecore.com/forum/topic/20410.

 

Chances are it tries to connect using SMBv1, which is insecure and disabled by default industry-wide (including in OpenPLi 7).


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: UpdateProblem PLi-7.0-r #8 ColinB

  • Senior Member
  • 703 berichten

+28
Good

Geplaatst op 30 januari 2019 - 07:33

That is absolutely odd.

 

When you flash an old image, I can understand there are updates, but not with yesterday's build.

 

The feed is rebuild together with the image, so those versions should be identical, after a flash you should only see a few max (bootlogo, picons, stuff like that).

 

Checked the buildserver, there wasn't even a rebuild of samba, so the version in the image of the 28th was the same as the version on the 21st. 

 

You don't have files in your backup that don't belong there, by any chance, so that the restore after flash overwrites the package management database with old information?

 

I dont know if this is any help.

 

Bijlage  ipkgupgrade.log   43,21K   15 Aantal bijlagen


Xtrend et8000 7.0-Release

2 x 8/1 DiSEqC  30w 13e 19e 23e 28e   

Astrometa USB Tuner Working DVB-T2 now on Kernel 4.10 ;)

WD10EARX 1TB

Sandisk 32GB USB for AFB, EPG, Picons & Timeshift

 

ZGemma Star S (6.2) Testing 7.0-RC

4/1 DiSEqC  30w 13e 19e 28e

Sandisk 8GB USB for AFB, EPG, Picons & Timeshift

 

LG 49UH610V UHD-HDR

UHF/Cable/Sat

 

E-Channelizer

 

 

 


Re: UpdateProblem PLi-7.0-r #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45196 berichten

+729
Excellent

Geplaatst op 30 januari 2019 - 11:45

A little, the interesting bit in this file is that all packages to be updated are from the shared mipsel feed.

 

This can happen if the build of your box runs first, doesn't update anything, but later, the build for a second box decides it does need to rebuild those packages.

 

However, if I check one (I picked libnpa-tstream-samba4) on the build server, I see it was last build on January 11th, so it wasn't even rebuild. I see the latest version on the buildserver is r3.1. So am I at a loss.

 

On disk the buildserver has:

-rw-r--r-- 1 build build 11104 Jan 11 12:19 libnpa-tstream-samba4_4.6.2-r3.1_mips32el.ipk

The build log of the et8000 image from the 28th

lrwxrwxrwx 1 build build 19 Jan 28 18:37 log.do_rootfs -> log.do_rootfs.17997 

says:

Installing libnpa-tstream-samba4 (4.6.2) on root
Downloading file:/openpli/oe/release-7.0/build/tmp/deploy/ipk/mips32el/libnpa-tstream-samba4_4.6.2-r3.0_mips32el.ipk.

which is impossible because that file didn't exist at the time of the build? Also, the build log for the et8000 doesn't mention any package updates.

 

So, I'm clueless...


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: UpdateProblem PLi-7.0-r #10 ColinB

  • Senior Member
  • 703 berichten

+28
Good

Geplaatst op 30 januari 2019 - 12:34

A little, the interesting bit in this file is that all packages to be updated are from the shared mipsel feed.

 

This can happen if the build of your box runs first, doesn't update anything, but later, the build for a second box decides it does need to rebuild those packages.

 

However, if I check one (I picked libnpa-tstream-samba4) on the build server, I see it was last build on January 11th, so it wasn't even rebuild. I see the latest version on the buildserver is r3.1. So am I at a loss.

 

On disk the buildserver has:

-rw-r--r-- 1 build build 11104 Jan 11 12:19 libnpa-tstream-samba4_4.6.2-r3.1_mips32el.ipk

The build log of the et8000 image from the 28th

lrwxrwxrwx 1 build build 19 Jan 28 18:37 log.do_rootfs -> log.do_rootfs.17997 

says:

Installing libnpa-tstream-samba4 (4.6.2) on root
Downloading file:/openpli/oe/release-7.0/build/tmp/deploy/ipk/mips32el/libnpa-tstream-samba4_4.6.2-r3.0_mips32el.ipk.

which is impossible because that file didn't exist at the time of the build? Also, the build log for the et8000 doesn't mention any package updates.

 

So, I'm clueless...

 

Thanks WW, it was strange. I've not hat any issues since moving to 7.0-r .

 

As I said it updated normally and as of today there are no updates available.

 

I am more than happy to reflash my backup of the time or day before (Ihave daily backups from 20190117_0412) and try again AFB (automatic-full-backup).

 

Otherwise we can just leave it as an anomoly.

 

Cheers Col


Xtrend et8000 7.0-Release

2 x 8/1 DiSEqC  30w 13e 19e 23e 28e   

Astrometa USB Tuner Working DVB-T2 now on Kernel 4.10 ;)

WD10EARX 1TB

Sandisk 32GB USB for AFB, EPG, Picons & Timeshift

 

ZGemma Star S (6.2) Testing 7.0-RC

4/1 DiSEqC  30w 13e 19e 28e

Sandisk 8GB USB for AFB, EPG, Picons & Timeshift

 

LG 49UH610V UHD-HDR

UHF/Cable/Sat

 

E-Channelizer

 

 

 





1 gebruiker(s) lezen dit onderwerp

0 leden, 1 bezoekers, 0 anonieme gebruikers