Jump to content


Photo

[openpli7] [et4000] autossh not working / mgcamd in feed?


  • Please log in to reply
3 replies to this topic

#1 rokco

  • Member
  • 11 posts

0
Neutral

Posted 9 February 2019 - 08:51

Dear OpenPli team,

Just installed openpli7 on my first box and tried to get things running as before. Following points recognized:

 

(1) no mgcamd in feed

 

(2) autossh installed from feed, but wrong SSH binary is used

1970/01/01 01:00:27 autossh[411]: port set to 0, monitoring disabled
1970/01/01 01:00:27 autossh[412]: checking for grace period, tries = 1
1970/01/01 01:00:27 autossh[412]: starting ssh (count 1)
1970/01/01 01:00:27 autossh[414]: execing /openpli/oe/release-7.0/build/tmp/hosttools/ssh
1970/01/01 01:00:27 autossh[412]: ssh child pid is 414
1970/01/01 01:00:27 autossh[412]: check on child 414
1970/01/01 01:00:27 autossh[412]: set alarm for 600 secs
1970/01/01 01:00:27 autossh[414]: /openpli/oe/release-7.0/build/tmp/hosttools/ssh: No such file or directory
 
SSH binary is under /usr/bin/ssh. Would it be possible to fix this?
 
Thanks.


Re: [openpli7] [et4000] autossh not working / mgcamd in feed? #2 mimisiku

  • Senior Member
  • 1,890 posts

+23
Neutral

Posted 9 February 2019 - 11:29

Mgcamd is no longer maintained as it depends on old binaries. There is a word-around but at some time soon, the binaries will no longer run on new machines. And why? Switch to OScam which does everything mgcamd did..
VU+ Solo SE v2 Optus NZ

Re: [openpli7] [et4000] autossh not working / mgcamd in feed? #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,613 posts

+715
Excellent

Posted 9 February 2019 - 15:24

(1) no mgcamd in feed

 

There are 3 mgcamd versions in the feed for mipsel boxes. You mght have to install the libcrypto-compat package, to deal with the fact they are compiled against old versions of libraries (no guarantee it will work if you do).
 

(2) autossh installed from feed, but wrong SSH binary is used
   SSH binary is under /usr/bin/ssh. Would it be possible to fix this?

 

We'll have a look, in the meantime you can start it using

AUTOSSH_PATH=/usr/bin/ssh autossh ...

Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: [openpli7] [et4000] autossh not working / mgcamd in feed? #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 44,613 posts

+715
Excellent

Posted 9 February 2019 - 15:39

Fixed for the next release (and also bumped to the latest version): https://github.com/O...9d49d7e6f3f5358


Currently in use: VU+Duo 4K (2xFBC S2), VU+Zero, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users