Jump to content


Photo

samba


  • Please log in to reply
16 replies to this topic

#1 speed

  • Senior Member
  • 354 posts

0
Neutral

Posted 19 March 2019 - 18:15

on older pli I have direct link to samba to open folder but in network its hidden so you cannot find the solo2

that's how I want it

now after updating to latest pli my samba file didn't work anymore

so I updated and its working again but I cannot find how to hide inside network the box?



Re: samba #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 19 March 2019 - 19:09

If you want to "hide" samba on the network, you need to:

 

disable netbios by adding this in the global section of smb-user.conf:

disable netbios = yes

and remove the wsd daemon:

opkg remote wsdd

But know that this is security by obscurity, it would be better to uncomment the "smb-secure" include in the smb-user configuration file, so you need to login before you can access the box.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #3 imperia

  • Senior Member
  • 122 posts

+2
Neutral

Posted 20 March 2019 - 13:12

don't want to hijack speed thread, but actually i have problem with samba after latest update.

its not starting anymore:

root@et6x00:~# /etc/init.d/samba.sh restart
Stopping Samba: smbdstart-stop-daemon: warning: killing process 362: No such process
 nmbd wsdd.
Waiting for samba processes to die off...
Activating share definitions
Starting Samba: smbd/usr/sbin/smbd: error while loading shared libraries: /usr/lib/samba/libsmbd-base-samba4.so: file too short
 nmbdBus error
 wsdd.
root@et6x00:~# ls -al /usr/lib/samba/
drwxr-xr-x    4 root     root          5488 Mar 19 20:07 .
drwxr-xr-x   15 root     root         20400 Feb 18 05:07 ..
drwxr-xr-x    2 root     root           360 Feb 18 21:10 auth
-rwxr-xr-x    1 root     root         10152 Feb 18 05:07 libCHARSET3-samba4.so
-rwxr-xr-x    1 root     root         44776 Feb 18 05:07 libaddns-samba4.so
-rwxr-xr-x    1 root     root             0 Feb 18 21:10 libads-samba4.so
-rwxr-xr-x    1 root     root         23892 Feb 18 05:07 libasn1util-samba4.so
-rwxr-xr-x    1 root     root         18168 Feb 18 05:07 libauth-sam-reply-samba4.so
-rwxr-xr-x    1 root     root          4096 Feb 18 21:10 libauth-samba4.so
-rwxr-xr-x    1 root     root         53160 Feb 18 05:07 libauthkrb5-samba4.so
-rwxr-xr-x    1 root     root         31408 Feb 18 05:07 libcli-cldap-samba4.so
-rwxr-xr-x    1 root     root         30952 Feb 18 05:07 libcli-ldap-common-samba4.so
-rwxr-xr-x    1 root     root         40044 Feb 18 05:07 libcli-nbt-samba4.so
-rwxr-xr-x    1 root     root        192744 Feb 18 05:07 libcli-smb-common-samba4.so
-rwxr-xr-x    1 root     root         23012 Feb 18 05:07 libcli-spoolss-samba4.so
-rwxr-xr-x    1 root     root         83024 Feb 18 05:07 libcliauth-samba4.so
-rwxr-xr-x    1 root     root         46692 Feb 18 05:07 libdbwrap-samba4.so
-rwxr-xr-x    1 root     root       1781912 Feb 18 05:07 libdcerpc-samba-samba4.so
-rwxr-xr-x    1 root     root          5764 Feb 18 05:07 libflag-mapping-samba4.so
-rwxr-xr-x    1 root     root          5704 Feb 18 05:07 libgenrand-samba4.so
-rwxr-xr-x    1 root     root        169164 Feb 18 05:07 libgensec-samba4.so
-rwxr-xr-x    1 root     root        171980 Feb 18 05:07 libgse-samba4.so
-rwxr-xr-x    1 root     root          9940 Feb 18 05:07 libinterfaces-samba4.so
-rwxr-xr-x    1 root     root          5616 Feb 18 05:07 libiov-buf-samba4.so
-rwxr-xr-x    1 root     root         44500 Feb 18 05:07 libkrb5samba-samba4.so
-rwxr-xr-x    1 root     root        178120 Feb 18 05:07 libldbsamba-samba4.so
-rwxr-xr-x    1 root     root         14360 Feb 18 05:07 liblibcli-lsa3-samba4.so
-rwxr-xr-x    1 root     root             0 Feb 18 21:10 liblibcli-netlogon3-samba4.so
-rwxr-xr-x    1 root     root          8192 Feb 18 21:10 liblibsmb-samba4.so
-rwxr-xr-x    1 root     root         40468 Feb 18 05:07 libmessages-dgm-samba4.so
-rwxr-xr-x    1 root     root          5584 Feb 18 05:07 libmessages-util-samba4.so
-rwxr-xr-x    1 root     root          5692 Feb 18 05:07 libmsghdr-samba4.so
-rwxr-xr-x    1 root     root          8192 Feb 18 21:10 libmsrpc3-samba4.so
-rwxr-xr-x    1 root     root       1313208 Feb 18 05:07 libndr-samba-samba4.so
-rwxr-xr-x    1 root     root       1596888 Feb 18 05:07 libndr-samba4.so
-rwxr-xr-x    1 root     root         31260 Feb 18 05:07 libnpa-tstream-samba4.so
-rwxr-xr-x    1 root     root         15328 Feb 18 05:07 libpopt-samba3-samba4.so
-rwxr-xr-x    1 root     root         89652 Feb 18 05:07 libprinting-migrate-samba4.so
-rwxr-xr-x    1 root     root          5620 Feb 18 05:07 libreplace-samba4.so
-rwxr-xr-x    1 root     root          5952 Feb 18 05:07 libsamba-cluster-support-samba4.so
-rwxr-xr-x    1 root     root         19152 Feb 18 05:07 libsamba-debug-samba4.so
-rwxr-xr-x    1 root     root          9956 Feb 18 05:07 libsamba-modules-samba4.so
-rwxr-xr-x    1 root     root        116320 Feb 18 05:07 libsamba-security-samba4.so
-rwxr-xr-x    1 root     root        103820 Feb 18 05:07 libsamba-sockets-samba4.so
-rwxr-xr-x    1 root     root         41284 Feb 18 05:07 libsamba3-util-samba4.so
-rwxr-xr-x    1 root     root        181368 Feb 18 05:07 libsamdb-common-samba4.so
-rwxr-xr-x    1 root     root         44680 Feb 18 05:07 libsecrets3-samba4.so
-rwxr-xr-x    1 root     root         14224 Feb 18 05:07 libserver-id-db-samba4.so
-rwxr-xr-x    1 root     root          5756 Feb 18 05:07 libserver-role-samba4.so
-rwxr-xr-x    1 root     root         22904 Feb 18 05:07 libsmb-transport-samba4.so
-rwxr-xr-x    1 root     root             0 Feb 18 21:10 libsmbd-base-samba4.so
-rwxr-xr-x    1 root     root          9892 Feb 18 05:07 libsmbd-conn-samba4.so
-rwxr-xr-x    1 root     root          5900 Feb 18 05:07 libsmbd-shim-samba4.so
-rwxr-xr-x    1 root     root         18884 Feb 18 05:07 libsmbldaphelper-samba4.so
-rwxr-xr-x    1 root     root          5580 Feb 18 05:07 libsocket-blocking-samba4.so
-rwxr-xr-x    1 root     root          9984 Feb 18 05:07 libsys-rw-samba4.so
-rwxr-xr-x    1 root     root          9828 Feb 18 05:07 libtalloc-report-samba4.so
-rwxr-xr-x    1 root     root          9824 Feb 18 05:07 libtdb-wrap-samba4.so
-rwxr-xr-x    1 root     root          5640 Feb 18 05:07 libtime-basic-samba4.so
-rwxr-xr-x    1 root     root             0 Feb 18 21:10 libtrusts-util-samba4.so
-rwxr-xr-x    1 root     root         14900 Feb 18 05:07 libutil-cmdline-samba4.so
-rwxr-xr-x    1 root     root          5824 Feb 18 05:07 libutil-reg-samba4.so
-rwxr-xr-x    1 root     root          5872 Feb 18 05:07 libutil-setid-samba4.so
-rwxr-xr-x    1 root     root         10664 Feb 18 05:07 libutil-tdb-samba4.so
-rwxr-xr-x    1 root     root         14336 Feb 18 05:07 libwinbind-client-samba4.so
drwxr-xr-x    2 root     root           448 Feb 18 21:10 pdb

some libraries are with 0 file size. i tried to search the files with opkg search(so i can reinstall the affected packages), buts it doesn't find anything. 

i guess i will have to reflash.



Re: samba #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 20 March 2019 - 14:31

Only for samba? Of also in other directories? Flash not full?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #5 imperia

  • Senior Member
  • 122 posts

+2
Neutral

Posted 20 March 2019 - 18:16

Only for samba? Of also in other directories? Flash not full?

This was system update from menus. There were 5 packages to be updated. I didn't saw which ones.

Maybe this happened before but I didn't noticed. I will reflash the receiver.

Everything else on the receiver works fine. 

I thought that maybe the receiver's flash memory is dying. Receiver is kinda old et6000.



Re: samba #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 20 March 2019 - 19:30

I doubt flash is dying, it can take a very fair beating, if you see how many times we flash a box.

 

I'd rather think your flash is full, given the fact that images keep on getting bigger, and an old box like the 6K doesn't have a lot of flash.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #7 imperia

  • Senior Member
  • 122 posts

+2
Neutral

Posted 21 March 2019 - 13:40

After the reflash everything is working. With  my installed packages(oscam, one skin, mc, nano and bitrate viewer) 92% used disk space. Maybe some update hits the limit of 100%.

i will do updates from console from now on, to see the error messages. 


Edited by imperia, 21 March 2019 - 13:41.


Re: samba #8 imperia

  • Senior Member
  • 122 posts

+2
Neutral

Posted 21 March 2019 - 13:47

One thing is different from before.

Pressing F3 in Midnight Commander doesn't work. Program freezes for few seconds. Viewer doesn't open.

If I press Shift-F3 it works.

 

F4 doesn't work too.. Only Shift-F4

 

I de-selected Use internal viewer and editor. Didn't helped.

 

Actually F1 F2 F3 F4 F5 don't work.

F6-F10 work.


Edited by imperia, 21 March 2019 - 13:51.


Re: samba #9 imperia

  • Senior Member
  • 122 posts

+2
Neutral

Posted 21 March 2019 - 13:55

Looks like I had to change in Putty:

Terminal - >Keyboard

The Function keys and numpad:

 

From ESC[~ to Linux

 

Never needed to do this before.



Re: samba #10 tykasan

  • Member
  • 23 posts

+1
Neutral

Posted 5 April 2019 - 23:57

Hello Guys,
Can you help me out to run samba on Openpli7? VUSOLO2

Im not getting any errors and still dont see smbd wsdd processes.

Would you have any hints on this one?

 

I can see VUSOLO2 in network neigbourhood, bu no acces to it.. probably because samba deamon doesnt work... only netbios deamon works..

root@vusolo2:~# ps | grep mbd
  462 root     21528 S    /usr/sbin/nmbd
  953 root      3036 S    grep mbd
root@vusolo2:~# /etc/init.d/samba.sh restart
Stopping Samba: smbdstart-stop-daemon: warning: killing process 782: No such process
 nmbd wsdd.
Waiting for samba processes to die off...
Activating share definitions
Starting Samba: smbd nmbd wsdd.
root@vusolo2:~#


VU+Solo2

OpenPLi 7.0


Re: samba #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 6 April 2019 - 01:17

Does you box have the correct time on startup?

 

Samba doesn't start if it doesn't, so if your box doesn't tune a valid transponder quickly enough, you need to install the systemtime plugin and activate ntp on boot.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #12 tykasan

  • Member
  • 23 posts

+1
Neutral

Posted 6 April 2019 - 07:43

Thank you for quick reply WanWizard.

I installed suggested plugin, I set it up to have NTP sync, but no option to sync at boot... Am I missing something?

smbd and wsdd still wont run.

 

Do you have any other thoughts, Sir?


VU+Solo2

OpenPLi 7.0


Re: samba #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 6 April 2019 - 11:21

In the systemtime plugin:

  • you can leave the sync time using set to "transponder" (unless your box has no tuners or its tuners are never used)
  • set NTP cold start to "yes"
  • Press green to save

This will only use NTP when the box starts, but switches to transponder time as soon as you have a tuner active.

 

It is still doesn't start, check for errors in /var/log/samba/log.smbd, you may have made an error in the configuration that prevents it from starting?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #14 tykasan

  • Member
  • 23 posts

+1
Neutral

Posted 6 April 2019 - 17:21

Thank you WanWizard.

Accorting to log file you pointed out... Issue was:

security = share

in smb-user.conf file..

 

I changed this to:

security = user

then I could see samba running. Thanks again for your priceless hints! You rock!


VU+Solo2

OpenPLi 7.0


Re: samba #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 6 April 2019 - 18:59

You're welcome.

 

Did you have any error messages in the logs related to your security setting?

 

According to the samba docs, "security = share" has been deprecated for years now, and should be replaced by

security = user
map to guest = Bad User

I've added this action to our restore script: https://github.com/O...2596fd998082f23


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: samba #16 tykasan

  • Member
  • 23 posts

+1
Neutral

Posted 6 April 2019 - 21:00

Yes, my config were really old :) few weeks ago I was running OpenPLi v3. Shame on me, I know.

 

I was having error like:

Ignoring invalid value 'share' for parameter 'security'

So I started to looking for solution and found info that share value is obsolete. And that made the trick :)
Thanks again... M>
 


VU+Solo2

OpenPLi 7.0


Re: samba #17 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,629 posts

+737
Excellent

Posted 6 April 2019 - 21:17

Clear, thanks for reporting.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users