Jump to content


Photo

flexget instalation with pip install


  • Please log in to reply
10 replies to this topic

#1 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 06:57

hi to all, I have installed flexget onm y Zero 4k and it return these errors about several .py  files, it's possible to fix it some way?? this is what it say when I run 'flexget check' on console:

 

root@bf2:/media/hdd/flexget# flexget check
Traceback (most recent call last):
  File "/usr/bin/flexget", line 6, in <module>
    from flexget import main
  File "/usr/lib/python2.7/site-packages/flexget/__init__.py", line 12, in <module>
    from flexget.manager import Manager
  File "/usr/lib/python2.7/site-packages/flexget/manager.py", line 32, in <module>
    from flexget.utils.sqlalchemy_utils import ContextSession  # noqa
  File "/usr/lib/python2.7/site-packages/flexget/utils/sqlalchemy_utils.py", line 6, in <module>
    from past.builtins import basestring
  File "/usr/lib/python2.7/site-packages/past/__init__.py", line 88, in <module>
    from past.translation import install_hooks as autotranslate
  File "/usr/lib/python2.7/site-packages/past/translation/__init__.py", line 41, in <module>
    from lib2to3.pgen2.parse import ParseError
ImportError: No module named lib2to3.pgen2.parse
 
There are 5 code error and I dont know if it's possible to fix by some python update, I dont know. Any helpful comment will be welcome.
 
Thanks!


Re: flexget instalation with pip install #2 littlesat

  • PLi® Core member
  • 48,313 posts

+508
Excellent

Posted 22 March 2019 - 07:59

What is flexget and where did you get it from?
Actually there is one error.. regarding a module it does not find. It looks like Some code (library) is missing.

Edited by littlesat, 22 March 2019 - 08:01.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: flexget instalation with pip install #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,159 posts

+784
Excellent

Posted 22 March 2019 - 10:14

It looks like a python3 package,  lib2to3 is a backward compatibility library. We don't support python3 at all...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: flexget instalation with pip install #4 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 10:36

Flexget is an app to get files from an rss automatically... and other features...

 

https://flexget.com/...allWizard/Linux

 

I install setuptools from this link:

wget https://phm.pw/ez_setup.py -O - | python

And I run this line to install pip

easy_install pip

And then to finish, these 2 executions:

pip install flexget 
pip install transmissionrpc

==> I've followed a public thread of world of satelite, thinking it would be possible to be success...

 

I try with several versions of flexget and I get different error reply, I am lost... I am not a coder... I would be good to use the stb to do other tasks while it is on standby.

 

Thank you.


Edited by daveraver, 22 March 2019 - 10:37.


Re: flexget instalation with pip install #5 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 10:41

It looks like a python3 package,  lib2to3 is a backward compatibility library. We don't support python3 at all...

 

ok, I will be here to see the openpli changes and if it's possible to get flexget working. It only looked for more possibilities to do more tasks with my stb.

 

thanks


Edited by daveraver, 22 March 2019 - 10:41.


Re: flexget instalation with pip install #6 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 10:45

Hi, look at that, using a flexget version to work on python2 only, we get this error message,
root@bf2:/media/hdd/flexget# flexget check
Traceback (most recent call last):
File "/usr/bin/flexget", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3191, in <module>
@_call_aside
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3175, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3204, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 585, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 791, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (six 1.10.0 (/usr/lib/python2.7/site-packages/six-1.10.0-py2.7.egg), Requirement.parse('six>=1.11.0'), set(['jsonschema']))

Is it possible to fix?? not for me, thanks

Re: flexget instalation with pip install #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,159 posts

+784
Excellent

Posted 22 March 2019 - 11:06

Current development has:

python-six - 1.10.0-r0.1 - Python 2 and 3 compatibility library

so don't expect a 1.11+ any time soon...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: flexget instalation with pip install #8 littlesat

  • PLi® Core member
  • 48,313 posts

+508
Excellent

Posted 22 March 2019 - 11:24

Or find a flexget that need a 'lower' version of python-six. Or wait we upgrade OE.


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: flexget instalation with pip install #9 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 16:21

ok, thanks mates, I will try to run lower flexget version. If not, I will be expectant to new library update. I will have to modifiy some code on site-packaes on flexget, only latest versions of flexget comes ready to export from https sites, and I need it. I will comment my achievements.

Re: flexget instalation with pip install #10 foxbob

  • Senior Member
  • 266 posts

+9
Neutral

Posted 22 March 2019 - 16:37

I tried installing the rocko branch on my home assembly.

Error ImportError: No module named xmlrpclib

Attached Files



Re: flexget instalation with pip install #11 daveraver

  • Senior Member
  • 350 posts

+3
Neutral

Posted 22 March 2019 - 16:51

Current development has:

python-six - 1.10.0-r0.1 - Python 2 and 3 compatibility library
so don't expect a 1.11+ any time soon...
ok, lower version avalaible of flexget on pip install is 1.1.4 and it requires six-1.11, so no more to do that wait to an update, absolutely not guaranted that flexget will work, who knows what else will be necessary to fix....
greetings!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users