Jump to content


Photo

VU+ Duo 4K HDMI-CEC not switching TV to the right entry


  • Please log in to reply
11 replies to this topic

#1 Pr2

  • PLi® Contributor
  • 3,451 posts

+151
Excellent

Posted 12 May 2019 - 09:13

Hi,

 

On my Panasonic Viera TV the VU+ Duo 4K is not switching the TV to the HDMI entry. It just turn on/off the TV.

I really think that the TV is not the culprit since it is the TV where I test many boxes and it is the first time that the TV doesn't switch to the right entry.

I have already test many HDMI-CEC parameters without any luck to have it working. I even replace the HDMI cable with the one received with the STB without any improvement.

 

Do you know if there is already a case opened at VU+ to report the HDMI-CEC malfunction?

 

Thanks,

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #2 Pr2

  • PLi® Contributor
  • 3,451 posts

+151
Excellent

Posted 12 May 2019 - 10:12

Hi,

 

Here is the work-around I use:

 

1) Search for and define your TV to always turn on a the specified HDMI entry (for my Panasonic Viera I need to turn on Hotel mode).

2) Download the full VU+ Duo 4K manual

http://www.vuplus.co...ual_English.pdf

3) Read from page 70 and find your TV code.

4) Press TV Power and OK button on the RCU for 3 seconds, wait for the red light to stay on

5) Type your TV 5 digits code follow by OK

6) Test if your TV turn on/off with the TV power button (TV should start on HDMI entry thanks to point 1)

 

Now you have to press the TV Power followed by the STB Power button, so your TV will turn on the specified HDMI entry then you will turn on the STB, so you will be on the right HDMI entry for it.

 

Anyways I hope that VU+ will properly implement the HDMI-CEC.

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #3 Erik Slagter

  • PLi® Core member
  • 45,235 posts

+496
Excellent

Posted 12 May 2019 - 10:21

It's not a VU+ limitation / malfunction, because it works over here.

 

I assume you are aware of the numerous incompatibilities in CEC between vendors, so you can never trust everything works?

 

You may want to try the sending delay though.


Edited by Erik Slagter, 12 May 2019 - 10:22.

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #4 Taykun345

  • Senior Member
  • 1,154 posts

+31
Good

Posted 12 May 2019 - 10:26

I had problems with old Vu+ Duo and X10 Panny plasma, it worked OK with Samsung plasma. I guess its still the same? X10 is very old though. What exact model do you have?


Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,162 posts

+784
Excellent

Posted 12 May 2019 - 11:10

I don't have any problem with the Duo 4K and my Viera plasma.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #6 Pr2

  • PLi® Contributor
  • 3,451 posts

+151
Excellent

Posted 12 May 2019 - 13:09

Hi,

 

I use this TV for all my test and it is only with the Duo 4K that I had problem. (HDMI-CEC was working fine with:  Xtrend, Zgemma, Octagon, ...)

I test many combination of parameters, delay change the HDMI cable, etc... and no luck. TV turn on/off but remain on DVB-C it doesn't switch to HMDI entry.

 

I also try on another HDMI entry, refresh the address...

 

@Wanwizard,

 

Can you please post here the settings that you are using so I can try exactly the same one.

 

Pr2


Edited by Pr2, 12 May 2019 - 13:11.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,162 posts

+784
Excellent

Posted 12 May 2019 - 13:12

Sure:

Attached File  1_0_19_CD64_844_2_11A0000_0_0_0_20190512131224.jpg   105.08KB   2 downloads

 

Note that CEC is a shared bus, so it is also important what else is connected to the bus. No matter which TV input is used, or if you use HDMI switches, connecting a box can influence the behaviour of all other devices on the bus.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #8 Pr2

  • PLi® Contributor
  • 3,451 posts

+151
Excellent

Posted 12 May 2019 - 13:54

Hi,

 

Thanks in between I have play again with the setup and set the delay to 150ms and it works, I saw that you set it to 100ms.

It is the first time that I had to set such an "high" value for the delay (I was trying lower values), but fortunately now it works.

 

About my work-around once you enable the Universal RCU code on the VU+ RCU the volume +/- code sent are the one from the TV, so you can no longer control the volume from within OpenPLi.

So I advice that you set the audio level that you want in OpenPLi before enabling the Universal RCU code.

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,162 posts

+784
Excellent

Posted 12 May 2019 - 16:22

It took me some time to get it to work as well. ;)


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #10 Eragon

  • Senior Member
  • 163 posts

+1
Neutral

Posted 12 May 2019 - 18:55


So I advice that you set the audio level that you want in OpenPLi before enabling the Universal RCU code.

 

 

Anyway, if needed it's always possible to change the box volume using WebIf, even after configuring the remote for the TV set.



Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #11 Pr2

  • PLi® Contributor
  • 3,451 posts

+151
Excellent

Posted 12 May 2019 - 20:32

You can also enable the left / right arrow to control volume and you can still adjust it that way.  ;)


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: VU+ Duo 4K HDMI-CEC not switching TV to the right entry #12 Taykun345

  • Senior Member
  • 1,154 posts

+31
Good

Posted 30 May 2019 - 08:28

Sure:

attachicon.gif1_0_19_CD64_844_2_11A0000_0_0_0_20190512131224.jpg

 

Note that CEC is a shared bus, so it is also important what else is connected to the bus. No matter which TV input is used, or if you use HDMI switches, connecting a box can influence the behaviour of all other devices on the bus.

 

Best info thanks. Now CEC works normally also on my old X10 plasma. 100ms did the trick.


Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users