Jump to content


Photo

Bootpartition für Multiboot im OpenPli-Image


  • Please log in to reply
12 replies to this topic

#1 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 18 May 2019 - 09:39

Hallo OpenPli-Team,

 

wo finde ich im OpenPli-Image die Bootpartitionen für das Multiboot, sollen eigentlich im Ordner /boot liegen, dort sind sie aber nicht?

 

Bootpartitionen für Multiboot, hier gibt es die Dateien:

STARTUP
STARTUP_1
STARTUP_2
STARTUP_3
STARTUP_4

 

Danke vorab.

 

Gruß Mikel


Edited by mikel, 18 May 2019 - 09:40.


Re: Bootpartition für Multiboot im OpenPli-Image #2 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 18 May 2019 - 09:43

Die Bootpartition wird meine ich nicht per Default gemountet.

mkdir /tmp/boot

mount /dev/mmcblk0p1 /tmp/boot

 

Dann findest du die Dateien unter /tmp/boot


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Bootpartition für Multiboot im OpenPli-Image #3 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 18 May 2019 - 18:12

Keine Bootdateien zu finden, bei anderen Images liegen diese in /boot.

 

Möchte bei einem total Crash, (auch mit Powertaste kein Start mehr möglich), die Box wieder an den Start bringen, sonst muss man immer alles neu aufsetzen.

Dazu brauche ich die Startupdateien. Wenn man noch per ftp auf die Box kommt, kann man das im Startup gewählte und nicht mehr startende Image, durch Tausch der Bootdateien wieder zum Leben erwecken.

 

Die müssen sich doch irgendwo verstecken, warum liegen diese beim OpenPli nicht auch dort wo sie eigentlich hin gehören?


Edited by mikel, 18 May 2019 - 18:13.


Re: Bootpartition für Multiboot im OpenPli-Image #4 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 18 May 2019 - 19:04

Und was geht an meinen Befehlen nicht? Wenn du per ftp auf die Box kommst, kommst du auch per Telnet auf die Box.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Bootpartition für Multiboot im OpenPli-Image #5 WTE

  • Senior Member
  • 663 posts

+30
Good

Posted 18 May 2019 - 19:25

Openpli 7.1 image:

 

HD60:

mkdir /tmp/boot

mount /dev/block/by-name/bootoptions /tmp/boot

 

HD51:

mkdir /tmp/boot

mount /dev/block/by-name/boot /tmp/boot


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: Bootpartition für Multiboot im OpenPli-Image #6 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 19 May 2019 - 09:31

Hallo,

 

habe die Bootdateien jetzt gefunden.

 

Telneteingabe:
mkdir/tmp/boot

 

unter ftp:
Simlink > tmp>/var/tmp
/var/volatile/temp/boot

 

STARTUP
STARTUP_1
STARTUP_2
STARTUP_3
STARTUP_4

 

Vielleicht gibt es bei einem Crash auch einen Befehl direkt aus einer anderen Startup Partition die Box wieder zu starten?

Danke für die Hilfe.

 

Gruß Mikel



Re: Bootpartition für Multiboot im OpenPli-Image #7 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 19 May 2019 - 10:26

Bisher war es so, dass du beim Starten der Box lange den Power Knopf gedrückt halten müsstest, damit das 1. Image gestartet wird (ohne USB Stick mit Image an der Box da ansonsten das Flashen startet). Man kann damit aber nur das 1. Image starten. Wenn das komplett kaputt ist, ist es schlecht. Deswegen vielleicht besser Image 2 als Hauptimage verwenden.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Bootpartition für Multiboot im OpenPli-Image #8 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 19 May 2019 - 13:27

Ich nutze schon immer die Images im Startup 2-4, das Image in Startup 1 wird meist nur auf einen neuen Stand gebracht und ab und zu zum flashen der anderen Images genutzt. Sollte ein Stabiles Image sein aber was heißt stabil?

Auf jeden Fall sollte im Image ein gut funktionierendes Backup/Flashtool enthalten sein, womit man die Startups 2-4 bedienen kann.

Also wenn meine Box crasht, dann nur innerhalb der gestarteten Images 2-4 und trotzdem funzt die Sache mit dem Powerknopf meist nicht, warum weiß der Teufel? Hatte zuletzt ein total Crash, kein Start mögich, musste/wollte neu über USB flashen, Stick rein, Netzschalter ein und dabei Powertaste gedrückt gehalten, die Anzeige Flash wurde kurz angezeigt und die Box startete über Notfall Startup 1.

Das funzt aber nur mit dem USB-Stick und dem Flashimage auf dem Stick, warum, weiß wie gesagt der Teufel? Normalerweise sollte ja hier ein USB-Flash durchgeführt werden, was aber nicht der Fall ist, vielleicht liegt es am Image was auf dem Stick liegt? Wenn das so funzt brauche ich vorerst bei einem Crash nicht alles neu aufsetzen.

 

Ich muss dazu sagen, einen Crash hatte ich bislang nur, wenn ich ein Backup von Openpli mit Backupsuite erstellt habe, diese Backupimages crashen meist beim flashen, ob mit Backupsuite oder über ein anderes Image zurückgespielt. Werde beim nächsten Crash, vorausgesetzt ich komme per ftp auf die Box, das Wechseln der Startupdateien probieren.

 

Was ist mit einen Befehl zum starten eines anderen Startups, um die Box wieder hoch zu fahren?

 

"Vielleicht gibt es bei einem Crash auch einen Befehl direkt aus einer anderen Startup Partition die Box wieder zu starten?"

 

J/N?


Edited by mikel, 19 May 2019 - 13:31.


Re: Bootpartition für Multiboot im OpenPli-Image #9 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 19 May 2019 - 16:35

Habe mal nachgeschaut was ich da für ein Image auf den Stick gelegt habe.

Statt ein USB-Image (disk.img) habe ich fälschlicher weise ein Backupimage drauf gelegt, somit habe ich eine nicht gedachte Neuerung für mein nicht startendes Notfallimage erhalten.

Was es so alles gibt!



Re: Bootpartition für Multiboot im OpenPli-Image #10 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 22 May 2019 - 08:55

Erfahrungen mit neuer Formatierung Flashspeicher für Multiboot

 

Hallo,

 

kann jemand seine Erfahrungen mit der neuen Formatierung (Image 7.1) des Flashspeichers für Multiboot mitteilen?

 

Bei USB-Flash mit Image 7.1 wird der Flashspeicher für Multiboot (Zgemma H7 und ähnliche Boxen) neu formatiert,

Startup 1 bekommt 1 GB und die Startups 2-4 Teilen sich 3 GB je nach Nutzung.

Funktioniert das schon ohne Fehler, vertragen sich die verschiedenen Images im Multiboot, hat das schon jemand getestet?

 

Wenn man "parted -l" unter Telnet ausführst und dann ein paar Mal Strg+c drückst, sollte man die Partition Table angezeigt bekommen. In der Ausgabe sieht man auch die echten Partitionsgrößen.

Den echten verwendbaren Platz siehst du dann mit "df bzw. df -h".

 

Danke vorab.

 

Gruß Mikel



Re: Bootpartition für Multiboot im OpenPli-Image #11 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 22 May 2019 - 12:33

Es gibt aktuell noch Probleme Images in anderen Slots zu starten, wenn man per USB Stick ein neues OE-A Image installiert hat. Wird aber in den nächsten Tagen behoben.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Bootpartition für Multiboot im OpenPli-Image #12 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 22 May 2019 - 12:45

Danke,

 

sind in der Hinsicht Multiboot Flashformatierung alle Images auf den gleichen Stand oder ist das unterschiedlich?

 

Bleibe vorerst bei der alten Version, funktioniert eigentlich z. Z. gut.


Edited by mikel, 22 May 2019 - 12:45.


Re: Bootpartition für Multiboot im OpenPli-Image #13 betacentauri

  • PLi® Core member
  • 5,112 posts

+239
Excellent

Posted 22 May 2019 - 16:36

Die OE-A Images (OpenATV, OpenViX,...) führen gerade soweit ich weiß auch die neue Partitionierung ein.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users