Jump to content


Photo

Epg Import installation problem


  • Please log in to reply
17 replies to this topic

#1 momak

  • Member
  • 10 posts

0
Neutral

Posted 18 May 2019 - 10:14

I cannot install Epg import  from feeds on my DM800 hd se with latest image!

Message after install is: no module name boxbranding ?



Re: Epg Import installation problem #2 Abu Baniaz

  • PLi® Contributor
  • 922 posts

+22
Neutral

Posted 18 May 2019 - 10:51

That is an OE-A plugin. PLi does not use box branding. You can put a fake box branding though.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

Re: Epg Import installation problem #3 momak

  • Member
  • 10 posts

0
Neutral

Posted 18 May 2019 - 11:08

How? Thanks



Re: Epg Import installation problem #4 gutemine

  • Senior Member
  • 869 posts

+68
Good

Posted 18 May 2019 - 14:27

Nonsense, EPGImport will NOT work with an old OE 2.0 Image with or without boxbranding.

 

You either use an Open* Image on these old Dreamboxes (an they normally have working EPGImport plugins in their feed)  or you will have to live with CrossEPG for XMLTV Importing.

 

The reason is that OE2.0 Image don't contain the Ouedis patch for loading EPG Events (Open* Images have this patch), hence ONLY loading entire epg.dat files will work, BUT the epg.dat creator in EPGImport is broken (maybe only with OE2.0 Images but as hardly anybody uses it anymore nobody reall knows or cares), hence NONE of the options work to habe EPGImporter Plugin on OE2.0 Images.

 

CrossEPG uses their own epg.dat creator written in C and this one works with OE2.0 Images, but it has other fun waiting for you.



Re: Epg Import installation problem #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,483 posts

+793
Excellent

Posted 18 May 2019 - 15:02

EPGimport works fine on images without the Oudeis patch, it specifically checks for it so it can fallback if needed.

 

EPGimport even runs on Windows, without Enigma being present (but obviously can't import, only create an epg.dat). Afaik Willy uses that all the time...

 

Also, what exactly in the python code has a dependency with a specific Yocto release (OE version)?

 

I cannot install Epg import  from feeds on my DM800 hd se with latest image!

 

The latest OpenPLi for a DM800HD is 2.1. It's feeds are still online, and you can download the xmltvimport (the old name for epgimport) without problems.

 

If you run another image on your box, you need to discuss this with the creator(s) of that image. It isn't our job to make sure our code is compatible with god knows what exists out there.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Epg Import installation problem #6 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 18 May 2019 - 15:52

Problem though.  The old xmltvimport does not understand xz files.  And all our files are in xz format nowadays.

Installing an epgimport ipk from one of the later images, will not work either,  as a lot of new libraries are required to make these working.

 

The oldest image which will work with the xz files is OpenPLi4.0

Although probably some manual editing of the sources.xml file will have to be done.

 

Also chances are that Crossepg in OpenPLi2.1 also does not understand the xz files.

 

OpenATV 6.2 - might be a solution.  Althought the latest update for your receiver is from 2015.  So no guaranties there.

This is around the same time as the latest OpenPLi2.1

 

Willy


Edited by doglover, 18 May 2019 - 15:55.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #7 gutemine

  • Senior Member
  • 869 posts

+68
Good

Posted 18 May 2019 - 15:52

Yes I know about the fallback, but it doesn't work, as already explained :D

 

Anyway, using an Open* Image is a valid workaround, hence let's not argue B)


Edited by gutemine, 18 May 2019 - 15:53.


Re: Epg Import installation problem #8 momak

  • Member
  • 10 posts

0
Neutral

Posted 18 May 2019 - 16:31

I have installed xlmtvimport from feeds no problem,on latest OpenPLi4.0 image.

Do I have to edit something,beaucose it has been downloading services from Rytec epg,but I canon get epg to work?

Thanks



Re: Epg Import installation problem #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,483 posts

+793
Excellent

Posted 18 May 2019 - 16:32

Yes I know about the fallback, but it doesn't work, as already explained :D

Anyway, using an Open* Image is a valid workaround, hence let's not argue B)

 

I don't want to argue, I just hate it when someone says "it doesn't work", and doesn't say why. I expect that from an end-user, they don't know any better, but knowing you, you must have a pretty good idea... ;)


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Epg Import installation problem #10 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,483 posts

+793
Excellent

Posted 18 May 2019 - 16:34

Do I have to edit something,beaucose it has been downloading services from Rytec epg,but I canon get epg to work?

 

What do you mean with "get it to work"?

 

There is nothing you need to get working. If data imports, and the data is ok, and the time on your box is ok, and if you have channels in your list for which EPG data is available, you should see it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Epg Import installation problem #11 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 18 May 2019 - 16:36

I have installed xlmtvimport from feeds no problem,on latest OpenPLi4.0 image.

Do I have to edit something,beaucose it has been downloading services from Rytec epg,but I canon get epg to work?

Thanks

 

Obtain the import log.  (press menu when the plug-in is open)

Follow the instructions.

You can save the log.  After that the log is in /tmp/

 

Attach the log to a reply.


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #12 momak

  • Member
  • 10 posts

0
Neutral

Posted 18 May 2019 - 19:26

Hello. I hope this wil help:

[EPGImport] autostart (0) occured at 1558192149.06
[EPGImport] No settings [Errno 2] No such file or directory: '/etc/enigma2/epgimport.conf'
[EPGImport] Selected sources: ['Srbija/Hrvatska/Crna Gora - Sport/Film (xz)', 'Srbija/Hrvatska/Crna Gora - Dodatni (xz)', 'Sverige - Sport/Filmer (xz)', 'Srbija/Crna Gora - Sport/Film (xz)', 'Hrvatska - Dodatni (xz)', 'Sverige - Diverse (xz)', 'Srbija/Crna Gora - Dodatni (xz)', 'Rytec IPTV XMLTV (xz)', 'Sverige - Grundlaggande (xz)', 'Danmark - Delt (xz)', 'Danmark - Grundleggende (xz)', 'Norge - Basic (xz)', 'Srbija/Hrvatska/Crna Gora - Osnovni (xz)', 'Danmark - Sport/Movies (xz)', 'Srbija/Crna Gora - Osnovni (xz)', 'Norge - Delt (xz)', 'Hrvatska - Sport/Film (xz)', 'Norge - Sport/Movies (xz)', 'Hrvatska - Osnovni (xz)']
sourcesDone():  True ['Srbija/Hrvatska/Crna Gora - Sport/Film (xz)', 'Srbija/Hrvatska/Crna Gora - Dodatni (xz)', 'Sverige - Sport/Filmer (xz)', 'Srbija/Crna Gora - Sport/Film (xz)', 'Hrvatska - Dodatni (xz)', 'Sverige - Diverse (xz)', 'Srbija/Crna Gora - Dodatni (xz)', 'Rytec IPTV XMLTV (xz)', 'Sverige - Grundlaggande (xz)', 'Danmark - Delt (xz)', 'Danmark - Grundleggende (xz)', 'Norge - Basic (xz)', 'Srbija/Hrvatska/Crna Gora - Osnovni (xz)', 'Danmark - Sport/Movies (xz)', 'Srbija/Crna Gora - Osnovni (xz)', 'Norge - Delt (xz)', 'Hrvatska - Sport/Film (xz)', 'Norge - Sport/Movies (xz)', 'Hrvatska - Osnovni (xz)']
[EPGImport] Selected sources: ['Srbija/Hrvatska/Crna Gora - Sport/Film (xz)', 'Srbija/Hrvatska/Crna Gora - Dodatni (xz)', 'Sverige - Sport/Filmer (xz)', 'Srbija/Crna Gora - Sport/Film (xz)', 'Hrvatska - Dodatni (xz)', 'Sverige - Diverse (xz)', 'Srbija/Crna Gora - Dodatni (xz)', 'Rytec IPTV XMLTV (xz)', 'Sverige - Grundlaggande (xz)', 'Danmark - Delt (xz)', 'Danmark - Grundleggende (xz)', 'Norge - Basic (xz)', 'Srbija/Hrvatska/Crna Gora - Osnovni (xz)', 'Danmark - Sport/Movies (xz)', 'Srbija/Crna Gora - Osnovni (xz)', 'Norge - Delt (xz)', 'Hrvatska - Sport/Film (xz)', 'Norge - Sport/Movies (xz)', 'Hrvatska - Osnovni (xz)']
sourcesDone():  True ['Srbija/Hrvatska/Crna Gora - Sport/Film (xz)', 'Srbija/Hrvatska/Crna Gora - Dodatni (xz)', 'Sverige - Sport/Filmer (xz)', 'Srbija/Crna Gora - Sport/Film (xz)', 'Hrvatska - Dodatni (xz)', 'Sverige - Diverse (xz)', 'Srbija/Crna Gora - Dodatni (xz)', 'Rytec IPTV XMLTV (xz)', 'Sverige - Grundlaggande (xz)', 'Danmark - Delt (xz)', 'Danmark - Grundleggende (xz)', 'Norge - Basic (xz)', 'Srbija/Hrvatska/Crna Gora - Osnovni (xz)', 'Danmark - Sport/Movies (xz)', 'Srbija/Crna Gora - Osnovni (xz)', 'Norge - Delt (xz)', 'Hrvatska - Sport/Film (xz)', 'Norge - Sport/Movies (xz)', 'Hrvatska - Osnovni (xz)']
[EPGImport] nextImport, source= Rytec IPTV XMLTV (xz)
[EPGImport] Downloading: http://rytecepg.wanwizard.eu/rytecIPTV.xz to local path: /tmp/epgimport.xz
[EPGImport] afterDownload /tmp/epgimport.xz
[EPGImport] unlink /tmp/epgimport.xz
[EPGImport] Downloading: http://www.xmltvepg.nl/rytec.channels.xml.xz to local path: /tmp/epgimport.xz
[EPGImport] afterChannelDownload /tmp/epgimport.xz
[EPGImport] Using twisted thread
[EPGImport] Parsing channels from 'rytec.channels.xml.xz'
Invalid serviceref string: 4097:0:1:2:1:352:0:0:0:0::http%3a//example.com
Invalid serviceref string: 4097:0:1:1:1:352:0:0:0:0::http%3a//example.com
Invalid serviceref string: 4097:0:1:5269:C99:3:EB0000:0:0:http%3a//example.com
[EPGImport] Already running, won't start again
[XMLTVConverter] Enumerating event information
Unknown channel:  DobbitTV.be
Unknown channel:  AVSEeklo.be
Unknown channel:  AVSGent.be
Unknown channel:  AVSOudenaarde.be
Unknown channel:  RingTV.be
Unknown channel:  RTVKempenNoord.be
Unknown channel:  RTVKempenOost.be
Unknown channel:  RTVKempenWest.be
Unknown channel:  RTVMechelen.be
Unknown channel:  TVCom.be
Unknown channel:  BipTV.fr
Unknown channel:  MensUpTV.fr
Unknown channel:  DemainTV.fr
Unknown channel:  AzurTV.fr
Unknown channel:  TraceTropical.fr
Unknown channel:  TraceGospel.fr
Unknown channel:  TraceKitoko.fr
Unknown channel:  TraceMziki.fr
Unknown channel:  TraceNaija.fr
Unknown channel:  TraceToca.fr

Edited by WanWizard, 18 May 2019 - 21:32.


Re: Epg Import installation problem #13 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 19 May 2019 - 07:42

First good news.  The version you installed understands xz files.  It parsed the channels file and reads the XMLTV (data) files.

 

There are a couple of remarks though:

 

1. On an old receiver like the Dream 800HD, selecting so many sources spells disaster.
EPG is stored in memory.  With this many sources selected you can easily full up all the available memory with EPG, with crashes as a consequence.

Besides when testing the system, you should try a single source.

(Dream HD800 does not have a lot of memory)

The lack of memory can be overcome by installing a swap file on a USB-Stick or HDD.

 

2. This version of EPGimport, does not understand this:

Invalid serviceref string: 4097:0:1:2:1:352:0:0:0:0::http%3a//example.com
Invalid serviceref string: 4097:0:1:1:1:352:0:0:0:0::http%3a//example.com
Invalid serviceref string: 4097:0:1:5269:C99:3:EB0000:0:0:http%3a//example.com

These service refs are for (legal) IPTV channels.  (also for illegal ones, but the ones included in the channels file are legal ones)

A solution could be that you download the rytec.channels file (see the rytec.sources.xml file for an url)  unzip it and change all the 4097: in 1:

Store this file in /etc/epgimport/

Edit now the rytec.sources.xml file. 

Delete in this file the section:

<channel name="rytec.channels.xml.xz">
.
.
.
</channel>

And replace all occurrences of  rytec.channels.xml.xz with rytec.channels.xml

The program will now take the local defined channels file.

Of course, when anything changes in the channels file, you have to do this all over.

 

3. When you see this:  [EPGImport] Already running, won't start again

you have to restart enigma2 in order to start a new import.

It could be the import is locked up, or it simply did not finish yet.  And with the amount of import you asked, this could take some time.  I am talking about half an hour or more.

 

4. Finally, I am attaching the latest version of EPGimport (which understands the 4097: service refs).  However it is no guaranty this will install on OpenPLi4.0.  But you can always try.

If succesfull, you do not need to do bullet 2.

 

Willy

 

 

PS:  Took a closer look at the amount of EPG.  There are several small files in that list.  The amount should be OK.


Edited by doglover, 19 May 2019 - 07:46.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #14 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 19 May 2019 - 14:29

PS:  disregard remark 2. in the above post.  I made a mistake


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #15 momak

  • Member
  • 10 posts

0
Neutral

Posted 19 May 2019 - 19:51

Hi. I thave delete all plugins.

So I tryed your plugin,but it does not want to install on dm 800 se.

So now I have installed XMLimport,and rytec,xml for xmlimport.

But I could not se chanels,and sources files in " Root /etc /epgimport,it was empty.

 Now I have downloaded  rytec.sources.xml.20180913.gz, and from there took url and  downloaded channels list for only one sources .

I couldnt find channels 4097 in those sources that I want,all was 1.

I have put both sources,and chanels list in Root /etc /epgimport.,and restarted enigma,but nothing.

Tried to download from sources but it doesnt want to download,after I have made changes in xml.sources(removed "xz")

 

<source type="gen_xmltv" channels="rytec.channels.xml.">

            <description>Danmark - Delt (xz)</description>
            <url>http://www.xmltvepg....c.xml</url>    
            <url>http://rytecepg.epgs..._Misc.xml</url>
            <url>http://rytecepg.wanw..._Misc.xml</url>
            <url>http://rytecepg.dynd..._Misc.xml</url>
            <url>http://www.vuplus-co...isc.xml</url>  

 I dont now what I have done wrong,but I have entusiasm to continue to make this work:)



Re: Epg Import installation problem #16 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 20 May 2019 - 07:16

First:  The older XMLTVimport does not support .xz files.  Only .gz and uncompressed files.

So this will never work.

 

Secondly:  I tried to give you the latest plug-in, but I am not surprised it does not install.  It needs some libs which are not provided in the feed of OpenPLi 2.1

 

Thirdly:

I tried to help, but really I know too little about Dreamboxes and their images to do anything else.

You are recommended to seek help on the forums which deal with your receiver and image.

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #17 doglover

  • Rytec EPG Team
  • 12,798 posts

+388
Excellent

Posted 20 May 2019 - 09:46

Looked around and maybe this is something for you:

 

https://www.oozoon.d...-800-hd-images/

 

and:

 

https://www.oozoon-b...pg-for-dreamos/

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Epg Import installation problem #18 momak

  • Member
  • 10 posts

0
Neutral

Posted 21 May 2019 - 14:36

Thanks. I will try






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users