Jump to content


Photo

OPENVPN on DUO 4K


  • Please log in to reply
7 replies to this topic

#1 dudule22

  • Senior Member
  • 60 posts

0
Neutral

Posted 30 May 2019 - 10:07

An error occures when i try to instal OpenVPN in OpenPLI 7.1.

 

/$ opkg install openvpn
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
Collected errors:
 * opkg_download_backend: Failed to download http://downloads.ope...mv7ahf-neon.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download liblzo2-2. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope....16_vuduo4k.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download kernel-module-tun-4.1.45-1.17. Perhaps you need to run 'opkg update'?
 * opkg_download_backend: Failed to download http://downloads.ope...mv7ahf-neon.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download openvpn. Perhaps you need to run 'opkg update'?
Installing liblzo2-2 (2.09) on root
Downloading http://downloads.ope...mv7ahf-neon.ipk.
Installing kernel-module-tun-4.1.45-1.17 (4.1.45) on root
Downloading http://downloads.ope....16_vuduo4k.ipk.
Installing openvpn (2.3.9) on root
Downloading http://downloads.ope...mv7ahf-neon.ipk.
 

opkg update errors

 

/$ opkg update
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
wget: bad address 'downloads.openpli.org'
Collected errors:
 * opkg_download_backend: Failed to download http://downloads.ope...eon/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...rty/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...o4k/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...all/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...eon/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...ons/Packages.gz, wget returned 1.
 * opkg_download_backend: Failed to download http://downloads.ope...o4k/Packages.gz, wget returned 1.
Downloading http://downloads.ope...eon/Packages.gz.
Downloading http://downloads.ope...rty/Packages.gz.
Downloading http://downloads.ope...o4k/Packages.gz.
Downloading http://downloads.ope...all/Packages.gz.
Downloading http://downloads.ope...eon/Packages.gz.
Downloading http://downloads.ope...ons/Packages.gz.
Downloading http://downloads.ope...o4k/Packages.gz.
 

Thank you for you help.

 



Re: OPENVPN on DUO 4K #2 Frenske

  • Forum Moderator
    PLi® Core member
  • 22,174 posts

+200
Excellent

Posted 30 May 2019 - 10:12

Just tested the download of OpenVPN on the Ultimo4K with OpenPLi RC 7.1.
You might have a network issue. Try opkg update first.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: OPENVPN on DUO 4K #3 dudule22

  • Senior Member
  • 60 posts

0
Neutral

Posted 30 May 2019 - 10:46

Thank you, it was network issue. On static IP with WIFI the DNS are cleaned after a reboot.



Re: OPENVPN on DUO 4K #4 Frenske

  • Forum Moderator
    PLi® Core member
  • 22,174 posts

+200
Excellent

Posted 30 May 2019 - 10:48

You‘re welcome.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: OPENVPN on DUO 4K #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 30 May 2019 - 12:15

Thank you, it was network issue. On static IP with WIFI the DNS are cleaned after a reboot.

 

This is a known bug that is on the todo list.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OPENVPN on DUO 4K #6 dudule22

  • Senior Member
  • 60 posts

0
Neutral

Posted 2 June 2019 - 08:13

Is there a script to start, stop OpenVPN and see the external IP adress ?

 

I want to put it in ppanel.

 

Regards.



Re: OPENVPN on DUO 4K #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 2 June 2019 - 09:22

OpenVPN starts and stops with a standard sysv init script, which is in /etc/init.d.

 

I don't know of the top of my head any way to get connection information without parsing log files.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OPENVPN on DUO 4K #8 dudule22

  • Senior Member
  • 60 posts

0
Neutral

Posted 3 June 2019 - 19:28

Ok






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users