Jump to content


Photo

libpscsclite1


  • Please log in to reply
4 replies to this topic

#1 EnoSat

  • Senior Member
  • 28 posts

0
Neutral

Posted 4 June 2019 - 19:38

hi, why remove support libpscsclite1 from feed ?

in 05/2019 - OK

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2019.05.18 10:07:07 =~=~=~=~=~=~=~=~=~=~=~=
openpli 7.1-rc vuuno
vuuno login: root
Last login: Sat May 18 10:06:50 CEST 2019 on pts/0
root@vuuno:~# opkg update
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party/Packages.gz.
Updated source 'openpli-3rd-party'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party-mips32el/Packages.gz.
Updated source 'openpli-3rd-party-mips32el'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party-vuuno/Packages.gz.
Updated source 'openpli-3rd-party-vuuno'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/all/Packages.gz.
Updated source 'openpli-all'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/Packages.gz.
Updated source 'openpli-mips32el'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/picons/Packages.gz.
Updated source 'openpli-picons'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/vuuno/Packages.gz.
Updated source 'openpli-vuuno'.
root@vuuno:~# opkg install libpscsclite1
Installing libpcsclite1 (1.8.13) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/libpcsclite1_1.8.13-r0.22_mips32el.ipk.
Configuring libpcsclite1.
root@vuuno:~# opkg install pcsc-lite
Installing libudev1 (3.2.1) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/libudev1_3.2.1-r0.24_mips32el.ipk.
Installing libusb-1.0-0 (1.0.21) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/libusb-1.0-0_1.0.21-r0.6_mips32el.ipk.
Installing pcsc-lite (1.8.13) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/pcsc-lite_1.8.13-r0.22_mips32el.ipk.
Installing ccid (1.4.24) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/ccid_1.4.24-r0.21_mips32el.ipk.
Configuring libusb-1.0-0.
Configuring libudev1.
Configuring pcsc-lite.
Configuring ccid.
root@vuuno:~# update-rc.d pcscd defaults 49
 Adding system startup for /etc/init.d/pcscd.
root@vuuno:~#

but in 06/2019 - not OK

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2019.06.04 19:03:46 =~=~=~=~=~=~=~=~=~=~=~=
openpli 7.1-rc vuuno
vuuno login: root
root@vuuno:~# opkg update
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party/Packages.gz.
Updated source 'openpli-3rd-party'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party-mips32el/Packages.gz.
Updated source 'openpli-3rd-party-mips32el'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/3rd-party-vuuno/Packages.gz.
Updated source 'openpli-3rd-party-vuuno'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/all/Packages.gz.
Updated source 'openpli-all'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/mips32el/Packages.gz.
Updated source 'openpli-mips32el'.
Downloading http://downloads.openpli.org/feeds/openpli-7-release/picons/Packages.gz.
Updated source 'openpli-picons'.
Downloading http://downloads.openpli.org/feeds/openpli-7.1-rc/vuuno/Packages.gz.
Updated source 'openpli-vuuno'.
root@vuuno:~# opkg install libpscsclite1
Collected errors:
 * opkg_prepare_url_for_install: Couldn't find anything to satisfy 'libpscsclite1'.
root@vuuno:~# 
root@vuuno:~# opkg install pcsc-lite
No packages installed or removed.
Configuring libusb-1.0-0.
Configuring libudev1.
root@vuuno:~# update-rc.d pcscd defaults 49
 Adding system startup for /etc/init.d/pcscd.
root@vuuno:~#


Re: libpscsclite1 #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 4 June 2019 - 20:21

Nothing has changed to 7.1-rc's OE definition since the branch was created.

 

And as far as I can see, it is still available:

[wanwizard@buildserver3] $ find . -name "libpcsclite1*"
./mips32el-nf/libpcsclite1_1.8.13-r0.23_mips32el-nf.ipk
./armv7ahf-neon/libpcsclite1_1.8.13-r0.9_armv7ahf-neon.ipk
./cortexa15hf-neon-vfpv4/libpcsclite1_1.8.13-r0.24_cortexa15hf-neon-vfpv4.ipk
./aarch64/libpcsclite1_1.8.13-r0.3_aarch64.ipk
./mips32el/libpcsclite1_1.8.13-r0.22_mips32el.ipk

I see no attempts do download it on our download mirrors.

 

I've checked a mipsel box I have here:

root@vipert2c:/var/cache/opkg$ opkg info libpcsclite1
Package: libpcsclite1
Version: 1.8.13-r0.18
Depends: libc6 (>= 2.25)
Provides: pcsc-lite-lib
Status: unknown ok not-installed
Section: base
Architecture: mips32el
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: 92d3cea87dee303ebf9d83f4e58ba14e
Size: 19144
Filename: libpcsclite1_1.8.13-r0.18_mips32el.ipk
Source: pcsc-lite_1.8.13.bb
Description: PC/SC Lite smart card framework and applications
 PC/SC Lite smart card framework and applications.

and it seem to be available?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libpscsclite1 #3 EnoSat

  • Senior Member
  • 28 posts

0
Neutral

Posted 4 June 2019 - 21:23

hmm, interesant why now UNO not download libpcsclite

PS:

ahaaaa

05/2019 - name - libpscsclite1

06/2019 - name - libpcsclite1

 

box write

error while loading shared libraries: libpcsclite.so.1: cannot open shared object file: No such file or directory
 
now name correct :)

Edited by EnoSat, 4 June 2019 - 21:28.


Re: libpscsclite1 #4 EnoSat

  • Senior Member
  • 28 posts

0
Neutral

Posted 4 June 2019 - 21:32

PS2:

but after install write this: /lib/libc.so.6: version `GLIBC_2.28' not found

libc.so.6 linked to libc.so.6 -> libc-2.25.so


Edited by EnoSat, 4 June 2019 - 21:34.


Re: libpscsclite1 #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 4 June 2019 - 23:12

No clue what you are trying to install, we don't supply glibc 2.28, and we never did.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users