Jump to content


Photo

Fallbacktuner with wifi-stick doesn‘t work ok.


  • Please log in to reply
13 replies to this topic

#1 WTE

  • Senior Member
  • 681 posts

+30
Good

Posted 24 June 2019 - 19:01

I have an issue with some wifi sticks and import the fallbacktuner channellist. (I know a wired ethernet is better but wifi works fine as well)

 

9 of 10 wifi sticks it works fine but a few I have issue when the box startup. It seems some wifi sticks need some extra time to start and then the channel import from the fallbacktuner fails.

I use the follow setting for import channellist by start: "Also import at reboot/restart enigma2"

 

Is it possible to load the channellist from the fallbacktuner after the ethernet/wifi connection is up?

 


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #2 WTE

  • Senior Member
  • 681 posts

+30
Good

Posted 24 June 2019 - 19:26

The interfaces for wifi shouldn't it have a fallback wrapper if nl80211 is not available or support? Normal setting is I thought -Dnl80211,wext

Now it's:

wpa or wpa2 = pre-up wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.wlan0.conf -B -dd -Dwext || true

wpa2 = pre-up wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.wlan0.conf -B -dd -Dnl80211 || true

 

I assume this option should been ok for all devices on WPA2 security as follow:

 

wpa2 = pre-up wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.wlan0.conf -B -dd -Dnl80211,wext || true


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #3 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 24 June 2019 - 19:53

Looks like we need to ‘ping’ first and when not there try again each minute??? Until it completes?

But for one out of 10 ‘sjitty’ USB sticks?

Edited by littlesat, 24 June 2019 - 19:56.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #4 WTE

  • Senior Member
  • 681 posts

+30
Good

Posted 24 June 2019 - 20:15

Looks like we need to ‘ping’ first and when not there try again each minute??? Until it completes?

But for one out of 10 ‘sjitty’ USB sticks?

 

rtl8188 and rt5592 I had some difficults all other over 20 were all fine. Just reporting that there is no check on it if network and/or fallback tuner is up.
Maybe in future development can send by WOL wakeupcall if host is not available. Then a ping is interest to do for check when to load the channellist and epg.


Edited by WTE, 24 June 2019 - 20:15.

Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #5 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 25 June 2019 - 06:42

So it is only an issue for ‘crappy cheap’ usb sticks? Add WOL for the sync could be nice... then ‘ping’ when not pinged do wol and then try again each minute..(or wait for the pop-up that no stream started). but still for a minute no picture due to crappy stick... maybe another thought discover why these sticks connect late....

It can be improved indeed... but to do it only for crappy sticks???
With WOL I can at least show a pop-up that the serverbox is booted with a please wait.... Ping could be check if owif is reachable

Edited by littlesat, 25 June 2019 - 06:59.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,429 posts

+823
Excellent

Posted 25 June 2019 - 13:11

WOL is only interesting if:

  • the fallback receiver is switched off (deep standby)
  • the fallback receiver supports WOL
  • you know the MAC address of the fallback receiver
  • and you have configured it on the client
  • oh, and both client and fallback are on the same layer 2 network

If so, you can send a magic packet to wake the fallback receiver up. There is a Python module available for that (https://github.com/r...ing/pywakeonlan), which we can build if needed.

 

However, the problem with slow network availability is a more general one, for example it will also impact ntp, and because of that also openvpn and samba startup. And then there is the case that there is no network because none is configured (it is a standalone box), then you can wait for network connectivity until you're blue in the face...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #7 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 25 June 2019 - 14:49

So for WOL we need to 'strip' the MAC address from the server (fallback) box? Likely it can also be gathered via OWIF (or add it to OWIF)

 

It might be an idea for those who want to put a server box in deep standby...

 

The other issue is slow WiFi (sticks)... I have currently no clear idea how we can solve this in a good way.


Edited by littlesat, 25 June 2019 - 14:51.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,429 posts

+823
Excellent

Posted 25 June 2019 - 15:25

Do we actually now how many, and which, boxes support WOL? And which wifi drivers / chipsets do? It is a bit pointless to implement this if the answer is "two"...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #9 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 25 June 2019 - 15:26

Indeed... ;) But when it is three (LOL)....


Edited by littlesat, 25 June 2019 - 15:26.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #10 WTE

  • Senior Member
  • 681 posts

+30
Good

Posted 25 June 2019 - 15:49

So for WOL we need to 'strip' the MAC address from the server (fallback) box? Likely it can also be gathered via OWIF (or add it to OWIF)

 

It might be an idea for those who want to put a server box in deep standby...

 

The other issue is slow WiFi (sticks)... I have currently no clear idea how we can solve this in a good way.

 

To get mac is easy:

arp "fallbacktuner IP"


Edited by WTE, 25 June 2019 - 15:53.

Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,429 posts

+823
Excellent

Posted 25 June 2019 - 16:01

Yup. For which also a Python module exists https://github.com/s...r/python-arpreq which can be build.

 

It really gets time to dump the current enigma network stack, and rewrite it, so it has a proper API with these kind of methods...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #12 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 26 June 2019 - 09:51

A simple python function to send a magic WOL package to a MAC address... which should work in our image without adaptions. Without any additional libraries and/or modules required.

import socket
 
def sendWOL(mac):
        s = socket.socket(socket.AF_INET, socket.SOCK_DGRAM)
        s.setsockopt(socket.SOL_SOCKET, socket.SO_BROADCAST, 1)
        s.sendto('\xff'*6 + ''.join([chr(int(x,16)) for x in mac.split(':')]) * 16, ('<broadcast>', 9))

Edited by littlesat, 26 June 2019 - 09:52.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #13 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 26 June 2019 - 10:32

To get the mac address from the fallback/server box you can parse the XML via OWIF

http://ip.from.fallback.box/web/about

 

<e2lanmac>00:1d:ec:10:5f:f2</e2lanmac>

<e2lanip>192.168.1.10</e2lanip> + verify by module on IP?

 

Once known the MAC could be stored in a config so the next reboot the importchannels module can also try to wakeup the fallback/server box.


Edited by littlesat, 26 June 2019 - 10:35.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Fallbacktuner with wifi-stick doesn‘t work ok. #14 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 26 June 2019 - 13:35

import urllib2
import xml.etree.cElementTree
 
print xml.etree.cElementTree.fromstring(urllib2.urlopen('http://192.168.1.10/web/about').read()).find('e2about').find('e2lanmac').text
 
 
This 'pings' the server/fallback tuner via the OWIF and the result is the MAC address of the server/fallback tuner. (sorry it is a oneliner)

When it fails/timedout  you can perform a WOL (just once but 'blindly' without a config or setting - keep it simple) and then try again for e.g. polling it 6 x 10 seconds and show a message... 

Edited by littlesat, 26 June 2019 - 13:39.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users