Jump to content


Photo

HD51 truncated libs - start niet door sinds release 7.1


  • Please log in to reply
33 replies to this topic

#1 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 1 July 2019 - 07:45

Hoi,

 

Sinds release 7.1 start mijn box (mut@nt hd51) niet door na flashen of upgrade. Enigma blijft hangen met een spinner. Het probleem was er niet bij de 7.1 release candidates. Gek genoeg ook niet bij de laatste. ldconfig geeft de volgende foutmeldingen:

/sbin/ldconfig: file /usr/lib/libEGL.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libv3ddriver.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2.0 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so.1.4 is truncated

Verwijderen van het pakket hd-v3ddriver-hd51 lost het probleem op, de box start weer door.

opkg remove hd-v3ddriver-hd51

Terug installeren (opkg install hd-v3ddriver-hd51) introduceert het probleem weer. Nu weet ik niet precies wat hd-v3ddriver-hd51 precies doet. Ik vermoed iets met HD en/of 3D. Ik heb tot op heden geen nadelige gevolgen gemerkt van het verwijderen, maar een package upgrade installeert automatisch hd-v3ddriver-hd51 en brengt het dus probleem weer terug, en dat is toch lastig. Ben ik de enige met dit probleem? Ik vind op het forum in ieder geval geen anderen.

 

En oh ja, autoinstall bevat volgens mij geen gekke pakketten.

bzip2
enigma2-meta
enigma2-plugin-extensions-addstreamurl
enigma2-plugin-extensions-automatic-fullbackup
enigma2-plugin-extensions-autotimer
enigma2-plugin-extensions-backupsuite
enigma2-plugin-extensions-dvdplayer
enigma2-plugin-extensions-epgimport
enigma2-plugin-extensions-epgimport-rytec
enigma2-plugin-extensions-fritzcall
enigma2-plugin-softcams-oscam
enigma2-plugin-systemplugins-automaticcleanup
enigma2-plugin-systemplugins-autoresolution
enigma2-plugin-systemplugins-defaultservicesscanner
enigma2-plugin-systemplugins-mphelp
enigma2-plugin-systemplugins-networkwizard
enigma2-plugins-meta
enigma2-skins-meta
file
liblzma5
liblzo2-2
libncursesw5
mtd-utils
mtd-utils-ubifs
nano
ncurses-terminfo
python-lzma
softcam-support
util-linux-blkid
zip

Alvast bedankt voor jullie antwoord!

 

Rob


Edited by robadouche, 1 July 2019 - 07:47.


Re: HD51 truncated libs - start niet door sinds release 7.1 #2 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 1 July 2019 - 07:56

Nog even teruggekeken naar het probleem dat ik in 7.1rc had met enigma2-plugin-extensions-qthbbtv , want daar waren de zelfde libs corrupt. Daar zit dus een relatie. In 7.1rc kon ik dat oplossen door enigma2-plugin-extensions-qthbbtv uit de autoinstall te halen. Maar blijkbaar zit het probleem iets dieper en is het setje libs zelf corrupt, of misschien niet geschikt voor de processor van de hd51 of zo? En waarom was dit probleem er in 6.2 niet? Ik ben even de draad kwijt.

 

https://forums.openpli.org/topic/69133-hd51-start-alleen-door-direct-na-flash-70-en-71rc/


Edited by robadouche, 1 July 2019 - 07:57.


Re: HD51 truncated libs - start niet door sinds release 7.1 #3 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 1 July 2019 - 14:34

Beiden worden gebouwd door de BSP van de fabrikant, dus niet iets wat wij verder onder controle hebben.

 

Ik heb beide pakketten uit de build cache verwijderd, en een nieuwe 7.1-release build voor de hd51 ingepland. Misschien vanavond even kijken of dat uit maakt?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: HD51 truncated libs - start niet door sinds release 7.1 #4 WTE

  • Senior Member
  • 680 posts

+30
Good

Posted 1 July 2019 - 16:42

Komt door https://github.com/H...-utgard.inc#L32

 

Maar heeft verder geen schadelijk effect. Ik heb al doorgegeven als ze dit in volgende update willen verwijderen voor de cosmetisch view.

 

Ik verwacht dat er toch nog iets anders bij je is wat dit veroorzaakt.


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: HD51 truncated libs - start niet door sinds release 7.1 #5 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 2 July 2019 - 19:16

 

Ik heb beide pakketten uit de build cache verwijderd, en een nieuwe 7.1-release build voor de hd51 ingepland.

Je bedoelt hd-v3ddriver-hd51 en enigma2-plugin-extensions-qthbbtv ?

 

 

Misschien vanavond even kijken of dat uit maakt?

Gedaan, 1 juli flash, geen verschil. Volgens mij zit hd-v3ddriver-hd51 nog in de build. Kan dat kloppen? Of wordt hij meegeladen met 1 van mijn autoinstall-pakketten. Ik heb alleen geen afhankelijkheden kunnen vinden.

 

 

Maar heeft verder geen schadelijk effect.

Behalve dan dat enigma niet wil starten? :P



Re: HD51 truncated libs - start niet door sinds release 7.1 #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 2 July 2019 - 21:50

Gedaan, 1 juli flash, geen verschil. Volgens mij zit hd-v3ddriver-hd51 nog in de build. Kan dat kloppen? Of wordt hij meegeladen met 1 van mijn autoinstall-pakketten. Ik heb alleen geen afhankelijkheden kunnen vinden.

 

Ja uiteraard. Die wordt door de BSP gebouwd, dus ik ga er even van uit dat die nodig is.

 

Wel vreemd overigens dat jij de enige HD51 gebruiker bent die dit meldt?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: HD51 truncated libs - start niet door sinds release 7.1 #7 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 3 July 2019 - 07:39

 

Wel vreemd overigens dat jij de enige HD51 gebruiker bent die dit meldt?

 

Dat vind ik ook, daarom keek ik in eerste instantie naar mijn autoinstall-lijst om te zien of daar iets vreemds tussen staat wat er niet hoort. Suggesties?

bzip2
enigma2-meta
enigma2-plugin-extensions-addstreamurl
enigma2-plugin-extensions-automatic-fullbackup
enigma2-plugin-extensions-autotimer
enigma2-plugin-extensions-backupsuite
enigma2-plugin-extensions-dvdplayer
enigma2-plugin-extensions-epgimport
enigma2-plugin-extensions-epgimport-rytec
enigma2-plugin-extensions-fritzcall
enigma2-plugin-softcams-oscam
enigma2-plugin-systemplugins-automaticcleanup
enigma2-plugin-systemplugins-autoresolution
enigma2-plugin-systemplugins-defaultservicesscanner
enigma2-plugin-systemplugins-mphelp
enigma2-plugin-systemplugins-networkwizard
enigma2-plugins-meta
enigma2-skins-meta
file
liblzma5
liblzo2-2
libncursesw5
mtd-utils
mtd-utils-ubifs
nano
ncurses-terminfo
python-lzma
softcam-support
util-linux-blkid
zip


Re: HD51 truncated libs - start niet door sinds release 7.1 #8 WTE

  • Senior Member
  • 680 posts

+30
Good

Posted 3 July 2019 - 11:45

Wat je kan proberen is

telnet/putty command: dmesg

en ook:

init 4

enigma2

 

En kijk als je een fout melding krijgt.


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:


Re: HD51 truncated libs - start niet door sinds release 7.1 #9 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 5 July 2019 - 09:24

Ik ben trouwens niet de enige met dit probleem en het probleem is ook niet beperkt tot de HD51:

 

https://forums.openp...truncated files



Re: HD51 truncated libs - start niet door sinds release 7.1 #10 littlesat

  • PLi® Core member
  • 49,168 posts

+527
Excellent

Posted 5 July 2019 - 09:28

Dat is een heel antieke post en zover ik weet al lang opgelost...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: HD51 truncated libs - start niet door sinds release 7.1 #11 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 5 July 2019 - 09:35

Dat is een heel antieke post en zover ik weet al lang opgelost...

Nog iets antieker (wel half jaar oud) https://forums.openp...rmation/page-22 ook met hetzelfde probleem. En blijkbaar is het nog niet opgelost, want ik heb er nog steeds last van.

 

Uit de antieke post:

Die hele qt handel is zo wie zo een grote rotzooi, het wordt door de build in de shared feed gegooid, maar eigenlijk is het niet shared maar box specifiek. Kans is dus groot dat er voor de h9 bij de laatste builds niks aangepast is, maar voor een andere box (bv een hd51) wel, en dan krijg jij de hd51 files binnen (want die overschrijven elkaar).

Ik begrijp uit de antieke post dat het iets met de qt-libs te maken heeft. Ik had vroeger wel enigma2-plugin-extensions-qthbbtv, maar die heb ik er al een paar maanden af, werkte toch niet meer. En daarna al vele malen vers geflashed. Dat zou het dus niet moeten zijn, toch? Als ik dit goed lees, zou het zo kunnen zijn dat ik de libs binnen krijg voor een heel andere box, dat die overschreven worden, en dat mijn box er dus niets mee kan, want voor ander platform?

 

En dan heb ik nog steeds de vraag of dat hele pakket wel nodig is. Als ik ze namelijk verwijder met "opkg remove hd-v3ddriver-hd51" dan lijkt alles nog gewoon goed te werken. Alleen na elke flash of update komt het probleem weer terug.


Edited by robadouche, 5 July 2019 - 09:38.


Re: HD51 truncated libs - start niet door sinds release 7.1 #12 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 5 July 2019 - 12:16

  1. "opkg list-installed | grep qt" geeft geen resultaten, dus blijkbaar heb ik geen "qt handel" geïnstalleerd.
  2. Alle truncated libs zijn links naar /usr/lib/libv3ddriver.so Kennelijk is dat bestand, dat in de image zit niet bestemd voor het hd51 platform? Daar zouden dan toch meer hd51 gebruikers last van moeten hebben? Ik zal vanavond eens een flash doen zonder autoinstall en zonder settings restore. Kijken wat er dan gebeurt.
  3. hd-v3ddriver-hd51 depends on:
            libc6 (>= 2.25)
    root@hd51:~# opkg whatdepends hd-v3ddriver-hd51
    Root set:
      hd-v3ddriver-hd51
    What depends on root set
    

Edited by robadouche, 5 July 2019 - 12:19.


Re: HD51 truncated libs - start niet door sinds release 7.1 #13 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 18 July 2019 - 16:23

Hoi, heeft even geduurd, maar bij de laatste update ging het weer niet goed. Dus, ik heb gedaan wat ik hierboven zei: clean install, geen settings teruggezet en geen plugins geinstalleerd, ook geen autoinstall. Door de setupwizart met volgende volgend volgende.

 

En de uitkomst van ldconfig:

ldconfig: file /usr/lib/libEGL.so.1 is truncated
ldconfig: file /usr/lib/libv3ddriver.so is truncated
ldconfig: file /usr/lib/libEGL.so is truncated
ldconfig: file /usr/lib/libGLESv1_CM.so.1 is truncated
ldconfig: file /usr/lib/libGLESv2.so is truncated
ldconfig: file /usr/lib/libGLESv1_CM.so is truncated
ldconfig: file /usr/lib/libGLESv1_CM.so.1.1 is truncated
ldconfig: file /usr/lib/libGLESv2.so.2.0 is truncated
ldconfig: file /usr/lib/libgbm.so.1 is truncated
ldconfig: file /usr/lib/libGLESv2.so.2 is truncated
ldconfig: file /usr/lib/libgbm.so is truncated
ldconfig: file /usr/lib/libEGL.so.1.4 is truncated

En bij de eerste reboot blijft hij hangen. Ook een helemaal schone box. Er is toch iets niet goed met de image. En ik denk dat de EGL libs voor een ander platform zijn. Dat was ook het geval met de ZGEMMA H9 in februari. https://forums.openp...truncated files


Edited by robadouche, 18 July 2019 - 16:28.


Re: HD51 truncated libs - start niet door sinds release 7.1 #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 18 July 2019 - 18:23

Dan is de vraag is de image fout is, of de package, of allebei. Of dat er bij de installatie iets corrupt is geraakt.

 

Al die files in de output zijn symlinks, en die wijzen allemaal naar /usr/lib/libv3ddriver.so. Die is in de package 1053608 bytes. Als die op jou systeem anders is, probeer eens:

opkg install hd-v3ddriver-hd51 --force-reinstall

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: HD51 truncated libs - start niet door sinds release 7.1 #15 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 19 July 2019 - 08:51

Hoi, dank voor je antwoord! Zie hieronder de output. Hij was al 1053608 groot. Net als in de package. Na geforceerd herinstalleren nog steeds even groot. En nog steeds de truncated libs.

root@hd51:~# ls -l /usr/lib/libv3ddriver.so
-rwxr-xr-x    1 root     root       1053608 Jul  1 15:26 /usr/lib/libv3ddriver.so
root@hd51:~# opkg install hd-v3ddriver-hd51 --force-reinstall
Downloading http://downloads.openpli.org/feeds/openpli-7-release/hd51/hd-v3ddriver-hd51_20170322-r0.0_hd51.ipk.
Installing hd-v3ddriver-hd51 (20170322) on root
Configuring hd-v3ddriver-hd51.
/sbin/ldconfig: file /usr/lib/libEGL.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libv3ddriver.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2.0 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so.1.4 is truncated
root@hd51:~# ls -l /usr/lib/libv3ddriver.so
-rwxr-xr-x    1 root     root       1053608 Jul  1 15:26 /usr/lib/libv3ddriver.so


Re: HD51 truncated libs - start niet door sinds release 7.1 #16 Loui (PD1LOI)

  • Senior Member
  • 2,993 posts

+68
Good

Posted 19 July 2019 - 11:30

 

Hoi, dank voor je antwoord! Zie hieronder de output. Hij was al 1053608 groot. Net als in de package. Na geforceerd herinstalleren nog steeds even groot. En nog steeds de truncated libs.

root@hd51:~# ls -l /usr/lib/libv3ddriver.so
-rwxr-xr-x    1 root     root       1053608 Jul  1 15:26 /usr/lib/libv3ddriver.so
root@hd51:~# opkg install hd-v3ddriver-hd51 --force-reinstall
Downloading http://downloads.openpli.org/feeds/openpli-7-release/hd51/hd-v3ddriver-hd51_20170322-r0.0_hd51.ipk.
Installing hd-v3ddriver-hd51 (20170322) on root
Configuring hd-v3ddriver-hd51.
/sbin/ldconfig: file /usr/lib/libEGL.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libv3ddriver.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so is truncated
/sbin/ldconfig: file /usr/lib/libGLESv1_CM.so.1.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2.0 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so.1 is truncated
/sbin/ldconfig: file /usr/lib/libGLESv2.so.2 is truncated
/sbin/ldconfig: file /usr/lib/libgbm.so is truncated
/sbin/ldconfig: file /usr/lib/libEGL.so.1.4 is truncated
root@hd51:~# ls -l /usr/lib/libv3ddriver.so
-rwxr-xr-x    1 root     root       1053608 Jul  1 15:26 /usr/lib/libv3ddriver.so

Heb het bij mij ook even getest omdat ik ook een HD51 heb en de uitkomst is precies het zelfde als bij jou.


Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli v7.0. 

Bereikbaar op BM 204 NL-DMR


Re: HD51 truncated libs - start niet door sinds release 7.1 #17 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 19 July 2019 - 14:49

Dan weten we in ieder geval dat het probleem hem zit in of het build proces, of de aanlevering, en niet in de distributie of de installatie.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: HD51 truncated libs - start niet door sinds release 7.1 #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 19 July 2019 - 14:55

Probeer deze eens?

 

Deze komt rechtstreeks uit de download van Mutant, als binary. Als die het wel doet, dan zit er iets in de BSP dat 'm vernaggelt.

Attached Files


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: HD51 truncated libs - start niet door sinds release 7.1 #19 robadouche

  • Senior Member
  • 60 posts

0
Neutral

Posted 20 July 2019 - 00:42

Dat helpt. Als ik die over de corrupte lib heen zet, dan geeft ldconfig geen foutmelding meer. Als ik daarna weer het pakket herinstalleer, heb ik weer trunctated libs (eigenlijk 1, maar door de symlinks wordt het een lijstje). Ik ga morgenochtend een weekje op vakantie, dus ik kan pas weer testen als ik terug ben!

 

Wat is trouwens de BSP?



Re: HD51 truncated libs - start niet door sinds release 7.1 #20 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,380 posts

+821
Excellent

Posted 20 July 2019 - 12:44

Merci, dan weten we waar de oorzaak zit.

 

BSP = Board Support Package. De OpenEmbedded Linux layer die door de fabrikant geleverd wordt, en waarin alle box specifieke zaken zitten, zoals linux kernel, hardware drivers, etc. De fabrikant beheert die, wij kunnen die niet aanpassen.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users