Jump to content


Photo

sound settings alsa settings pre defined cards external amlifier

sound alsa alsa.config

  • This topic is locked This topic is locked
21 replies to this topic

#1 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 15 July 2019 - 21:11

I have "vu+ like" receiver: OPEN PLI 4, year 2015 chip BCM7358 and want to upgrade to the other modern model.

 

The "standard" configuration of video and of sound passes though HDMI interface or via "Lotus" connectors.

OPEN PLII engineers put ALSA configurations into

1. /etc/asound.conf  

2. multiple files in /user/share/alsa

where pre defined cards configuration location: /user/share/alsa/cards

 

Problem description:

1. I want to get

- video signal from the receiver (Enigma2) to the monitor via HDMI cable,

- sound signal from the receiver (Enigma2) to the amplifier or via DAC  via RCA connector (also known as Lotus connector)

2. But there is no description of enigma2 commands and of "guides" for the configuration of ALSA given by Open PlI engineers.

Actions:

I connect the amplifier or DAC to the receiver (2.0 stereo) RCA output and to the amplifier or to DAC input via RCA cable (Lotus connectors),

Open PLI command:

aplay -l , response: no sound device

lshw : no such command

lspci : no pci device (or similar response)

   

Questions to OPEN PLI ENGINEERS:

1. Which command can give the possibility to see my connected DAC (external sound card/amplifire) via RCA cable?

2. Which files and by which method shall I configure such files in order to see the external amplifier / DAC (external sound card) in telnet?

3. or : do you have the configuration files for 2.0 sound connection (stereo), which is separate from HDMI signal (I do not need audio signal to monitor via HDMI)?  

 

Thanks. 

ENCLOSED: RCA (Lotus) connectors from the OPEN PLI 4 receiver to amplifier.



Re: sound settings alsa settings pre defined cards external amlifier #2 -M-

  • Senior Member
  • 111 posts

+4
Neutral

Posted 16 July 2019 - 08:45

I have never heard about "Lotus" before. Are you talking about the SPDIF (RCA) connector in the STB?
or are you sometimes talking about analog RCA connectors (right + left) in the STB?

PS. S/PDIF output should be working. I am using it in DUO 4K. It is optical and called Toslink. It is the same signal as coax (RCA) S/PDIF.

Re: sound settings alsa settings pre defined cards external amlifier #3 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 16 July 2019 - 13:00

Irrelevant. The above topic is related to the exact desription of the configuration, addressed to the engneers and is not intended to a user with lack of knowledge, or to a blind user.


Edited by crocuz, 16 July 2019 - 13:02.


Re: sound settings alsa settings pre defined cards external amlifier #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 16 July 2019 - 14:15

The box doesn't use ALSA, video and audio is entirely processed in hardware. All audio and all video is active on all outputs, at all times.

 

You say you want to look for another box. Most don't provide analogue out anymore. Why don't you use the digital out to connect to your amplifier? That is what it is there for? 


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: sound settings alsa settings pre defined cards external amlifier #5 Trial

  • Senior Member
  • 987 posts

+29
Good

Posted 16 July 2019 - 15:15

Hi,

always nice to offend a user with the 2nd post.

 

Ralf



Re: sound settings alsa settings pre defined cards external amlifier #6 betacentauri

  • PLi® Core member
  • 5,528 posts

+252
Excellent

Posted 16 July 2019 - 16:39

Yes, right Trial.

 

And when I read this

"vu+ like" receiver:

it seems to me it's a clone. Or what is "vu+ like"?

No, support for clones and the rest was already written by WanWizard.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: sound settings alsa settings pre defined cards external amlifier #7 -M-

  • Senior Member
  • 111 posts

+4
Neutral

Posted 16 July 2019 - 18:30

Irrelevant. The above topic is related to the exact desription of the configuration, addressed to the engneers and is not intended to a user with lack of knowledge, or to a blind user.

Sorry for offend you or someone else. If you relate to me what you wrote, I will only reply that you don't know me.

PS. The first post include statements and questions that is not in line with reality. Therefor it is (as I see it) difficult to give any good answers. Correct facts about the specific use case is needed first. It seems the user try to do something that is impossible. But okay, I will leave this thread. Only wanted to help, because I thought what the user want to to is very simple.

Re: sound settings alsa settings pre defined cards external amlifier #8 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 24 July 2019 - 23:10

The box doesn't use ALSA, video and audio is entirely processed in hardware. All audio and all video is active on all outputs, at all times.

 

You say you want to look for another box. Most don't provide analogue out anymore. Why don't you use the digital out to connect to your amplifier? That is what it is there for? 

Clear. Done.

 

Due to over emotions of the users, I repeat the primary problem:-

 

Problem description:

1. I want to get

- video signal from the receiver (Enigma2 / ) to the monitor, not TV, via HDMI cable,

and

sound signal from the receiver (Enigma2) via the amplifier or via DAC  connector 

 

2. There is no description of enigma2 commands and of "guides" for the separtrate configuration of ALSA given by Open PlI engineers.

OPEN PLI is enigma2 based system. So I can use ALSA for my configuration also: opkg install alsa-util  is it correct?

After DAC is connected via SPDIF in Open Pli, the OPEN PLI 4 does not see or can not identify DAC:

 

configuaration: etc/asound.config :
pcm.!spdif {
     type hw
     card 0
     device 0
}
pcm.!default {
     type plug
     slave {
           pcm "spdif"
     }
}
  

Open PLI commands and responces:

aplay -l : no sound device

lshw : no such command

lspci : no pci device (or similar response)

   

Questions to ENIGMA2 ENGINEERS:

1. Which command gives the possibility to see my connected DAC (external sound card/amplifire)?

2. Which files and which exact lines can be configured in addition in order to see the connected external amplifier / DAC (external sound card) ? -- 

 

Thanks, engineers.



Re: sound settings alsa settings pre defined cards external amlifier #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 24 July 2019 - 23:31

I got the question, but you didn't get my answer.

 

1. Audio and Video is completely processed in hardware, you can't control it. It is sent out through all available ports, simultaneously, and always.

 

2. The hardware doesn't use ALSA, it simply doesn't work.

 

Which I already replied in post #4.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: sound settings alsa settings pre defined cards external amlifier #10 mrvica

  • Senior Member
  • 736 posts

+45
Good

Posted 25 July 2019 - 07:13

you can get the (analog) sound from the headphone output of your hdmi monitor, just connect it with the amplifier, to use the SPDIF (digital) output oy your box you need an external DAC or an amplifier with digital input

Re: sound settings alsa settings pre defined cards external amlifier #11 -M-

  • Senior Member
  • 111 posts

+4
Neutral

Posted 25 July 2019 - 12:33

1. I want to get
- video signal from the receiver (Enigma2 / ) to the monitor, not TV, via HDMI cable,
and
sound signal from the receiver (Enigma2) via the amplifier or via DAC  connector

This is normal. The audio you can take from s/pdif (RCA or TosLink, if your STB have it). Note however, if you connect the spdif signal to a DAC (not a AVR, Home Cinema Receiver). The dac most likely only can handle PCM stereo sound format. For example if you watch a channel that sends out the audio in AC3 format. The DAC will not give you sound, or you might get ugly noise. In OpenPLi it is a setting called downmix (or similar), This change the sound format to normal stereo pcm (it also downmix multichannel to 2ch). This setting is available both on a global level and a per TV-channel level. Also a setting which says that one have higher priority, over the other setting. One of these settings you can simple see by pressing the Audio button on the remote.

Edited by -M-, 25 July 2019 - 12:36.


Re: sound settings alsa settings pre defined cards external amlifier #12 rantanplan

  • Senior Member
  • 163 posts

+5
Neutral

Posted 25 July 2019 - 12:40


 

2. The hardware doesn't use ALSA, it simply doesn't work.

 

If you knew what box it is?

With alsa it is the case that it is usually built via config.
However, no values ​​are set.
This is possible but already.
If one were to pretend values ​​there, then one would have the possibility, as I understand it, of adapting them afterwards.



Re: sound settings alsa settings pre defined cards external amlifier #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 25 July 2019 - 13:50

I suggest you make it working then. Have fun, it's all yours. Let us know how it went.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: sound settings alsa settings pre defined cards external amlifier #14 rantanplan

  • Senior Member
  • 163 posts

+5
Neutral

Posted 25 July 2019 - 15:02

Should only be an idea, but if you feel directly attacked?

Nobody can help with the box mentioned above because it was not mentioned by name.
An old xtrend et4000 has the same chipset.

Anyway, it's probably too hot for such things.
No problem.



Re: sound settings alsa settings pre defined cards external amlifier #15 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 25 July 2019 - 15:17

 


 

2. The hardware doesn't use ALSA, it simply doesn't work.

 

If you knew what box it is?

With alsa it is the case that it is usually built via config.
However, no values ​​are set.
This is possible but already.
If one were to pretend values ​​there, then one would have the possibility, as I understand it, of adapting them afterwards.

 

 

1. I want to get
- video signal from the receiver (Enigma2 / ) to the monitor, not TV, via HDMI cable,
and
sound signal from the receiver (Enigma2) via the amplifier or via DAC  connector

This is normal. The audio you can take from s/pdif (RCA or TosLink, if your STB have it). Note however, if you connect the spdif signal to a DAC (not a AVR, Home Cinema Receiver). The dac most likely only can handle PCM stereo sound format. For example if you watch a channel that sends out the audio in AC3 format. The DAC will not give you sound, or you might get ugly noise. In OpenPLi it is a setting called downmix (or similar), This change the sound format to normal stereo pcm (it also downmix multichannel to 2ch). This setting is available both on a global level and a per TV-channel level. Also a setting which says that one have higher priority, over the other setting. One of these settings you can simple see by pressing the Audio button on the remote.

 

Gentlemen,

 

Thank you for your attempts to answer, but you did not make the general sense:

OPEN PLI is a custom made system, which use elements of enigma2 system.

Both sytems do not have the relevant published standards, which can allow the user to undertsand the essence : what is OPEN PLI at all.

I refer to version 4 of Openpli - the product which is not defined, not explained to any one in a plain engineering language.

OPEN PLI is soft without standards and without tech descripton for end user and for a manufacturer.

Do you understand ?  

 

HARDWARE:

The box of my product shows : VU SOLO PRO3.

It  related the marketing of manufacturer but, not to open pli  - your sytem.

So all explanations can be given by simple decsription, which is not relevent to standard.

 

OPEN PLI 4 after commands: opkg update && opkg upgrade

 

Goal
I want to get
- video signal from the receiver (Enigma2 / ) to the monitor, not TV, via HDMI cable,
and
- sound signal from the receiver (Enigma2) via the amplifier or via DAC  connector 
 
There is no description of enigma2 commands and configuartion files.
After DAC is connected via SPDIF in Open Pli recever, the OPEN PLI 4 does not see and can not identify DAC.
I can connect the amplifier to DAC and to speakers in addition. 
 
Commands:
opkg install alsa- utils
opkg install alsa- lib
aplay -l , response: no sound device

lshw : no such command

lspci : no pci device (or similar response)

 
I made the configuaration as follows:
 
etc/asound.config :
pcm.!spdif {
     type hw
     card 0
     device 0
}
pcm.!default {
     type plug
     slave {
           pcm "spdif"
     }
}
  
-- EOF --
 
Open PLI commands and responces:
aplay -l : no sound device
lshw : no such command
lspci : no pci device 
 
   
Questions to ENIGMA2 ENGINEERS:
Which files and which exact lines can be configured in addition in order to see the connected  DAC (external sound card) ? 
 
 
 

 

 

 

 

 

 


Edited by crocuz, 25 July 2019 - 15:20.


Re: sound settings alsa settings pre defined cards external amlifier #16 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 25 July 2019 - 15:38

[post]https://forums.openp...r/#entry1085957[/post]

 

The primary config in my OPEN PLI 4 device

etc/asound.config 

pcm.!default {

    type plug
    slave.pcm "hw:0"
}
ctl.mixer0 {
    type hw
    card 0
}
-- EOF --

Edited by crocuz, 25 July 2019 - 15:42.


Re: sound settings alsa settings pre defined cards external amlifier #17 betacentauri

  • PLi® Core member
  • 5,528 posts

+252
Excellent

Posted 25 July 2019 - 16:12

As expected a clone box.
But nevertheless it won’t work. You cannot add an external soundcard. WanWizard already told you 2 times.
And as it’s a clone you won’t get any support from VU. And even if it would be a genuine box it is quite old and don’t expect any new features to be added to it.

Edited by betacentauri, 25 July 2019 - 16:14.

Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: sound settings alsa settings pre defined cards external amlifier #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 25 July 2019 - 16:15

Should only be an idea, but if you feel directly attacked?

 

I don't feel attacked. I only have said twice that it wil not work, but the TS continues to ask, and you seem to suggest you know exactly how to do it.  

 

All I said was that if you think you are right and I am wrong, please feel free to help the TS implement it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: sound settings alsa settings pre defined cards external amlifier #19 crocuz

  • Member
  • 6 posts

0
Neutral

Posted 28 July 2019 - 19:40

As expected a clone box.
But nevertheless it won’t work. You cannot add an external soundcard. WanWizard already told you 2 times.
And as it’s a clone you won’t get any support from VU. And even if it would be a genuine box it is quite old and don’t expect any new features to be added to it.

 

I did not ask support of unknown vu.

"Clone"" is a term for a housewife.

Also explained above: open pli is clone of enigma2 according to your appreciations.

I use open pli 4 for 3 years and ask a question to engineers here.

In total: useless answer of an engineers: you stated clear foolish regarding impossibility to set up external card (DAC) in open pli 4 (enigma2).

 

https://forums.openp.../#entry1085957 

 

I will not purchace product with open pli.


Edited by crocuz, 28 July 2019 - 19:44.


Re: sound settings alsa settings pre defined cards external amlifier #20 Pr2

  • PLi® Contributor
  • 3,720 posts

+158
Excellent

Posted 28 July 2019 - 20:22

Engineer told you that Enigma2/OpenPLi is not using Alsa driver at all,  and you don't want to understand this.

 

https://forums.openp...dpost&p=1082433

 

 

The box doesn't use ALSA, video and audio is entirely processed in hardware. All audio and all video is active on all outputs, at all times.

 


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users