Jump to content


Photo

Kodi 17.6 krypton plugin problem


  • Please log in to reply
17 replies to this topic

#1 darius

  • Member
  • 11 posts

0
Neutral

Posted 16 July 2019 - 22:13

HI

kodi 17.6 plugin dose not working on Open Pli 7.1 is it possible to add new version kodi 18 on downlod or at list fix the problem which is non of the video addons works well, when you chose a video , film  on any addons you just get back screen.

It works on other Image .

It did works on Open Pli 7 But not works on  new versin of Open Pli 7.1.



Re: Kodi 17.6 krypton plugin problem #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,829 posts

+803
Excellent

Posted 16 July 2019 - 23:03

I don't think any of us uses kodi, which means someone needs to be willing to look at it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Kodi 17.6 krypton plugin problem #3 darius

  • Member
  • 11 posts

0
Neutral

Posted 17 July 2019 - 08:12

I don't think any of us uses kodi, which means someone needs to be willing to look at it.

There are meny some use kodi,but what abuot my answer,why it dose  not works for newer version? are you going to fix it or not? or is it possible have kodi 18 or 19 in plugin section?

Regards.Darius


Edited by darius, 17 July 2019 - 08:13.


Re: Kodi 17.6 krypton plugin problem #4 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,915 posts

+195
Excellent

Posted 17 July 2019 - 09:13

Kodi never had any priority for OpenPLi. In case it would have been possible that Kodi worked without causing any issues then it would have been present and updated on a regular base. As this definitely isn’t the fact don’t count on it that Kodi 18 or even 19 will be present in our image. Unless, as Wanwizard already stated, several of our developers are willing to put extra effort in it. What the future brings, no one knows. ;)

I can imagine that this answer doesn’t satisfy you but it is as it is. We aim for stability in our image and the presence of Kodi doesn’t really help.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Kodi 17.6 krypton plugin problem #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,829 posts

+803
Excellent

Posted 17 July 2019 - 10:49

Unless, as Wanwizard already stated, several of our developers are willing to put extra effort in it. What the future brings, no one knows. ;)

 

I was more thinking about someone in the community, as none of our developers use Kodi, and maintaining for all the different hardware OpenPLi supports is a right nightmare...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Kodi 17.6 krypton plugin problem #6 A.A.

  • Senior Member
  • 51 posts

0
Neutral

Posted 17 July 2019 - 11:15

It seems the kodi v.18 development for enigma2 has somehow stalled. Even the folks at oe-alliance are at v.17.6.

 

Honestly after the cross-compilation for mipsel was solved I'd hoped someone would jump in and finish the works but it must not be that easy...

 

 

@darius

if it's only about add-ons, just try KodiLite on OpenPLi 7.1

I might insist and have Kodi 17.6 working on my vuduo2 on OpenPLi but I'd rather spend the efforts on kodi 18.x.

 

 

Cheers

A.A.



Re: Kodi 17.6 krypton plugin problem #7 darius

  • Member
  • 11 posts

0
Neutral

Posted 17 July 2019 - 13:19

It seems the kodi v.18 development for enigma2 has somehow stalled. Even the folks at oe-alliance are at v.17.6.

 

Honestly after the cross-compilation for mipsel was solved I'd hoped someone would jump in and finish the works but it must not be that easy...

 

 

@darius

if it's only about add-ons, just try KodiLite on OpenPLi 7.1

I might insist and have Kodi 17.6 working on my vuduo2 on OpenPLi but I'd rather spend the efforts on kodi 18.x.

 

 

Cheers

A.A.

 I am using uno4kse and I don see any kodi lite in dwonload lista, by the way ,thanks.



Re: Kodi 17.6 krypton plugin problem #8 darius

  • Member
  • 11 posts

0
Neutral

Posted 17 July 2019 - 13:21

Kodi never had any priority for OpenPLi. In case it would have been possible that Kodi worked without causing any issues then it would have been present and updated on a regular base. As this definitely isn’t the fact don’t count on it that Kodi 18 or even 19 will be present in our image. Unless, as Wanwizard already stated, several of our developers are willing to put extra effort in it. What the future brings, no one knows. ;)

I can imagine that this answer doesn’t satisfy you but it is as it is. We aim for stability in our image and the presence of Kodi doesn’t really help.

factice not, but thanks anyway.



Re: Kodi 17.6 krypton plugin problem #9 darius

  • Member
  • 11 posts

0
Neutral

Posted 17 July 2019 - 13:22

 

Unless, as Wanwizard already stated, several of our developers are willing to put extra effort in it. What the future brings, no one knows. ;)

 

I was more thinking about someone in the community, as none of our developers use Kodi, and maintaining for all the different hardware OpenPLi supports is a right nightmare...

 

ok thanks



Re: Kodi 17.6 krypton plugin problem #10 darius

  • Member
  • 11 posts

0
Neutral

Posted 17 July 2019 - 13:30

Kodi never had any priority for OpenPLi. In case it would have been possible that Kodi worked without causing any issues then it would have been present and updated on a regular base. As this definitely isn’t the fact don’t count on it that Kodi 18 or even 19 will be present in our image. Unless, as Wanwizard already stated, several of our developers are willing to put extra effort in it. What the future brings, no one knows. ;)

I can imagine that this answer doesn’t satisfy you but it is as it is. We aim for stability in our image and the presence of Kodi doesn’t really help.

Open Pli ia the best,I love it. but you know that it is a compitations over ,which team do the best image ,while other teams image have a funktionelt kodi ,it is a negative reaction for Open Pli that is unfunktionable kodi on thire imga, I undrstand it not priority but it is a important that allting works well.

Thanks anyway.



Re: Kodi 17.6 krypton plugin problem #11 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,915 posts

+195
Excellent

Posted 17 July 2019 - 14:24

I disagree. I just want to remind everyone that the basis function of these kind of hardware actually is to watch television via satellite, cable or terrestrial. This hardware isn’t a mediaplayer although many people would like it to be. Be happy with the functions that are available and usually are stable. That is our main goal. ;)
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Kodi 17.6 krypton plugin problem #12 A.A.

  • Senior Member
  • 51 posts

0
Neutral

Posted 18 July 2019 - 09:17

I disagree. I just want to remind everyone that the basis function of these kind of hardware actually is to watch television via satellite, cable or terrestrial. This hardware isn’t a mediaplayer although many people would like it to be. Be happy with the functions that are available and usually are stable. That is our main goal. ;)

 

Hi,

no, please, don't start this rant again.

We know there are modern smart-tv and android-boxes but I don't want/need one more device: already my old vuduo2 has more than enough juice for multimedia apps.

 

There are many other priorities, we know, like the old OE checkouts OpenPLi is based on, the painful enigma2 spaghetti-code, the unmaintained vendor's bsp, etc. etc.

Neverthless we can't just ignore that most of the people who bought (consciously) an enigma2 receiver do NOT just use it for TV but also as a NAS, or a media-player. I do.

 

The problem is that the extensions/plugins do not work or do not compare at all with the dedicated (xbmc) add-ons.

I imagine the reason behind this (vuplus fault) still we cannot force all the vendors to provide a working browser.

 

So while I agree many people are tempted by the gray-zone/pirates add-ons I give here my perfectly legal case: the Hbbtv extension does not work here in Italy for italian service providers (RAI on Demand).

The Kodi/KodiLite add-on does instead work.

For my machine I have been told a special kernel is needed for Kodi (different commandline I think btw) but this appears not to be mandatory because KodiLite 5 does indeed work on OpenPLi 7.1 (installed by hand its installer)

 

Now, what to do?

As OE developer I must have missed the tragedies behind the OE2/OE3 OE-Alliance, OpenPLi splits back in the years.

What I see is there are around the recipes for Kodi in almost any other 'distro' (big word).

 

Are there any more conceptual taboos?

Is it adviseable/permitted/suggested/accepted to just import the Kodi stuff from oe-alliance to the PLi layers?

 

Cheers

A.A.



Re: Kodi 17.6 krypton plugin problem #13 darius

  • Member
  • 11 posts

0
Neutral

Posted 18 July 2019 - 17:06

 

I disagree. I just want to remind everyone that the basis function of these kind of hardware actually is to watch television via satellite, cable or terrestrial. This hardware isn’t a mediaplayer although many people would like it to be. Be happy with the functions that are available and usually are stable. That is our main goal. ;)

 

Hi,

no, please, don't start this rant again.

We know there are modern smart-tv and android-boxes but I don't want/need one more device: already my old vuduo2 has more than enough juice for multimedia apps.

 

There are many other priorities, we know, like the old OE checkouts OpenPLi is based on, the painful enigma2 spaghetti-code, the unmaintained vendor's bsp, etc. etc.

Neverthless we can't just ignore that most of the people who bought (consciously) an enigma2 receiver do NOT just use it for TV but also as a NAS, or a media-player. I do.

 

The problem is that the extensions/plugins do not work or do not compare at all with the dedicated (xbmc) add-ons.

I imagine the reason behind this (vuplus fault) still we cannot force all the vendors to provide a working browser.

 

So while I agree many people are tempted by the gray-zone/pirates add-ons I give here my perfectly legal case: the Hbbtv extension does not work here in Italy for italian service providers (RAI on Demand).

The Kodi/KodiLite add-on does instead work.

For my machine I have been told a special kernel is needed for Kodi (different commandline I think btw) but this appears not to be mandatory because KodiLite 5 does indeed work on OpenPLi 7.1 (installed by hand its installer)

 

Now, what to do?

As OE developer I must have missed the tragedies behind the OE2/OE3 OE-Alliance, OpenPLi splits back in the years.

What I see is there are around the recipes for Kodi in almost any other 'distro' (big word).

 

Are there any more conceptual taboos?

Is it adviseable/permitted/suggested/accepted to just import the Kodi stuff from oe-alliance to the PLi layers?

 

Cheers

A.A.

 

 nice I agree ,



Re: Kodi 17.6 krypton plugin problem #14 darius

  • Member
  • 11 posts

0
Neutral

Posted 18 July 2019 - 17:12

I disagree. I just want to remind everyone that the basis function of these kind of hardware actually is to watch television via satellite, cable or terrestrial. This hardware isn’t a mediaplayer although many people would like it to be. Be happy with the functions that are available and usually are stable. That is our main goal. ;)

This is your idea but not All people  who use an enima2 devices.otherwise all othe team has a well funcktionable Image. :D


Edited by darius, 18 July 2019 - 17:13.


Re: Kodi 17.6 krypton plugin problem #15 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,915 posts

+195
Excellent

Posted 18 July 2019 - 17:30

No this is not specific my opinion about any Enigma2 receiver but the opinion of most of our internal members. Those plugins demand all kind of special adjustments in the BSP and most manufacturers aren’t that keen to change their BSP. We aim for a stable image which in the opinion of most, if not all manufacturers, are happy with the way our image works.
In case anyone isn’t happy with OpenPLi feel free to change your image and flash any other image which in his / her opinion is far better. And everyone is entitled to his own free opinion. I will never argue concerning this fact. :)
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Kodi 17.6 krypton plugin problem #16 darius

  • Member
  • 11 posts

0
Neutral

Posted 18 July 2019 - 17:52

No this is not specific my opinion about any Enigma2 receiver but the opinion of most of our internal members. Those plugins demand all kind of special adjustments in the BSP and most manufacturers aren’t that keen to change their BSP. We aim for a stable image which in the opinion of most, if not all manufacturers, are happy with the way our image works.
In case anyone isn’t happy with OpenPLi feel free to change your image and flash any other image which in his / her opinion is far better. And everyone is entitled to his own free opinion. I will never argue concerning this fact. :)

Do you think other teams dont aim for a stable image ? Its just Open Pil dose?  you are wrong We dont demand anything ,we just ask for help and have sugestions.



Re: Kodi 17.6 krypton plugin problem #17 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,915 posts

+195
Excellent

Posted 18 July 2019 - 18:35

Please read better. I did not say that you or any other members demand something. The plugin ‘demand’ or better require all kind of special adjustments in the BSP. And as all manufacturers maintain their own BSP they should fix those issues.
It seems to me that you aren’t aware of the way OpenPLi works. We ‘never’ create workaround for whatever issues. In case we created an issue we will fix this.
Besides this, we have a limited number of available hands to try to solve certain issues like Kodi and don’t forget this is just a hobby.

Suggestion where our developers might benefit are always welcome. Let’s see if and how our developers respond on all possible suggestions. Agreed?
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Kodi 17.6 krypton plugin problem #18 darius

  • Member
  • 11 posts

0
Neutral

Posted 20 July 2019 - 17:28

Please read better. I did not say that you or any other members demand something. The plugin ‘demand’ or better require all kind of special adjustments in the BSP. And as all manufacturers maintain their own BSP they should fix those issues.
It seems to me that you aren’t aware of the way OpenPLi works. We ‘never’ create workaround for whatever issues. In case we created an issue we will fix this.
Besides this, we have a limited number of available hands to try to solve certain issues like Kodi and don’t forget this is just a hobby.

Suggestion where our developers might benefit are always welcome. Let’s see if and how our developers respond on all possible suggestions. Agreed?

Meny Thank for all works you do and you andrstanig. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users