Jump to content


Photo

Geen externe ondertitel

Ondertitel 7.1 zgemma h9

  • Please log in to reply
17 replies to this topic

#1 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 11:34

Allereerst eens even wat complimenten voor de mensen die Openpli onderhouden.
Super!
Recent overgestapt naar een nieuwe Zgemma H9.2S (Xtrend kaput) en natuurlijk meteen Openpli erop gezet.
Installatie was probleemloos, kastje loopt als een zonnetje met de vertrouwde Openpli interface.
Knap gedaan mensen!

En nou is er toch een kleinigheid die ik moet melden,
Externe ondertitel werkt niet altijd, of eigenlijk, werkt meestal niet.
Mijn box is vandaag nog geupdate (draaide versie 7.1 van 22 juli, nu die van 24 juli), probleem is er nog.

Betreft dan ondertitel in een apart srt bestandje met dezelfde naam als de film in dezelfde map als de film. Werkte voorheen wel altijd (zelfde externe disk op et8000 met openpli 6).

De optie “schakel externe ondertitel automatisch in” staat aan, maar bij het afspelen van een film wordt de externe ondertitel niet automatisch geselecteerd. Selecteer ik hem zelf dan gebeurt er niks, ondertitel wordt niet weergegeven (werkte dus wel op mijn oude et8000).
Betreft films met extensie mp4, mpg, avi, mkv enzovoort.

Ik hoop dat de Openpli specialisten hier eens naar willen kijken.

Re: Geen externe ondertitel #2 40H3X

  • PLi® Contributor
  • 3,392 posts

+116
Excellent

Posted 25 July 2019 - 11:57

De oplossing is eenvoudig, als je de ondertitel muxed met de container gaat het eigenlijk altijd goed.

 

https://wiki.openpli...9_and_subtitles


Edited by 40H3X, 25 July 2019 - 11:57.

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB 2.5 inch - Amiko Viper Combo HDD - Edision OS mio 4K - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 4TB RAID 1
Software : OpenPLi - OScam - Settings van Hans  -  Autotimer  -  EPGImport


Re: Geen externe ondertitel #3 satenkabelgluurder

  • Senior Member
  • 109 posts

+1
Neutral

Posted 25 July 2019 - 12:54

Op je niet werkende .srt eens met notepad++ en kijk een wat je encoding is.

Bij mij werken soms ook externe subtitles niet, maar altijd is de encoding NIET UTF8 of regels zijn CR LF (Windows) ipv LF (Unix)

Met notepad++ kun je dat zomaar omzetten


Edited by satenkabelgluurder, 25 July 2019 - 12:54.


Re: Geen externe ondertitel #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 July 2019 - 13:48

Gebruikt die H9 niet die HiSil player, in plaats van gstreamer? Er staat mij bij dat srt support een van de ontbrekende zaken waren bij die player.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Geen externe ondertitel #5 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 15:15

Update, vanmiddag wat tips geprobeerd:

1. Multiplexen (met mkvtoolnix) lost het probleem niet op. Ondertitel is daarna intern/ingebouwd, maar wordt niet zichtbaar na selecteren.
2. SRT-bestanden gecheckt. Waren al goed, maar nogmaals met notepad++ UTF-8 en linefeed unix/LF ingesteld en opgeslagen. Ondertitel niet zichtbaar.
3. Kodi geinstalleerd en daarmee film afgespeeld. Warempel, ondertitel is zichtbaar, zowel als ik het srt-bestand kies als wanneer ik de ingebouwde ondertitel kies van de net nieuw gemuxte file.

Hmmm, ik heb voor nou even een oplossing.
Mocht er een betere zijn, dan hoor ik het graag.
Ik heb het gevoel dat er een bugje in zit, zeker omdat de menuoptie betreffende extern ondertitel laden aanstaat maar de externe ondertitel niet geselecteerd wordt.

Re: Geen externe ondertitel #6 satenkabelgluurder

  • Senior Member
  • 109 posts

+1
Neutral

Posted 25 July 2019 - 15:27

Ik heb zelf geen Zgemma, maar het lijkt erop dat de player die de Zgemma gebruikt geen support voor de srt subtitles heeft.

Of heb je wel 1 film met .srt file die wel werkt ?



Re: Geen externe ondertitel #7 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 15:48

Er staat Openpli op, dan gebruikt hij toch geen software meer van zgemma?

Ik heb trouwens net een film gevonden, mp4, met ingebouwde engelse ondertitel en externe nederlandse srt. Beide ondertitels zijn na selectie zichtbaar.
Begrijp er niks meer van...

Re: Geen externe ondertitel #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 July 2019 - 15:54

Er staat Openpli op, dan gebruikt hij toch geen software meer van zgemma

 

Nee, dat heeft daar niks mee van doen.

 

Zoals ik eerder schreef, de HiSil player ondersteunt geen srt files, de standaard gestreamer wel (maar die werkt dan weer niet op de box). Keuze van de de fabrikant, daar kunnen wij niks aan veranderen...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Geen externe ondertitel #9 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 16:26

Nog een film gevonden die het gewoon doetop deze zgemma, een mkv met externe srt.
Alle bestanden hebben altijd goed gespeeld op andere systemen (et8000, losse mediaspeler van netgear, zelfs via usb-poort op een philips-tv! van mijn broer). Kan toch niet zijn dat die player in de H9 het bij de sommige films wel doet en bij andere niet? Lijkt me sterk.

En ik vind het nog steeds vreemd dat die menu setting over de externe ondertitiel de selectie niet uitvoert.

Re: Geen externe ondertitel #10 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 July 2019 - 16:30

Lijkt me sterk.

 

Have it your way.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Geen externe ondertitel #11 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 16:40

Uhhh, ik begrijp niet wat je bedoelt.
Bedoel je dat die player srt-bestanden af en toe toch afspeelt?
Ik dacht dat omdat je eerder schreef dat die player geen externe srt-bestanden support, hij die ondertitels nooit laat zien en niet soms wel, soms niet.

Re: Geen externe ondertitel #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 July 2019 - 16:57

Nee, ik bedoel dat je de zoveelste bent die klaagt over problemen met externe srt's en die HiPlayer, en dat het bekend is dat die inderdaad het niet doet. Dat heb ik je al twee keer verteld. ;)

 

En niet alle media wordt door dezelfde player afgespeeld, dus het kan best dan sommige het wel doen, en andere niet.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Geen externe ondertitel #13 40H3X

  • PLi® Contributor
  • 3,392 posts

+116
Excellent

Posted 25 July 2019 - 17:03

WanWizard heeft je uitgelegd dat deze box iets anders werkt en dat dit iets anders werken niets met OpenPLi heeft te doen, maar met de makers van deze box, als het om het afspelen van movie bestanden gaat met losse .srt bestanden ( zie zijn opmerking #4 en #8).

Wat je kunt doen is de .str bestanden muxen met de container, dus .srt als het ware aan het movie bestand toevoegen en dan zou het goed moeten gaan. Als je de link, die ik heb gegeven naar de wiki volgt, kom je ook een link tegen van software die dat voor je kan doen.

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB 2.5 inch - Amiko Viper Combo HDD - Edision OS mio 4K - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 4TB RAID 1
Software : OpenPLi - OScam - Settings van Hans  -  Autotimer  -  EPGImport


Re: Geen externe ondertitel #14 et9000usr

  • Senior Member
  • 41 posts

0
Neutral

Posted 25 July 2019 - 17:23

Multiplexen (met mkvtoolnix) lost het probleem niet op.
Ondertitel is daarna inderdaad intern/ingebouwd, maar wordt niet zichtbaar op het scherm na selecteren.

Als ik het goed begrijp gebruikt deze H9 dus voor sommige bestanden een player die nooit srt ondertitels afspeelt, en soms gebruikt hij een player die dat om nog niet bekende reden soms wel en soms niet doet.
Kan ik niet zoveel mee, maar zeker bedankt voor alle hulp!
Lijkt me dat ik dan kodi ga gebruiken om films met externe ondertitel af te spelen, die geeft ze wel weer.

Thanks!

Edited by et9000usr, 25 July 2019 - 17:25.


Re: Geen externe ondertitel #15 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 25 July 2019 - 19:54

De h9 is een hisilicon box en gebruikt dan ook een aparte player van hisilicon en geen gstreamer of zo.
Deze speelt idd geen srt files (ondertitels) automatisch af,
Ze staan hoger in beeld (denk door extra linefeed) en ook heeft deze player nog wat problemen met streams omdat het soms onterecht dmr ziet. Ik heb alles gemeld dus het word w88 op nieuwe drivers

Met 2 x geel kan je wel handmatig de ondertitels aan zetten en kan zijn dat je dan wel ff de file 15 sec terug moet spoelen om ze
Uiteindelijk te zien

Edited by littlesat, 25 July 2019 - 19:56.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Geen externe ondertitel #16 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 16 August 2019 - 11:32

Met 2 x geel kan je wel handmatig de ondertitels aan zetten en kan zijn dat je dan wel ff de file 15 sec terug moet spoelen om ze
Uiteindelijk te zien

Als dat werkt, waarom zou het dan niet automatisch werkt? Ik hoor van Wanwizard dat ondertitels icm media icm hisil helemáál niet werken.

 

Ik weet wel een oplossing, de vraag is of TS daar blij van wordt: muxen naar een transport stream met teletext subs. Die worden afgespeeld zonder de specifieke hisil media engine.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Geen externe ondertitel #17 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 16 August 2019 - 12:37

Het werkt niet automatisch omdat de HiSilicon player (!= gstreamer uuh servicemp3 player) een srt niet automatisch afspeelt. Wij spelen srt files automatisch af omdat wij er destijds vanuit gingen dat een gebruiker die er bewust bijzetten om de ondertitel ook te kunnen zien (in srt files zit geen taal info!)... en dat is al heel heel lang geleden.


Edited by littlesat, 16 August 2019 - 12:38.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Geen externe ondertitel #18 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 13 September 2019 - 18:35

Nah, een jaar of drie. En kennelijk doet men dat in de hisil player niet.

 

Ik vind sowieso losse ondertitels een abominatie (o.a. inderdaad omdat je dan geen taal of encoding weet), gewoon in de media muxen en opgelost.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





Also tagged with one or more of these keywords: Ondertitel, 7.1, zgemma h9

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users