Jump to content


Photo

OSMIO4K Multiboot Crash (Pli 7.1)


  • Please log in to reply
57 replies to this topic

Re: OSMIO4K Multiboot Crash (Pli 7.1) #41 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 23 September 2019 - 16:02

Then we should be fine with my suggested code above. It takes this data/time and in case something wierd happens due to not having a time/date after first boot it falls back to the bootlogo.mvi or enigma2 binary whichever of those to is the latest. This should work for any image as long the status file and enigma2 binary are on the same location.

Or can we find a better method...

 

It would be nice when ntpd could be involved here.... During restore/auto install the time/date is unknown because it did not tune a transponder yet.


Edited by littlesat, 23 September 2019 - 16:06.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #42 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 23 September 2019 - 16:35

My suggestion even works when none of those are true.

 

The only reason for opkg.list not to exist is if there is no opkg package. In which case /var/lib/opkg won't even exist.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #43 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 23 September 2019 - 17:23

Uuuh you also saw the 1970 issue???

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #44 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 23 September 2019 - 17:31

On /var/lib/opkg/status, yes, I can confirm the restore of the backup resets that timestamp. If you flash and don't restore a backup, the timestamp is the build date.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #45 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 23 September 2019 - 17:58

The restore does not change the timestamp as during restore/AutoInstall no transponder is tuned the box stays in 1970...

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #46 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 23 September 2019 - 18:01

When you flash the box WITHOUT a restore, the status file has the same timestamp als all the other files: the time on the buildserver when the rootfs was created.

 

When you flash WITH a restore, you do an "opkg update" before running "opkg install" from autoinstall, which will reset the timestamp as the box doesn't have transponder time at that moment.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #47 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 23 September 2019 - 18:16

Exactly that is what happens... and before doing the opkg update set the time to eg that status file is also obvious...

Edited by littlesat, 23 September 2019 - 18:17.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #48 Abu Baniaz

  • PLi® Contributor
  • 1,083 posts

+25
Good

Posted 23 September 2019 - 20:06

On other images, ntpdate is installed and there is a script in E2 startup to update date.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

Re: OSMIO4K Multiboot Crash (Pli 7.1) #49 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 23 September 2019 - 20:15

We'll add that too (it is on the todo list), but my check works even without internet or transponder connections.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #50 eelstrebor

  • New Member
  • 1 posts

0
Neutral

Posted 25 September 2019 - 17:27

Since my crash log had significant differences with elbandido's original log posting, here's mine.

Attached Files



Re: OSMIO4K Multiboot Crash (Pli 7.1) #51 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 September 2019 - 17:31

Same issue:

Traceback (most recent call last):
  File "/usr/lib/enigma2/python/Components/Console.py", line 37, in finishedCB
  File "/usr/lib/enigma2/python/Tools/Multiboot.py", line 57, in appClosed
OSError: [Errno 2] No such file or directory: '/tmp/testmount/usr/share/bootlogo.mvi'

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #52 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 25 September 2019 - 19:02

Solved in 7.2... maybe cherry pick?
But it is still wierd as you have an image that does something wierd with the bootlogo.mvi

Edited by littlesat, 25 September 2019 - 19:03.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #53 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 25 September 2019 - 19:02

7.2 will be out soon.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #54 el bandido

  • Senior Member
  • 138 posts

+5
Neutral

Posted 25 September 2019 - 20:59

Confirmed Fixed in 7.2. Thanks!



Re: OSMIO4K Multiboot Crash (Pli 7.1) #55 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 25 September 2019 - 21:11

Thanks for the feedback

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #56 Pr2

  • PLi® Contributor
  • 3,648 posts

+156
Excellent

Posted 28 September 2019 - 16:15

One more reason to switch to ntp by default and use transponder time as backup solution.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: OSMIO4K Multiboot Crash (Pli 7.1) #57 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 28 September 2019 - 16:38

Will be a subject for 8.0

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OSMIO4K Multiboot Crash (Pli 7.1) #58 Taykun345

  • Senior Member
  • 1,167 posts

+31
Good

Posted 28 September 2019 - 17:26

I agree with ntp as default. Some boxes are only used for (legal i must add) iptv and you need a special plugin now with openpli.

Sent from my HTC U11 using Tapatalk
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users