Jump to content


Photo

Audio track auto language selection


  • Please log in to reply
5 replies to this topic

#1 socks

  • Senior Member
  • 54 posts

+3
Neutral

Posted 8 October 2019 - 20:27

In settings "Prefer AC3 track" is selected but an MPEG audio track is chosen. Why?

It stopped working correctly a few months ago.

I'm using VU+ Ultimo 4K with latest OpenPLI 7.1.

 

Attached File  Settings.png   608.69KB   2 downloads

 

Attached File  AudioTrack.png   337.76KB   2 downloads


Edited by socks, 8 October 2019 - 20:29.


Re: Audio track auto language selection #2 littlesat

  • PLi® Core member
  • 49,515 posts

+533
Excellent

Posted 8 October 2019 - 21:25

Cache in lamedb does that most likely

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Audio track auto language selection #3 socks

  • Senior Member
  • 54 posts

+3
Neutral

Posted 8 October 2019 - 22:30

root@vuultimo4k:/etc/enigma2# init 4
root@vuultimo4k:/etc/enigma2# rm lamedb
root@vuultimo4k:/etc/enigma2# rm lamedb5
root@vuultimo4k:/etc/enigma2# init 3

Afterwards I made a full service scan.
Still the same problem. AC3 track is not auto selected :-(



Re: Audio track auto language selection #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,948 posts

+840
Excellent

Posted 8 October 2019 - 22:36

Maybe it has something to do with the language settings? It is usually not a good idea to put "Original" first, I would go for "German, English, Original, None".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Audio track auto language selection #5 socks

  • Senior Member
  • 54 posts

+3
Neutral

Posted 8 October 2019 - 22:43

That's it! I changed it like you recommended.

I don't understand why this affects the setting to prefer the AC3 audio track.

Nevertheless, it works now. Thank you!



Re: Audio track auto language selection #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,948 posts

+840
Excellent

Posted 8 October 2019 - 23:03

Language goes for type. In this case it didn't find a match for "OriginalAC3", but it found a match "Original/MPEG".

 

The reason for this order is that if you have "German, English", in that order, it means that you prefer German over Eniglish. So if there is a German MPEG track, and an English AC3 track, it will pick the MPEG track...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users