Jump to content


Photo

PCSC driver for uno4k se


  • Please log in to reply
47 replies to this topic

#1 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 10:17

Hi,

I have an uno4k se with openpli 7.1 and i would like to use my pcsc reader as second card reader.
This reader is a omnikey 3121.
I can not find driver for this.
Is it possible to add in the next update?

Best regards

Re: PCSC driver for uno4k se #2 Pr2

  • PLi® Contributor
  • 3,805 posts

+161
Excellent

Posted 1 November 2019 - 13:42

Hi,

Have you looked for libpcsc and install it?

Pr2

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: PCSC driver for uno4k se #3 Pr2

  • PLi® Contributor
  • 3,805 posts

+161
Excellent

Posted 1 November 2019 - 14:47

Back in front of my PC here is the package name: pcsc-lite


 

So in telnet you can type:

opkg update
opkg install pcsc-lite

Perhaps this one is needed too:   libpcsclite1

 

Pr2


Edited by Pr2, 1 November 2019 - 14:49.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: PCSC driver for uno4k se #4 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 15:22

Hi,

I can't find libpcsc, just only for mips.

Re: PCSC driver for uno4k se #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,495 posts

+873
Excellent

Posted 1 November 2019 - 15:29

There are two pcsc packages, available for all ARM boxes:

./armv7ahf-neon/pcsc-lite_1.8.13-r0.0_armv7ahf-neon.ipk
./armv7ahf-neon/libpcsclite1_1.8.13-r0.0_armv7ahf-neon.ipk

./cortexa15hf-neon-vfpv4/libpcsclite1_1.8.13-r0.0_cortexa15hf-neon-vfpv4.ipk
./cortexa15hf-neon-vfpv4/pcsc-lite_1.8.13-r0.0_cortexa15hf-neon-vfpv4.ipk

./aarch64/libpcsclite1_1.8.13-r0.0_aarch64.ipk
./aarch64/pcsc-lite_1.8.13-r0.0_aarch64.ipk

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: PCSC driver for uno4k se #6 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 15:44

You can make 1 more posts until 2 November 2019 - 09:17. This restriction is in place until you have 3 more approved posts

so this my last post today :)


https://kepkuldes.com/image/eY30SB



Re: PCSC driver for uno4k se #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,495 posts

+873
Excellent

Posted 1 November 2019 - 15:55

You may need the libpcsclite1 package too...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: PCSC driver for uno4k se #8 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 15:59

How can i install it from telenet?

Re: PCSC driver for uno4k se #9 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 16:07

Installed libpcsclite, but same massage when i want install pcsc-lite:
No packes installed or removed

Re: PCSC driver for uno4k se #10 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 16:09

Installed libpcsclite, but same massage when i want install pcsc-lite:
No packes installed or removed

Re: PCSC driver for uno4k se #11 mimisiku

  • Senior Member
  • 2,252 posts

+30
Good

Posted 1 November 2019 - 16:19

You don't install them using telnet.. You have to include them in your OScam build.. The necessary drivers (usb) are already in your image...
And hope your smartcard operates at 3.69Mhz.. I don't think Omnikey can switch to 4,5 or 6 Mhz

Edited by mimisiku, 1 November 2019 - 16:20.

VU+ Solo SE v2 Optus NZ

Re: PCSC driver for uno4k se #12 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 18:32

I have pcsc oscam, yes! lsusb not detected this reader.
I have 3 cards 1. Work with vu+ speed 4.5 mhz, 2. Work 12.0 mhz(yes, overclock) in usb phoenix reader and the 3. Work now 3.57 with an usb-rs232 converter in serial phoenix. I would like to change the serial to pcsc.
On linux pc the pcsc work well 4.8 mhz as you can see here:

http://www.streamboa...ki/ReaderClocks

Re: PCSC driver for uno4k se #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,495 posts

+873
Excellent

Posted 1 November 2019 - 20:00

Installed libpcsclite, but same massage when i want install pcsc-lite:
No packes installed or removed

 

Means the package is already installed.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: PCSC driver for uno4k se #14 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 21:13

But not work...
When i write in putty:
lsusb, than there is no pcsc...
And when i use the pcsc oscam and turn on the pcsc reader, the oscam breakdown!
Did you try this?

Re: PCSC driver for uno4k se #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,495 posts

+873
Excellent

Posted 1 November 2019 - 21:15

I don't own a pcsc reader.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: PCSC driver for uno4k se #16 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 1 November 2019 - 21:33

This is the problem, but you are clever.

Re: PCSC driver for uno4k se #17 Pr2

  • PLi® Contributor
  • 3,805 posts

+161
Excellent

Posted 2 November 2019 - 00:32

I have install the lib and the pcsc-lite package and connect an Omni 3121 and it is detected:

 

[42931.448906] usb 1-2.1: new full-speed USB device number 8 using xhci-brcm

[42931.550228] usb 1-2.1: ep 0x83 - rounding interval to 128 microframes, ep desc says 192 microframes

 

And lsub show it too:

 

Bus 001 Device 008: ID 076b:3021

 

And I test it on a VU+ Duo 4K which is an ARM box.

 

root@vuduo4k:~# pcscd --version

pcsc-lite version 1.8.13.

Copyright © 1999-2002 by David Corcoran <corcoran@musclecard.com>.

Copyright © 2001-2011 by Ludovic Rousseau <ludovic.rousseau@free.fr>.

Copyright © 2003-2004 by Damien Sauveron <sauveron@labri.fr>.

Report bugs to <muscle@lists.musclecard.com>.

Enabled features: Linux arm-oe-linux-gnueabi serial usb libudev usbdropdir=/usr/lib/pcsc/drivers ipcdir=/var/run/pcscd configdir=/etc/reader.conf.d


Edited by Pr2, 2 November 2019 - 00:34.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: PCSC driver for uno4k se #18 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 2 November 2019 - 03:35

And how did you install the pcsc-lite package?

Re: PCSC driver for uno4k se #19 betacentauri

  • PLi® Core member
  • 5,596 posts

+254
Excellent

Posted 2 November 2019 - 08:35

Please exeute
opkg list-installed | grep pcsc
This shows whether the package is already installed.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: PCSC driver for uno4k se #20 Zolyma

  • Senior Member
  • 46 posts

0
Neutral

Posted 2 November 2019 - 11:12

Thanks, yes, it shows that!
So it is already on my box, but then why not detect my reader...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users