Jump to content


Photo

zgemma mgcams


  • Please log in to reply
14 replies to this topic

#1 ash1122

  • New Member
  • 1 posts

0
Neutral

Posted 8 November 2019 - 11:29

Hi there , im a newbie , ive just installed the v7 openpli image in my H1 zgemma box but i can't seem to install the mgcams in plugins , when i try i keep getting error messages .. any help please ??



Re: zgemma mgcams #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 8 November 2019 - 13:25

What error message?

 

Chances are you need to install the libcrypto-compat package, as mgcamd is old and no longer compatible with the current linux library versions...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #3 alias haha

  • Senior Member
  • 300 posts

+2
Neutral

Posted 11 November 2019 - 12:37

MGcamd runs on a lot of image builders, with the latest enigma boxes, also .arm boxes, but not on openpli...


Vu+ duo 4K | Vu+ duo²

Zgemma H2H | Zgemma H5 | Zgemma H7C

Wavefrontier T90


Re: zgemma mgcams #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 11 November 2019 - 12:40

What error message?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #5 littlesat

  • PLi® Core member
  • 49,514 posts

+533
Excellent

Posted 11 November 2019 - 16:33

Will be solved in thud...

The current oe we use in rc does not offer backwards compatibility for OpenSSL1.0.0.

(see other thread we had about this issue).

 

FYI https://forums.openp...or-duo4k/page-2


Edited by littlesat, 11 November 2019 - 16:35.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: zgemma mgcams #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 11 November 2019 - 16:42

The mgcamd binary is as old as Methusalem. 7.2 runs on the same OE as 7.0, so why is this all of a sudden an issue?

 

And since when is there an mgcamd binary for ARM? We don't have that in the feeds?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #7 lopess

  • Senior Member
  • 29 posts

0
Neutral

Posted 11 November 2019 - 19:32

The mgcamd binary is as old as Methusalem.

it's true :D

And since when is there an mgcamd binary for ARM?


there is an mgcamd binary for ARM of course…, but...:

1) there is no mgcamd in openpli feed, because…..:
2) all mgcamd ipk and binary files available in net for armv7 will not work on openpli 7.x images (also those marked as compatible with openpli - contain invalid commands in control files, not compatible with current OpenPli images)
3) mgcamd binary need OPENSSL.1.0.0 also...:
 

Will be solved in thud...
The current oe we use in rc does not offer backwards compatibility for OpenSSL1.0.0.
(see other thread we had about this issue).
 
FYI https://forums.openp...or-duo4k/page-2

The Openpli team is working on this ;)

Edited by lopess, 11 November 2019 - 19:33.

Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: zgemma mgcams #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 11 November 2019 - 19:35

3) mgcamd binary need OPENSSL.1.0.0 also...

 

You keep saying this, but no answer to my question why all of a sudden this is a problem, and nobody has mentioned this in the last 12 months, as all OpenPLi 7 images use the same OE version.

 

Also, if no mgcamd ARM versions in the wild are compatible, what is the point of all this?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #9 lopess

  • Senior Member
  • 29 posts

0
Neutral

Posted 11 November 2019 - 19:45

I don't know what you mean, read this topic:

https://forums.openp...-100-for-duo4k/

root@vuduo4k:/usr/bin# ./mgcamd
./mgcamd: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mgcamd)
This is a problem that has been on Openpli images (armv7 architecture) for a long time... Probably the last image that allowed to run armv7 mgcamd on openpli is 4.0 (but I'm not sure...)
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: zgemma mgcams #10 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 11 November 2019 - 19:53

That topic doesn't say anthing about the how and why.

 

Are you saying that the ARM version floating around is different from the MIPSel version in the feed? As that doesn't have this requirement appearently?

 

Where can I find that mgcamd binary?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #11 lopess

  • Senior Member
  • 29 posts

0
Neutral

Posted 11 November 2019 - 19:59

Also, if no mgcamd ARM versions in the wild are compatible, what is the point of all this?


ipk files are incompatible because they refer to old image versions - to other ld-x.xx.so and libcrypto.so libraries - it's not a problem - ipk files we can upgrade, but mgcamd for armv7 need OPENSSL_1.0.0. Most teams use ssl libraries that are compatible with openssl_1.0.0, but not openpli! That's why mgcamd's image works without any problems on OPenATV, VTi, and others....but not on Openpli images....
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: zgemma mgcams #12 lopess

  • Senior Member
  • 29 posts

0
Neutral

Posted 11 November 2019 - 20:01

Where can I find that mgcamd binary?


What else can I tell you?

read this topic again:
https://forums.openp...-100-for-duo4k/
mgcamd binary is in this topic....
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: zgemma mgcams #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 11 November 2019 - 20:02

All libraries are compatible, that has been said before.

 

The problem is that the mgcamd binary is crap, and hardcoded looks for the OPENSSL_1.0.0 data structure, instead of checking the version and retrieving the correct one. OE-A has fixed that by patching OpenSSL, so the 1.0.2 version has 1.0.0. datastuctures. Which also means that all OE-A derived images have this.

 

Very dirty practice, and not sure I will support this.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: zgemma mgcams #14 littlesat

  • PLi® Core member
  • 49,514 posts

+533
Excellent

Posted 12 November 2019 - 07:21

I always told likely a soft link should help here....
Oe-a uses thud or deviate from oe by patching it (brr) partly...
A more important question why should you use a binary blob mgcamd while an open source Oscam is available. What added value does mgcamd has? Why should we continue to support ancient binary blobs? Why should we spend time when most likely OpenSSL 1.0.0 will be back in as soon we switch to thud? Maybe we should release 7.2 and then make thud 8.0 rc? Issue solved for free! Discussion closed....

Edited by littlesat, 12 November 2019 - 07:25.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: zgemma mgcams #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,905 posts

+838
Excellent

Posted 12 November 2019 - 14:05

OE-A uses specific source patches for openssl, has nothing to do with thud.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users