Jump to content


Photo

Openssl 1.0.0 for duo4k


  • Please log in to reply
63 replies to this topic

#1 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 8 November 2019 - 19:21

Hello

is it possible to add openssl 1.0.0 support to the libssl library ?

OpenPli 7.x images use OpenSSL 1.0.2k now, which does not support openssl 1.0.0
 
root@vuduo4k:~# openssl version
OpenSSL 1.0.2k 26 Jan 2017
root@vuduo4k:~# grep OPENSSL /usr/lib/libssl.so.1.0.2
OPENSSL_cleanse
OPENSSL_DIR_read
OPENSSL_DIR_end
OPENSSL_1.0.2d
OPENSSL_1.0.2g
OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error
root@vuduo4k:~#
OpenATV for example using OpenSSL 1.0.2q, which support openssl 1.0.0:
 
root@vuduo4k:~# grep OPENSSL 
/usr/lib/libssl.so.1.0.2
OPENSSL_cleanse
OPENSSL_DIR_read
OPENSSL_DIR_end
OPENSSL_1.0.0
OPENSSL_1.0.1
OPENSSL_1.0.1d
OPENSSL_1.0.2
OPENSSL_1.0.2g
OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error
root@vuduo4k:~#
Openssl 1.0.0 is needed for some old apps - for example mgcamd:
 
root@vuduo4k:/usr/bin# ./mgcamd
./mgcamd: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mgcamd)
root@vuduo4k:/usr/bin#

Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #2 littlesat

  • PLi® Core member
  • 49,731 posts

+543
Excellent

Posted 8 November 2019 - 19:23

And with a softlink trick.....

Edited by littlesat, 8 November 2019 - 19:24.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Openssl 1.0.0 for duo4k #3 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 8 November 2019 - 20:06

softlinks it's not problem, problem is openssl 1.0.0 support ;)
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #4 littlesat

  • PLi® Core member
  • 49,731 posts

+543
Excellent

Posted 8 November 2019 - 22:53

Try softlink from 1.0.0 to 1.0.2 lib... or simply use oscam....

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Openssl 1.0.0 for duo4k #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,498 posts

+873
Excellent

Posted 9 November 2019 - 01:14

opkg install libcrypto-compat

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Openssl 1.0.0 for duo4k #6 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 06:53

Try softlink from 1.0.0 to 1.0.2 lib... or simply use oscam....


using the softlink will do nothing because the target library (1.0.2) does not support openssl 1.0.0., as I wrote above
 
vuduo4k login: root
root@vuduo4k:~# cd /usr/bin
root@vuduo4k:/usr/bin# ./mgcamd
./mgcamd: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mgcamd)
root@vuduo4k:/usr/bin#

opkg install libcrypto-compat

root@vuduo4k:/usr/bin# opkg install libcrypto-compat
Installing libcrypto-compat (1.0.2) on root
Downloading http://downloads.openpli.org/feeds/openpli-7.2-rc/armv7ahf-neon/libcrypto-compat_1.0.2-r0.0_armv7ahf-neon.ipk.
Configuring libcrypto-compat.
root@vuduo4k:/usr/bin# ./mgcamd
./mgcamd: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mgcamd)

the solution is to use in the Openlis images the Openssl library with ssl 1.0.0 support
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #7 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 07:09

mgcamd works on other teams' images (OpenATV, VTI for example) because they use libraries with OPENSSL 1.0.0 support

OpenPli (without OPENSSL 1.0.0 support):
 
root@vuduo4k:~# grep OPENSSL /usr/lib/libssl.so.1.0.0
OPENSSL_cleanse
OPENSSL_DIR_read
OPENSSL_DIR_end
OPENSSL_1.0.2d
OPENSSL_1.0.2g
OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error
root@vuduo4k:~#
OpenATV (with OPENSSL 1.0.0 support):
 
root@vuduo4k:~# grep OPENSSL /usr/lib/libssl.so.1.0.0
OPENSSL_cleanse
OPENSSL_DIR_read
OPENSSL_DIR_end
OPENSSL_1.0.0
OPENSSL_1.0.1
OPENSSL_1.0.1d
OPENSSL_1.0.2
OPENSSL_1.0.2g
OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error
root@vuduo4k:~#
VTI (with OPENSSL 1.0.0 support):
 
root@vuduo4k:~# grep OPENSSL /usr/lib/libssl.so.1.0.0
OPENSSL_cleanse
OPENSSL_DIR_read
OPENSSL_DIR_end
OPENSSL_1.0.0
OPENSSL_1.0.1
OPENSSL_1.0.1d
OPENSSL_1.0.2
OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error
root@vuduo4k:~#

Edited by lopess, 9 November 2019 - 07:11.

Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #8 betacentauri

  • PLi® Core member
  • 5,597 posts

+254
Excellent

Posted 9 November 2019 - 07:37

From where do you have the binary? I’m quite sure there is a binary available which runs under OpenPLi.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Openssl 1.0.0 for duo4k #9 Abu Baniaz

  • PLi® Contributor
  • 1,218 posts

+26
Good

Posted 9 November 2019 - 07:51

From my experience, the the newer libssl is backwards compatible. The cams just need the symlink as others have posted.

The older cam packages sometimes add a dependency which causes install to fail. The ipk need to be remade so it checks before creating links.

If it does install, check by starting the cam by command line.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

Edited by Abu Baniaz, 9 November 2019 - 07:51.


Re: Openssl 1.0.0 for duo4k #10 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:04

all mgcamd binary for arm (1.35a) is the same. there are no different ones...
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #11 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:06

The older cam packages sometimes add a dependency which causes install to fail. The ipk need to be remade so it checks before creating links.

If it does install, check by starting the cam by command line.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.


I don't use ipk CAM packages…
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #12 Abu Baniaz

  • PLi® Contributor
  • 1,218 posts

+26
Good

Posted 9 November 2019 - 08:14

so how are you installing it?

By "cam", I meant softcam

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

Edited by Abu Baniaz, 9 November 2019 - 08:16.


Re: Openssl 1.0.0 for duo4k #13 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:25

From my experience, the the newer libssl is backwards compatible.


you're wrong

look at this table:
https://abi-laborato...eline&l=openssl

you can check backward compatibility of your ssl library with command: grep OPENSSL /usr/lib/libssl.so.X.X.X
Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #14 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:32

so how are you installing it?

By "cam", I meant softcam

Sent from my Moto G (5S) using Forum Fiend v1.3.3.


I don't install any ipk files! I use binary files - then I have full control over what I do and see the system's response. Ipk files it's only archive, with a binary files and control files.

Edited by lopess, 9 November 2019 - 08:32.

Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #15 Abu Baniaz

  • PLi® Contributor
  • 1,218 posts

+26
Good

Posted 9 November 2019 - 08:33

Can you upload the binary file then.

You comment is not 100% accurate as the ipks also affect the Cam control mechanisms in the image. Obviously this does not apply to you.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

Edited by Abu Baniaz, 9 November 2019 - 08:35.


Re: Openssl 1.0.0 for duo4k #16 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:34

I have already given the reason and solution to the problem. My question is (just like in the first post) - can you add libssl library with OpenSSL 1.0.0 support to Openpli images?

Edited by lopess, 9 November 2019 - 08:38.

Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #17 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:37

here you are

Attached Files


Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #18 lopess

  • Senior Member
  • 38 posts

+1
Neutral

Posted 9 November 2019 - 08:39

You comment is not 100% accurate as the ipks also affect the Cam control mechanisms in the image. Obviously this does not apply to you.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.

 

so how are you installing it?

By "cam", I meant softcam

Sent from my Moto G (5S) using Forum Fiend v1.3.3.


Ipk files it's only archive, with a binary files and control files.

 


Laminas 150 - 39E | 36E , WaveFrontier T90 - 31,5E | 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W - 2.0/2.1 Spaun/WaveFrontier multiswich system
VU Duo4k, Zgemma H7s, Azbox Premium HD+, Azbox Premium HD, Dr HD F16, Technomate 6900 Combo Super

Re: Openssl 1.0.0 for duo4k #19 littlesat

  • PLi® Core member
  • 49,731 posts

+543
Excellent

Posted 9 November 2019 - 09:18

Why should we support an older OpenSSL because there is an ancient binary of mgcamd and for what reason do you need or prefer mgcamd?

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Openssl 1.0.0 for duo4k #20 Abu Baniaz

  • PLi® Contributor
  • 1,218 posts

+26
Good

Posted 9 November 2019 - 10:59

Using a newer one that is backward compatible should not be an issue. He is not asking us to revert to older one.

Sent from my Moto G (5S) using Forum Fiend v1.3.3.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users