Jump to content


Photo

build --with-libxine


  • Please log in to reply
No replies to this topic

#1 1455

  • Senior Member
  • 267 posts

+4
Neutral

Posted 24 December 2019 - 09:39

For research purposes, I wanted to compile only the enigma2 folder on PC with the --with-libxine option. However, I get errors:

service/servicexine.cpp: In constructor ‘eServiceFactoryXine::eServiceFactoryXine()’:
service/servicexine.cpp:25:54: error: no matching function for call to ‘eServiceCenter::addServiceFactory(eServiceFactoryXine::<unnamed enum>, eServiceFactoryXine*)’
   sc->addServiceFactory(eServiceFactoryXine::id, this);
                                                      ^
...

service/servicexine.cpp:45:41: error: invalid new-expression of abstract class type ‘eServiceXine’
  ptr = new eServiceXine(ref.path.c_str());
                                         ^
...

service/servicexine.cpp: In member function ‘virtual int eServiceXine::getInfo(int)’:
service/servicexine.cpp:332:7: error: ‘sTitle’ was not declared in this scope
  case sTitle:
       ^~~~~~
...

service/servicexine.cpp:333:7: error: ‘sArtist’ was not declared in this scope
  case sArtist:
       ^~~~~~~
...

service/servicexine.cpp:334:7: error: ‘sAlbum’ was not declared in this scope
  case sAlbum:
       ^~~~~~
...

       sTagAlbum
service/servicexine.cpp:335:7: error: ‘sComment’ was not declared in this scope
  case sComment:
       ^~~~~~~~
...

service/servicexine.cpp:336:7: error: ‘sTracknumber’ was not declared in this scope
  case sTracknumber:
       ^~~~~~~~~~~~
...

service/servicexine.cpp:337:7: error: ‘sGenre’ was not declared in this scope
  case sGenre:
       ^~~~~~

I tried to insert the following:

diff -ruN o/configure.ac pc/configure.ac
--- o/configure.ac    2019-08-01 17:26:23.924716525 +0300
+++ pc/configure.ac    2019-12-24 14:09:57.726693201 +0300
@@ -238,7 +250,7 @@
 AC_CHECK_LIB([crypt], [crypt], [BASE_LIBS+=" -lcrypt"], [AC_MSG_ERROR([Could not find crypt])])
 AC_CHECK_LIB([rt], [clock_gettime], [BASE_LIBS+=" -lrt"], [AC_MSG_ERROR([Could not find rt])])
 
-ENIGMA2_CFLAGS="-fno-rtti -fno-exceptions -rdynamic -funwind-tables"
+ENIGMA2_CFLAGS="-fno-rtti -fno-exceptions -rdynamic -funwind-tables -Wno-error=implicit-function-declaration"
 AC_SUBST(ENIGMA2_CFLAGS)
 
 AX_CXX_COMPILE_STDCXX_11([ext],[mandatory])

But this doesnt help. Any suggestion?  






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users