Jump to content


Photo

libtorrent and openpli 7.2


  • Please log in to reply
30 replies to this topic

#1 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 07:49

libtorrent is c++ library compiled for enigma2

after installing the library with openpli7.2  i faced with these errors when try to run libtorrent.

i faced these errors with vusolo2 and xt7500 openpli7.2

Python 2.7.13 (default, May 20 2019, 04:11:42)
[GCC 6.3.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import libtorrent
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/lib/libssl.so.1.0.2: version `OPENSSL_1.0.0' not found (required by /usr/lib/python2.7/site-packages/libtorrent.so)


also during install the libtorrent package i received complaints about  libc6

Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides libc6 >= 2.28 needed by libboost-python27-1.68.0-1.68.0-r1 *
 * Solution 1:
 *   - do not ask to install libboost-python27-1.68.0-1.68.0-r1



Re: libtorrent and openpli 7.2 #2 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 09:18


ImportError: /usr/lib/libssl.so.1.0.2: version `OPENSSL_1.0.0' not found (required by /usr/lib/python2.7/site-packages/libtorrent.so)

 

 

Are you sure you have this in OpenPLi 7.2... as far I know the old lib should be there... Otherwize make a softlink from  /usr/lib/libssl.so.1.0.2 to  /usr/lib/libssl.so.1.0.0,

Where did you get the plugin from? Might also be the plugin itself needs to be recompiled....
 


Edited by littlesat, 30 December 2019 - 09:19.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #3 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 10:01

Thanks for the answer

create soft link failed with this message

ln /usr/lib/libssl.so.1.0.2 /usr/lib/libssl.so.1.0.0
ln: /usr/lib/libssl.so.1.0.0: File exists

libtorrent.so is build through boost build according to this tutorial https://www.libtorre...on_binding.html

however i am sure nothing wrong with libtorrent because i installed in more than 6 opensource images without any problem and some of these images openpli based like openvision,openblackhole and openesi

also no problem with other images like openatv,pure2 and others



Re: libtorrent and openpli 7.2 #4 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 10:10

You compiled torrent binary missed some new libraries... So you need to build it differently..(recommended).

 

As far I know latest OpenPLi release should at least support the old libssl.so.1.0.0 as this was added last minute due to reports in RC that old binary blobs from emu's need it. Now your compiled binary 'blob' needs libssl.so.1.0.2.... 

 

Other images seems to add softlinks to get binary blobs working without any warning ;)


Edited by littlesat, 30 December 2019 - 10:12.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #5 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 10:12

mmm here this worked...

 

ln -s /usr/lib/libssl.so.1.0.2 /usr/lib/libssl.so.1.0.0


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #6 fairbird

  • Senior Member
  • 408 posts

+19
Neutral

Posted 30 December 2019 - 10:25

@littlesat

My friend .. Then problem is from openpli version 7.2 (right)

I have tried also and I have created soft link as log show but the issue still happens image ask to OPENSSL_1.0.0

glib-openssl - 2.50.8-r0
openssl - 1.0.2k-r0
openssl-conf - 1.0.2k-r0
python-pyopenssl - 17.3.0-r0

lrwxrwxrwx    1 0        0               15 Dec 29 19:43 /usr/lib/libssl.so.0.9.7 -> libssl.so.1.0.2
lrwxrwxrwx    1 0        0               15 Dec 29 19:43 /usr/lib/libssl.so.0.9.8 -> libssl.so.1.0.2
lrwxrwxrwx    1 0        0               15 Dec 29 19:47 /usr/lib/libssl.so.1.0.0 -> libssl.so.1.0.2
-rwxr-xr-x    1 0        0           318016 May 20  2019 /usr/lib/libssl.so.1.0.2
Python 2.7.13 (default, May 20 2019, 04:11:42) 
[GCC 6.3.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import libtorrent
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/lib/libssl.so.1.0.2: version `OPENSSL_1.0.0' not found (required by /usr/lib/python2.7/site-packages/libtorrent.so)

And here is from OpenATV with (openssl 1.0.2r-r0) works without problem ..

glib-openssl - 2.50.8-r0
glib-openssl-locale-de - 2.50.8-r0
glib-openssl-locale-es - 2.50.8-r0
glib-openssl-locale-fr - 2.50.8-r0
glib-openssl-locale-it - 2.50.8-r0
glib-openssl-locale-nl - 2.50.8-r0
glib-openssl-locale-pt - 2.50.8-r0
openssl10 - 1.0.2r-r0
openssl10-conf - 1.0.2r-r0
python-pyopenssl - 19.0.0-r0

Python 2.7.16 (default, Nov  7 2019, 05:20:53) 
[GCC 9.2.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import libtorrent
>>> 

And here is from Openvision with newest version of (openssl 1.1.1d-r0) works without problem ..

glib-openssl - 2.50.8-r0
openssl - 1.1.1d-r0
openssl-bin - 1.1.1d-r0
openssl-conf - 1.1.1d-r0
python-pyopenssl - 19.1.0-r0

Python 2.7.17 (default, Nov 25 2019, 00:54:19) 
[GCC 9.2.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import libtorrent
>>> 

Edited by fairbird, 30 December 2019 - 10:28.

DM500s
DM800

DM800se

DM920UHD


Re: libtorrent and openpli 7.2 #7 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 10:25

softlink is already exists in my openpli

screenshot-1351.png



Re: libtorrent and openpli 7.2 #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 10:28

Where is this "libtorrent.so" come from?

 

If it is from our feed, you would expect it to be build against the current libssl¸and not an old one.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libtorrent and openpli 7.2 #9 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 10:36

As far I can see it was a 'self' building thing...

 

 


libtorrent.so is build through boost build according to this tutorial https://www.libtorre...on_binding.html


Edited by littlesat, 30 December 2019 - 10:36.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #10 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 10:37

We also have it in our feeds... so first we should recommend to try ours..

 

root@vuultimo4k:~# opkg list | grep torrent
ctorrent - 3.3.1-r1.10 - ctorrent version 3.3.1-r1
 lightweight and quick. This is the Enhanced version from the dtorrent
 Bittorrent client for enigma2
libtorrent19 - 0.13.6+git0+c167c5a9e0-r0.4 - libtorrent version 0.13.6+gitAUTOINC+c167c5a9e0-r0
rtorrent - 0.9.6+git0+226e670dec-r0.4 - Torrent client

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #11 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 10:41

@WanWizard

libtorrent is not available in feed of openpli

it is compiled for arm and misspell,aarch64 accoding to this source

https://github.com/arvidn/libtorrent

and this tutorial for building for enigma

https://www.libtorre...on_binding.html

 

as i have said nothing wrong with libtorrent.so because installed and run smoothly with more other 10 images and some openpli based



Re: libtorrent and openpli 7.2 #12 littlesat

  • PLi® Core member
  • 51,922 posts

+589
Excellent

Posted 30 December 2019 - 10:42


libtorrent is not available in feed of openpli

???

See my opkg list | grep torrent output above....


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: libtorrent and openpli 7.2 #13 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 10:44

It is compiled against an old version of libssl for 7.2-release, so your "there is nothing wrong" statement is incorrect.

 

Whether or not it runs elsewhere is not really relevant, those images either use an old libssl, or have deployed "hacks" (like the symlink) to deal with people using incorrect external libs.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libtorrent and openpli 7.2 #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 10:58

root@vuduo4k:~# opkg install libtorrent
Installing cppunit (1.13.2) on root
Downloading http://*****/feeds/openpli-develop/armv7ahf-neon/cppunit_1.13.2-r0.1_armv7ahf-neon.ipk.
Installing libtorrent19 (0.13.6+git0+c167c5a9e0) on root
Downloading http://*****/feeds/openpli-develop/armv7ahf-neon/libtorrent19_0.13.6+git0+c167c5a9e0-r0.5_armv7ahf-neon.ipk.
Configuring cppunit.
Configuring libtorrent19.

root@vuduo4k:~# ls -l /usr/lib/libtorrent*
lrwxrwxrwx    1 root     root            20 Nov 19 21:54 /usr/lib/libtorrent.so.19 -> libtorrent.so.19.0.0
-rwxr-xr-x    1 root     root       1004392 Nov 19 21:54 /usr/lib/libtorrent.so.19.0.0

 


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libtorrent and openpli 7.2 #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 11:00

This we don't have:

root@vuduo4k:~# opkg install python-libtorrent
Couldn't find anything to satisfy 'python-libtorrent'.
No packages installed or removed.

but if that is needed, all one has to do is ask...
 


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libtorrent and openpli 7.2 #16 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 11:03

 

We also have it in our feeds... so first we should recommend to try ours..

root@vuultimo4k:~# opkg list | grep torrent
ctorrent - 3.3.1-r1.10 - ctorrent version 3.3.1-r1
 lightweight and quick. This is the Enhanced version from the dtorrent
 Bittorrent client for enigma2
libtorrent19 - 0.13.6+git0+c167c5a9e0-r0.4 - libtorrent version 0.13.6+gitAUTOINC+c167c5a9e0-r0
rtorrent - 0.9.6+git0+226e670dec-r0.4 - Torrent client

llibtorrent19 - 0.13.6+git0+c167c5a9e0-r0.4 available in the feed is not the main package and this one the files libtorrent depend upon

however this is old version

the main package name

python-libtorrent-rasterbar_1.2.0 and depends on  libtorrent20_0.13.7-git0-074f6ec51a-r0

 

instead of runway from the problem to think about what make installation of external new package is difficult in openpli 7.2 while on all other images runs smoothly



Re: libtorrent and openpli 7.2 #17 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 11:29

If you want to install Windows 95 software on Windows 10, you're on your own too.

 

You use an external binary that depends on old library versions, the only correct solution is "use the correct external binary", not "make sure your OS is compatible with whatever old crap users want to install".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: libtorrent and openpli 7.2 #18 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 11:31

The problem in openpli 7.2 as i see that still having old versions of

glib-openssl

openssl

python-pyopenssl

just look to the good comparison with other images made by fairbird above

https://forums.openp...dpost&p=1145953



Re: libtorrent and openpli 7.2 #19 mfaraj57

  • Senior Member
  • 1,588 posts

+284
Excellent

Posted 30 December 2019 - 11:38

libtorrent20 is the latest c++ interface for bittorent and depends on linssl 1.0.2 which is the latest,i do not know from "version `OPENSSL_1.0.0' not found"  come from as i do not see this any setup with same library in other images



Re: libtorrent and openpli 7.2 #20 WanWizard

  • Forum Moderator
    PLi® Core member
  • 53,973 posts

+1,071
Excellent

Posted 30 December 2019 - 11:40

OpenPLi runs on OE Pyro, so it has the libraries that come with that.

 

OpenPLi 7.2 uses OpenSSL 1.0.2r, so fairbird's list is not correct. Is also has OPENSSL_1_0_0 emulated, I added it myself. I suggest fairbird should look at what he has installed.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users