Jump to content


Photo

External subtitles out of sync


  • Please log in to reply
6 replies to this topic

#1 Robinson

  • Senior Member
  • 2,519 posts

+30
Good

Posted 8 January 2020 - 22:55

Hello,

I am curious about a certain feature, which is probably not available but I would like to make sure.

When I am watching a movie, either recorded on my HD51 or downloaded from the internet, I sometimes want to add subtitles to it.

Unfortunately, it is often not possible to match correct subtitles because of commercial breaks (for recorded movies) or some other issues. They are simply out of sync or they become out-of-sync as the film progresses.

Is it perhaps possible to adjust subtitles when watching a movie "on the fly" by delaying or advancing them by one second or a couple of seconds? That would be a very convenient feature.

 


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: External subtitles out of sync #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,315 posts

+949
Excellent

Posted 8 January 2020 - 23:02

When you have subtitles active, pres Yellow, Yellow, Blue (or Subtitles, Blue). You can define a delta from -10 to +20 seconds.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: External subtitles out of sync #3 Robinson

  • Senior Member
  • 2,519 posts

+30
Good

Posted 10 January 2020 - 15:02

Thanks.

I was not aware of that. Will have to try.


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: External subtitles out of sync #4 Robinson

  • Senior Member
  • 2,519 posts

+30
Good

Posted 12 January 2020 - 11:02

Just a quick question.

Is it possible to use external SRT subtitles with a movie recorded from TV (TS file)?

How to do that?


Edited by Robinson, 12 January 2020 - 11:02.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: External subtitles out of sync #5 Robinson

  • Senior Member
  • 2,519 posts

+30
Good

Posted 20 January 2020 - 22:08

Not possible, I guess?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: External subtitles out of sync #6 betacentauri

  • PLi® Core member
  • 5,915 posts

+263
Excellent

Posted 20 January 2020 - 23:55

Change suffix from ts to e.g. mpg. Then file will be played back with gstreamer. And with gstreamer you can external srt subtitles afaik.
(Don’t know how good it works)
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: External subtitles out of sync #7 rantanplan

  • Senior Member
  • 228 posts

+7
Neutral

Posted 21 January 2020 - 21:07

enigma2-plugin-extensions-subssupport

Has it been tried?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users