Jump to content


Photo

openvpn: unsatisfied recommendation for kernel-module-tun

openvpn tun

  • Please log in to reply
4 replies to this topic

#1 epsil0n

  • New Member
  • 3 posts

0
Neutral

Posted 25 January 2020 - 23:41

tried to install openvpn on my box but it doesnt seem like working starting with a message  :

openvpn: unsatisfied recommendation for kernel-module-tun

and even after i have it on my box i keep getting errors following log file about exiting due to fatal error .

here is my openvpn log file :

 

Sat Jan 25 20:36:39 2020 OpenVPN 2.3.4 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Jan 15 2016
Sat Jan 25 20:36:39 2020 library versions: OpenSSL 1.0.1i 6 Aug 2014, LZO 2.09
Sat Jan 25 20:36:39 2020 Control Channel Authentication: tls-auth using INLINE static key file
Sat Jan 25 20:36:39 2020 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Jan 25 20:36:39 2020 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sat Jan 25 20:36:39 2020 UDPv4 link local: [undef]
Sat Jan 25 20:36:39 2020 UDPv4 link remote: [AF_INET]
Sat Jan 25 20:36:40 2020 VERIFY OK: depth=1, O=5ac77a471997ee2ef780b5f7, CN=5ac77a471997ee2ef780b5f8
Sat Jan 25 20:36:40 2020 Validating certificate key usage
Sat Jan 25 20:36:40 2020 ++ Certificate has key usage  00a0, expects 00a0
Sat Jan 25 20:36:40 2020 NOTE: --mute triggered...
Sat Jan 25 20:36:47 2020 10 variation(s) on previous 3 message(s) suppressed by --mute
Sat Jan 25 20:36:47 2020 [5ac77a471997ee2ef780b609] Peer Connection Initiated with [AF_INET]
Sat Jan 25 20:36:49 2020 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Sat Jan 25 20:36:49 2020 Exiting due to fatal error
 
and my box specs:
 
TkfwMWy.png
 
hope someone can help me getting openvpn work without flashing or switching to other images . thanks


Re: openvpn: unsatisfied recommendation for kernel-module-tun #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,750 posts

+926
Excellent

Posted 26 January 2020 - 00:05

We don't make an OpenPLi image for that box. Besides that, it says "OE Alliance", so wrong forum too...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: openvpn: unsatisfied recommendation for kernel-module-tun #3 epsil0n

  • New Member
  • 3 posts

0
Neutral

Posted 26 January 2020 - 00:08

thanks for reply

any help about what i can do to resolve this problem

or even if this problem can be solved without flashing or switching to other images?



Re: openvpn: unsatisfied recommendation for kernel-module-tun #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,750 posts

+926
Excellent

Posted 26 January 2020 - 00:13

We don't have a clue what they do in their image, hence my remark you're asking the question in the wrong place. Like asking a BMW dealer why your Toyota doesn't start...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: openvpn: unsatisfied recommendation for kernel-module-tun #5 epsil0n

  • New Member
  • 3 posts

0
Neutral

Posted 26 January 2020 - 02:16

i just got my problem fixed  :lol:







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users