Jump to content


Photo

LCD4Linux probleem?


  • Please log in to reply
15 replies to this topic

#1 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 08:09

Mijn vraag heeft betrekking op het scherm van mijn Ultimo4k.

Op dat scherm wordt tijdens TV kijken en afspelen van een opname, de tijd digitaal aangegeven.

Ook is er een knipperend led zichtbaar wanneer er een opname loopt.

Kijk ik naar bv NPO1 en ga daarvan de teletekst lezen, dan blijft die klok stilstaan en knippert het led niet meer, totdat ik de teletekst verlaat.

Het lijkt erop dat alle activiteit van het schermpje stilstaat.

 

Ik gebruik PLI 7.2 van 24 februari.

 

En ja......... ik lees de teletekst nog wel.

 

 



Re: LCD4Linux probleem? #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 27 February 2020 - 10:31

Gokje: het scherm wordt aangestuurd door Enigma, en zodra je teletekst start stop Enigma tijdelijk, en dus ook die klok?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #3 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 12:27

Of enigma dan stopt weet ik niet. Ik weet wel dat de tijd stil blijft staan evenals de knipperende led van de opname, die knippert dan niet meer.

Lees ik bv 3 minuten de teletekst en ga daar dan uit, springt de digitale klok ineens 3 minuten vooruit en gaat de led weer knipperen.



Re: LCD4Linux probleem? #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 27 February 2020 - 12:38

Ik ben er redelijk zeker van dat mijn gokje klopt.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #5 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 12:54

Zou best kunnen hoor dat je gelijk hebt, maar goed is het toch niet.

Ik zeg niet dat het aan PLI ligt maar het hoort toch gewoon door te lopen?

Mogelijk is dat een dingetje van LCD4Linux.

 

Overigens, als je op de teletekstpagina zit, staat daar ook de tijd vermeldt en die is wel correct.



Re: LCD4Linux probleem? #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 27 February 2020 - 14:34

Enigma is geen multi-threaded applicatie, alles wordt uitgevoerd in een enkele mainloop. Vandaar ook de beroemde spinner, die krijg je te zien als de mainloop te lang busy blijft.

Met andere woorden, er is altijd maar 1 ding actief, en die worden sequentieel in een lus afgelopen.

 

tuxtxt is een aparte binary, als die op start dan stopt de mainloop gewoon (en die spinner zie je niet omdat Enigma de framebuffer dan niet heeft), en staat alles in Enigma stil.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #7 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 14:54

Dan heeft elke box met een LCD scherm oid daar dus last van?

 

 

Ik heb ooit ergens gehoord dat de Uno4kSE er ook last van heeft.



Re: LCD4Linux probleem? #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 27 February 2020 - 15:34

Ja.

 

En niet gelimiteerd tot het LCD scherm, maar tot alles wat vanuit Enigma draait. Ook een EPG import bv zal niet starten terwijl tuxtxt open staat...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #9 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 16:00

Met dat laatste ben ik het niet met je eens, gewoon omdat ik dit net heb getest.

Ik heb de tijd van de EPGimport even gewijzigd. Twee minuten voordat de import zou starten ben ik op NPO1 de teletekst gaan lezen, 5 minuten lang.

Na het afsluiten ervan meteen gekeken bij EPGimport en zag dat de EPG wel degelijk was binnengehaald op de ingestelde tijd.

 

Dus tijdens het lezen van teletekst wordt de EPG gewoon gedownload.

 

Ik maak gebruik van de EPGimport-Rytec plugin



Re: LCD4Linux probleem? #10 littlesat

  • PLi® Core member
  • 50,817 posts

+564
Excellent

Posted 27 February 2020 - 16:28

Als epg import gebruik gemaakt had can threaded technieken dan had die niet tot spinners geleid....

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: LCD4Linux probleem? #11 Bram55

  • Senior Member
  • 694 posts

+13
Neutral

Posted 27 February 2020 - 16:33

Wie heeft het nu over spinners? Dat wordt in heel deze discussie niet genoemd.



Re: LCD4Linux probleem? #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 27 February 2020 - 18:00

Wat littlesat bedoelt is dat een plugin zelf wel multi-threaded geschreven kan zijn, en dan lopen die (callback) taken buiten de mainloop om.  En Lcd4linux zal dat vast niet zijn.

 

Allemaal niet relevant voor tuxtxt, dat is geen python, dat is een gecompileerde binary...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #13 satlutser

  • Senior Member
  • 114 posts

0
Neutral

Posted 28 February 2020 - 12:10

Ik heb dit net even geprobeerd op mijn Zgemma H7s en hier draait LCD4Linux gewoon door bij het oproepen van teletekst.
Zgemma H7S, Wd hdd 750Gb intern, OpenPli 7.1, Oscam, LCD4Linux, Astra 19.2E, 23.5E, 28.2E, DVB-T2 fta.

Re: LCD4Linux probleem? #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,499 posts

+954
Excellent

Posted 28 February 2020 - 12:59

We hebben het hier toch over de LCD van de box? Heb je lcd4linux daarvoor speciaal geconfigureerd?

 

Want standaard komt dat display helemaal niet van Lcd4linux, die wordt door Enigma onderhouden...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: LCD4Linux probleem? #15 Tech

  • Forum Moderator
    PLi® Core member
  • 11,492 posts

+278
Excellent

Posted 28 February 2020 - 15:42

En ZgemmaH7 heeft ook weinig display ;) dus kan je er haast van uit gaan dat er een extern display aan hangt, die wordt niet door enigma onderhouden.


Aan de rand van de afgrond is een stap voorwaarts niet altijd vooruitgang....

Re: LCD4Linux probleem? #16 satlutser

  • Senior Member
  • 114 posts

0
Neutral

Posted 29 February 2020 - 12:16

Ja, met een externe display. Andere situatie dus.
Zgemma H7S, Wd hdd 750Gb intern, OpenPli 7.1, Oscam, LCD4Linux, Astra 19.2E, 23.5E, 28.2E, DVB-T2 fta.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users