Jump to content


Photo

oscam openvpn reader after start error


  • Please log in to reply
2 replies to this topic

#1 gusto

  • New Member
  • 4 posts

0
Neutral

Posted 27 February 2020 - 10:30

I test Openpli 6.2, 7.2 (boxes: vu+, formuler, qviart ....)

I have installed oscam and openvpn from the feed. I only have proxy readers in oscam

[reader]
label                         = loc_ovpn
protocol                      = cccam
device                        = openvpn_ip,12222
user                          = name
password                      = pass
inactivitytimeout             = 60
reconnecttimeout              = 120
group                         = 1
cccversion                    = 2.2.1
cccmaxhops                    = 2
ccckeepalive                  = 1
cccreshare                    = 1

[reader]
label                         = loc
protocol                      = cccam
device                        = public_ip,12222
user                          = name
password                      = pass
inactivitytimeout             = 60
fallback                      = 1
group                         = 1
cccversion                    = 2.2.1
cccmaxhops                    = 2
cccreshare                    = 1

Proxy loc is fallback. Every time I turn on the box, reader loc_ovpn is an error

1970/01/01 01:00:19 00000000 s >> OSCam << cardserver log switched, version 1.20_svn, build r11572 (mipsel-oe-linux)
1970/01/01 01:00:19 00000000 s (main) System name = Linux
1970/01/01 01:00:19 00000000 s (main) Host name = formuler4turbo
1970/01/01 01:00:19 00000000 s (main) Release = 4.10.6
1970/01/01 01:00:19 00000000 s (main) Version = #1 SMP Tue Dec 10 18:14:03 CET 2019
1970/01/01 01:00:19 00000000 s (main) Machine = mips
1970/01/01 01:00:19 00000000 s (main) Stb model = dm800se
1970/01/01 01:00:19 00000000 s (main) Stb boxtype = formuler4turbo
1970/01/01 01:00:19 00000000 s (main) The current system time is smaller than the build date (Dec 16 2019). Waiting up to 0 seconds for time to correct
1970/01/01 01:00:20 00000000 s (main) Waiting was not successful. OSCam will be started but is UNSUPPORTED this way. Do not report any errors with this version.
1970/01/01 01:00:20 00000000 s (main) creating pidfile /tmp/oscam.pid with pid 445
1970/01/01 01:00:20 00000000 s (config) userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
1970/01/01 01:00:20 00000000 s (main) signal handling initialized
1970/01/01 01:00:20 00000000 s (config) 176 service-id's loaded in 8 ms
1970/01/01 01:00:20 00000000 s (net) monitor: initialized (fd=6, port=989)
1970/01/01 01:00:20 00000000 s (net) cccam: initialized (fd=7, port=12013)
1970/01/01 01:00:20 00000000 s (reader) loc_ovpn [cccam] creating thread for device 10.8.0.1
1970/01/01 01:00:20 00000000 s (reader) loc [cccam] creating thread for device public_ip
1970/01/01 01:00:20 00000000 s (main) waiting for local card init
1970/01/01 01:00:20 469CE06B p (reader) 10.8.0.1: resolved ip=10.8.0.1
1970/01/01 01:00:20 469CE06B p (reader) loc_ovpn [cccam] connecting to 10.8.0.1:12222
1970/01/01 01:00:20 1CAD7C0A p (reader) public_ip: resolved ip=xx.xx.xx.xx
1970/01/01 01:00:20 1CAD7C0A p (reader) loc [cccam] connecting to public_ip:12222
1970/01/01 01:00:20 1CAD7C0A p (reader) loc [cccam] proxy initialized, server public_ip:12222
1970/01/01 01:00:20 1581DD37 h (webif) webif: decompressed 171152 bytes back into 419256 bytes
1970/01/01 01:00:20 1581DD37 h (webif) HTTP Server running. ip=:: port=8888
1970/01/01 01:00:21 00000000 s (main) init for all local cards done
1970/01/01 01:00:21 48F50BA8 c (client) plain dvbapi-client granted (dvbapiau, au=auto (4 reader))
1970/01/01 01:00:21 48F50BA8 c (dvbapi) dvbapi channelcache loaded from /etc/tuxbox/config/oscam/oscam.ccache
1970/01/01 01:00:21 48F50BA8 c (dvbapi) Detected /dev/dvb/adapter0/demux0 Api: 0, userconfig boxtype: 1 maximum number of filters is 64 (oscam limit is 64)
1970/01/01 01:00:21 48F50BA8 c (dvbapi) Detected /dev/dvb/adapter0/ca0 device, total available descramblers: 7
1970/01/01 01:00:21 48F50BA8 c (dvbapi) PMT mode 6: Connecting to enigma CA PMT listen socket...
1970/01/01 01:00:21 48F50BA8 c (dvbapi) socket connect error (errno=2 No such file or directory)
1970/01/01 01:00:22 48F50BA8 c (dvbapi) PMT mode 6: Connecting to enigma CA PMT listen socket...
1970/01/01 01:00:22 48F50BA8 c (dvbapi) PMT mode 6: Successfully connected to CA PMT server (fd 14)
1970/01/01 01:00:23 469CE06B p (reader) loc_ovpn [cccam] connect failed: Connection timed out
1970/01/01 01:00:23 469CE06B p (reader) loc_ovpn [cccam] proxy initialized, server 10.8.0.1:12222
1970/01/01 01:00:36 469CE06B p (reader) loc_ovpn [cccam] connecting to 10.8.0.1:12222
1970/01/01 01:00:39 469CE06B p (reader) loc_ovpn [cccam] connect failed: Connection timed out
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 ecmpid 0 CAID: 0668 ECM_PID: 1468 PROVID: 000000
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 ecmpid 1 CAID: 0624 ECM_PID: 1486 PROVID: 000000
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 ecmpid 2 CAID: 0500 ECM_PID: 14C2 PROVID: 051910
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 found 3 ECM pids and 2 STREAM pids in CA PMT
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 found channel in cache and matching prio -> start descrambling ecmpid 1
1970/01/01 01:00:42 48F50BA8 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0624 PROVID 000000 ECMPID 1486 ANY CHID PMTPID 138C VPID 1396
1970/01/01 01:00:42 48F50BA8 c (ecm) dvbapiau (0624@000000/0000/1328/55:0AA239EDD9505E1350E25696B65DFC42): found (8 ms) by loc
1970/01/01 01:00:44 48F50BA8 c (ecm) dvbapiau (0624@000000/0000/1328/55:5DD3EB4596D961C50D06199CC95CECF1): found (133 ms) by loc
2020/02/27 10:12:34 1CAD7C0A p (reader) loc [cccam] disconnected: reason inactivity
2020/02/27 10:12:44 1CAD7C0A p (reader) loc [cccam] connecting to public_ip:12222
2020/02/27 10:12:49 48F50BA8 c (ecm) dvbapiau (0624@000000/0000/1328/55:A11FC9BE85A38C17E581FC94BDAEE053): timeout (5002 ms) by loc
2020/02/27 10:12:54 48F50BA8 c (ecm) dvbapiau (0624@000000/0000/1328/55:A11FC9BE85A38C17E581FC94BDAEE053): found (4900 ms) by loc
2020/02/27 10:12:54 48F50BA8 c (ecm) dvbapiau (0624@000000/0000/1328/55:A499BB053B685125122F10CF3027ECD5): found (99 ms) by loc

I want it to work like this:

After the box starts, both readers will connect and after some time the reader loc (fallback) will disconnect.

Just as I wrote it works in Openpli 4.

In openpli 6.2 and 7.2, after the start  of box reader loc_ovpn is always an error. When I restart the reader or oscam, it works, but that's not the solution


Edited by gusto, 27 February 2020 - 10:31.


Re: oscam openvpn reader after start error #2 s3n0

  • Senior Member
  • 161 posts

+14
Neutral

Posted 2 March 2020 - 13:09

First, install the plugin "enigma2-plugin-systemplugins-systemtime" and set the time synchronization via NTP (i.e. via the internet, not via satellite transponder).

For "Formuler F4 Turbo" I think there is also some boot-loader CFE firmware patch - in conjunction with some Oscam BUGs, if you're using a deep standby on your "Formuler F4 Turbo". Is this not the same BUG ?
https://www.formuler...von-30-04-2018/

In case of cccam protocol + VPN network, using "ccckeepalive = 1" in file "oscam.server" might help.
http://www.streamboa...er#ccckeepalive

I would rather look for the error in VPN settings and not in OpenPLi Enigma or Oscam.



Re: oscam openvpn reader after start error #3 gusto

  • New Member
  • 4 posts

0
Neutral

Posted 8 March 2020 - 18:03

The problem was on the oscam servers.

max_connections               = 1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users