Jump to content


Photo

Mediaportal-Update fehlerhaft


  • Please log in to reply
58 replies to this topic

Re: Mediaportal-Update fehlerhaft #21 Thai

  • New Member
  • 4 posts

0
Neutral

Posted 21 May 2020 - 17:13

Danke, das Paket ließ sich installieren.

 

Mediaportal bringt jetzt (nach Flash von OpenPli 7.1 auf 7.2) beim Start einen GreenScreen wegen zu wenig Speicher.

 

Werde ich wohl nochmal flashen, diesmal geht es dann zurück auf die 4.0.



Re: Mediaportal-Update fehlerhaft #22 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,522 posts

+1,083
Excellent

Posted 21 May 2020 - 17:22

Wenn Sie einen grünen Bildschirm haben, haben Sie ein crash log in /home/root.

 

Die Chancen stehen gut, wie ich vorhergesagt habe, dass der XP1000 einfach zu alt ist, nicht genug Speicher und / oder Flash-Speicherplatz.
 
( google translate )

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mediaportal-Update fehlerhaft #23 Thai

  • New Member
  • 4 posts

0
Neutral

Posted 21 May 2020 - 17:56

Flash auf OpenPli 4.0 aus Ressourcengründen war jetzt erfolgreich, das angehängte Paket konnte ich ebenfalls installieren.
 
Die beiden Mediaportal IPK-Files liessen sich jedoch nicht installieren:

root@xp1000:/var/volatile/tmp# opkg install *.ipk
Installing python-youtube-dl (2020.05.08+git17681+8f841fa-r0.0) on root.
Installing python-argparse (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-argparse_2.7.3-r5.4.2_mips32el-nf.ipk.
Installing python-email (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-email_2.7.3-r5.4.2_mips32el-nf.ipk.
Installing python-image (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-image_2.7.3-r5.4.2_mips32el-nf.ipk.
Installing python-audio (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-audio_2.7.3-r5.4.2_mips32el-nf.ipk.
Installing python-html (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-html_2.7.3-r5.4.2_mips32el-nf.ipk.
Installing python-subprocess (2.7.3-r5.4.2) on root.
Downloading http://downloads.openpli.org/feeds/openpli-4/mips32el-nf/python-subprocess_2.7.3-r5.4.2_mips32el-nf.ipk.
Configuring python-image.
Configuring python-audio.
Configuring python-email.
Configuring python-subprocess.
Configuring python-argparse.
Configuring python-html.
Configuring python-youtube-dl.
root@xp1000:/var/volatile/tmp# opkg install *.ipk
Installing enigma2-plugin-extensions-mediaportal (2020052001) on root.
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
*      nodejs (>= 4.4.3) *     python-six *    python-requests (>= 2.11.1) *
* opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal.
root@xp1000:/var/volatile/tmp# opkg install *.ipk
Installing enigma2-plugin-extensions-mediaportal (2020010801) on root.
enigma2-plugin-extensions-mediaportal: unsatisfied recommendation for nodejs
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
*      python-six *    python-requests (>= 2.11.1) * 
* opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal.
root@xp1000:/var/volatile/tmp# 

 



Re: Mediaportal-Update fehlerhaft #24 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,522 posts

+1,083
Excellent

Posted 21 May 2020 - 18:16

Hate to say "told you so", but I told you so.

 

Besides that, the packages I build are for OpenPLi 7, it is very unlikely they work on an old image based on OE Morty....


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mediaportal-Update fehlerhaft #25 Thai

  • New Member
  • 4 posts

0
Neutral

Posted 21 May 2020 - 18:30

Kein Problem :)

Für's Schlafzimmer reicht die Box allemal noch.



Re: Mediaportal-Update fehlerhaft #26 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,522 posts

+1,083
Excellent

Posted 21 May 2020 - 18:39

For watching TV or recordings, it is still a fine box, but running a javascript engine like nodejs is above its capabilities.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mediaportal-Update fehlerhaft #27 lider

  • New Member
  • 1 posts

0
Neutral

Posted 24 May 2020 - 19:45

is it file python-youtube-dl_2020.05.08 work vti 14.0.6 solo2 vu ?



Re: Mediaportal-Update fehlerhaft #28 Pumuckel

  • Senior Member
  • 325 posts

+16
Neutral

Posted 24 May 2020 - 20:45

 The creators of VTI-image have to answer this question, because they are the ones who do not participate in the community and do not disclose their sources ;) --> so it is their job to solve problems.

 

 

... Pumuckel



Re: Mediaportal-Update fehlerhaft #29 dhwz

  • Senior Member
  • 224 posts

+19
Neutral

Posted 24 May 2020 - 21:46

@lider
No as VTi versioning is broken, you cannot use the packages from here, they will get overwritten again by the old VTi one.

Re: Mediaportal-Update fehlerhaft #30 warmsummerrain

  • Senior Member
  • 42 posts

+2
Neutral

Posted 26 May 2020 - 02:03

@WanWizard: That's what i call a 'supported image'. Thanks a lot! Great Job for, in my opinion, the best image on the planet!



Re: Mediaportal-Update fehlerhaft #31 warmsummerrain

  • Senior Member
  • 42 posts

+2
Neutral

Posted 4 July 2020 - 03:06

Ich muss hier leider nochmal posten, denn bei mir klappt etwas mit python-argparse nicht.
 
Problem ist Folgendes - installiere ich die python-Pakete, kam bei zwei von vier Receivern folgendes Problem:
 
Installing python-argparse (2.7.13) on root
Downloading python-argparse_2.7.13-r1.1_mips32el.ipk (habe hier den Hyperlink abgekürzt)
Removing corrupt package file /var/cache/opkg/3a36ed9c8257c8fc743355820d510915_python-argparse_2.7.13-r1.1_mips32el.ipk.
Installing python-youtube-dl (2020.05.08+git17680+a54c5f8) on root
Configuring python-youtube-dl.
Collected errors:
 * opkg_install_pkg: Failed to download python-argparse. Perhaps you need to run 'opkg update'?

 
Versuche ich dann das python-Paket nochmal zu installieren, kommt diese Fehlermeldung
(opkg update wurde natürlich bereits durchgeführt, bringt aber nichts):
 
Collected errors:
 * opkg_prepare_file_for_install: Refusing to load file 'python-youtube-dl_2020.05.08+git17680+a54c5f8-r0.1_mips32el.ipk' as it matches

   the installed version of python-youtube-dl (2020.05.08+git17680+a54c5f8-r0.1).
 
 
Wenn ich dann das Update auf die neueste Version des Mediaportals durchführe, kommt wiederum diese Fehlermeldung:
 
Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides requested python-argparse
 *
 * Solution 1:
 *   - do not ask to install a package providing python-argparse

 
 
Auf zwei Receivern läuft das 7.0er, auf den anderen zwei das 7.2er.
Das Kuriose dabei ist - auf einem der beiden 7.0er klappt die Installation einwandfrei, auf dem anderen nicht.
Bei den beiden 7.2er ist es genauso - bei einem klappt es, beim anderen nicht.
 
An allen vier Receivern wurde nichts installiert außer OpenPLi selbst und das Mediaportal.
Auch opkg update brachte nichts.
 
Kann mir da irgendwer weiterhelfen? Bzw. kann ich das 'korrupte' argparse-Paket manuell deinstallieren (damit ich dann

die aktuelle Version ohne Probleme installieren kann)?

 

 

 

 
 
 


Edited by warmsummerrain, 4 July 2020 - 03:15.


Re: Mediaportal-Update fehlerhaft #32 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,522 posts

+1,083
Excellent

Posted 4 July 2020 - 11:46

Es könnte im Cache eines der Download-Mirror beschädigt worden sein. Ich habe alle aktualisiert.

 

Könnten Sie es erneut versuchen?

 

( google translate )


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mediaportal-Update fehlerhaft #33 warmsummerrain

  • Senior Member
  • 42 posts

+2
Neutral

Posted 5 July 2020 - 22:34

Danke für die Antwort!

Ich hatte jetzt am Wochenende leider keine Zeit zum testen.

 

Ich versuche es morgen nochmal und poste dann hier das Ergebnis.



Re: Mediaportal-Update fehlerhaft #34 kalehrl

  • Senior Member
  • 421 posts

+7
Neutral

Posted 18 July 2020 - 08:01

Openpli 7.3 still doesn't have python-youtube-dl package.

The latest mediaportal plugin requires >= 2020.06.16 so the ones on the previous page don't work:

Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides python-youtube-dl >= 2020.06.16 needed by enigma2-plugin-extensions-mediaportal-2020053103.all
 *
 * Solution 1:
 *   - do not ask to install enigma2-plugin-extensions-mediaportal-2020053103.all

 


Edited by kalehrl, 18 July 2020 - 08:04.


Re: Mediaportal-Update fehlerhaft #35 Aliraza63

  • Senior Member
  • 28 posts

+2
Neutral

Posted 18 July 2020 - 08:29

 

Openpli 7.3 still doesn't have python-youtube-dl package.

The latest mediaportal plugin requires >= 2020.06.16 so the ones on the previous page don't work:

Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides python-youtube-dl >= 2020.06.16 needed by enigma2-plugin-extensions-mediaportal-2020053103.all
 *
 * Solution 1:
 *   - do not ask to install enigma2-plugin-extensions-mediaportal-2020053103.all

 

Working versions 

 send in temp ipk file

& telnet   force-depends install /tmp/*.ipk  

Attached Files


Vu+Duo2, Vu+Solo4k, Vu+Solo2 , Vu+Ultimo4k, Zegmma H9S


Re: Mediaportal-Update fehlerhaft #36 kalehrl

  • Senior Member
  • 421 posts

+7
Neutral

Posted 18 July 2020 - 08:57

I don't think that's a "clean" solution.



Re: Mediaportal-Update fehlerhaft #37 dhwz

  • Senior Member
  • 224 posts

+19
Neutral

Posted 18 July 2020 - 09:19

That's not a solution at all as the missing depend is still missing and some plugins depend on it to work properly.

Re: Mediaportal-Update fehlerhaft #38 Pumuckel

  • Senior Member
  • 325 posts

+16
Neutral

Posted 18 July 2020 - 11:00

@WanWizard

Can you build the dependencie-IPK (python-youtube-dl >= 2020.06.16)? THANKS!!

 

 

... Pumuckel



Re: Mediaportal-Update fehlerhaft #39 betacentauri

  • PLi® Core member
  • 6,290 posts

+276
Excellent

Posted 18 July 2020 - 11:17

It's a pity that bitbake cannot handle this situation properly. Or is it possible? At the moment we have fix PV https://github.com/O...utube-dl.bb#L15 even when we use AUTOREV.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Mediaportal-Update fehlerhaft #40 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,522 posts

+1,083
Excellent

Posted 18 July 2020 - 12:00

So the package itself is updated (due to the AUTOREV), but the box doesn't update it because the PV hasn't changed? Wouldn't the SRCPV not increment with newer versions?

 

I've just checked, even develop has this:

root@vuduo4k:~# opkg list python-youtube-dl
python-youtube-dl - 2020.05.08+git17720+a115e07-r0.0 - Download videos from YouTube (and more sites)

but mediaportal installs and starts fine.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users