Jump to content


Photo

Errors when opkg install package ZERO 4K

zero 4k openpli 7.3 opkg upgrade opkg install libc6-dev

  • Please log in to reply
10 replies to this topic

#1 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 24 November 2020 - 20:09

Hi I did and upgrade looking for packages I didnt find and now when I try to install a package the message is this:

 

Collected errors:
 * Solver encountered 2 problem(s):
 * Problem 1/2:
 *   - nothing provides requested linux-libc-headers-dev
 *
 * Solution 1:
 *   - do not ask to install a package providing linux-libc-headers-dev
 
 * Problem 2/2:
 *   - nothing provides requested libc6-dev
 *
 * Solution 1:
 *   - do not ask to install a package providing libc6-dev
 
Are these errors fatal and I must to reinstall/flash openpli 7.3 again on my box?

Edited by daveraver, 24 November 2020 - 20:09.


Re: Errors when opkg install package ZERO 4K #2 WanWizard

  • PLi® Core member
  • 62,675 posts

+1,476
Excellent

Posted 24 November 2020 - 22:42

I have no clue why something on the box would require -dev packages. What package has that dependency?


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), SAB AlphaTriple HD (S2+T2), (Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will have periods of inactivity, during which I won't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Errors when opkg install package ZERO 4K #3 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 25 November 2020 - 06:13

any package I try to install by console give me this message.

Edited by daveraver, 25 November 2020 - 06:14.


Re: Errors when opkg install package ZERO 4K #4 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 25 November 2020 - 08:11

I have tried with several packages, openvpn or other plugin extensions, and all report this same error message, I will flash the box with the last 7.3 build... thanks



Re: Errors when opkg install package ZERO 4K #5 WanWizard

  • PLi® Core member
  • 62,675 posts

+1,476
Excellent

Posted 25 November 2020 - 15:55

For some reason you have a package installed that requires -dev packages. Which we don't distribute because no one runs a compiler on his (or her) box.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), SAB AlphaTriple HD (S2+T2), (Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will have periods of inactivity, during which I won't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Errors when opkg install package ZERO 4K #6 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 25 November 2020 - 21:00

well, I flashed the 23rd November 7.3 build, I think now is right, maybe try installing dreamplex or bitrate plugin, not available for zero 4k?? no idea... I will test if I can install some other plugin, but it will be interesting to know if there is some problem after doing an opkg upgrade...

Enviat des del meu SNE-LX1 usant Tapatalk

Re: Errors when opkg install package ZERO 4K #7 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 25 November 2020 - 22:20

well, I flashed the 23rd November 7.3 build, I think now is right, maybe try installing dreamplex or bitrate plugin, not available for zero 4k?? no idea... I will test if I can install some other plugin, but it will be interesting to know if there is some problem after doing an opkg upgrade...

Enviat des del meu SNE-LX1 usant Tapatalk

so, now, problems with dreamplex 2.1.3... I have had to delete it...


Enviat des del meu SNE-LX1 usant Tapatalk

Re: Errors when opkg install package ZERO 4K #8 Aliraza63

  • PLi® Tester
  • 198 posts

+22
Neutral

Posted 26 November 2020 - 12:49

Once I had same this issue  when I was using OpenPli 7.2 at my Duo4k . I had figured out later it was due to install the mips plugin in arm architecture . Even the plugin was working seamlessly. 


DM-520,Vu+Duo2 , VU+Duo4k,Octagon 8008 S2X


Re: Errors when opkg install package ZERO 4K #9 blzr

  • PLi® Core member
  • 2,258 posts

+117
Excellent

Posted 26 November 2020 - 13:39

looks that this is the cause of the problem in this case too, mentioned above dreamplex plugin is packaged all arch, but AFAIK includes some mipsel libs (if the ipk in the vu feed is same as those that can be found on the internet)...


True sarcasm doesn't need green font...

Re: Errors when opkg install package ZERO 4K #10 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 26 November 2020 - 17:22

it worked well on zero 4k and openpli 6.2. is there any way to get it working, dreamplex 2.1.3 is the last ipk to put on any box??? the plugin on vu feed is a previous version with same problems, I think so

Edited by daveraver, 26 November 2020 - 17:25.


Re: Errors when opkg install package ZERO 4K #11 daveraver

  • Senior Member
  • 411 posts

+5
Neutral

Posted 28 November 2020 - 10:03

I think I must do a clean install of plugin, because when I upgrade to 7.3 version it installed the dreamplex feed plugin and then I install the latest plugin 2.1.3 version with not clean/delete folders. I will do it on monday and I will comment it.



Also tagged with one or more of these keywords: zero 4k, openpli 7.3, opkg upgrade, opkg install, libc6-dev

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users