Jump to content


Photo

play audio using alsa device (big probleme with Vu+ Model)


  • Please log in to reply
7 replies to this topic

#1 aridj

  • New Member
  • 3 posts

0
Neutral

Posted 1 March 2021 - 16:25

Hello , i'm trying to play sound from internet radio station using alsa device ,  i write "AUDIO_SET_MUTE" to the first audio adapter to mute e2 and alsa stay's unmuted everyting works fine in octagon sf8008, gegabluetrio4k, uclan

 

but in all vu+ models and other box  when i write "AUDIO_SET_MUTE" to the first audio adapter to mute e2 it return message Error "device busy"

 

i try other solution stop the current service and i write AUDIO_SET_MUTE again it work but mut evrything e2 sound and alsa

 

 

what is the probleme in all Vu+ model?


Edited by aridj, 1 March 2021 - 16:28.


Re: play audio using alsa device (big probleme with Vu+ Model) #2 rantanplan

  • Senior Member
  • 737 posts

+38
Good

Posted 1 March 2021 - 16:56

First of all ...
No it's not a big problem.

Then for explanation:
Alsa works on the 'Hisi' receiver built based on ffmpeg.
With regard to VU + you have to give more precise information. There is also the option of Alsa support for some models.

greetings



Re: play audio using alsa device (big probleme with Vu+ Model) #3 aridj

  • New Member
  • 3 posts

0
Neutral

Posted 1 March 2021 - 17:30

anadol zgemma are the same 'Hisi' cpu as octagon sf8008  "AUDIO_SET_MUTE"  work for them but it stop e2 sound and alsa sound together

 

for Vu+ i tested for all Model from solo to vu+ duo4k se have the same probleme AUDIO_SET_MUTE not work when /dev/dvb/adapter0/audio0 are used by enigma2 but in octagon sf8008 it work  even if /dev/dvb/adapter0/audio0 is used

 

in vu+ when i stop the current service "AUDIO_SET_MUTE" work and i can write to /dev/dvb/adapter0/audio0 But the problem is that it stops the e2 sound and alsa sound together


Edited by aridj, 1 March 2021 - 17:31.


Re: play audio using alsa device (big probleme with Vu+ Model) #4 betacentauri

  • PLi® Core member
  • 6,963 posts

+299
Excellent

Posted 1 March 2021 - 17:58

We cannot change the way "AUDIO_SET_MUTE" work. It's in the box drivers or kernel related. Nothing we can change.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: play audio using alsa device (big probleme with Vu+ Model) #5 aridj

  • New Member
  • 3 posts

0
Neutral

Posted 1 March 2021 - 18:06

Ok thank you



Re: play audio using alsa device (big probleme with Vu+ Model) #6 WanWizard

  • PLi® Core member
  • 58,391 posts

+1,273
Excellent

Posted 1 March 2021 - 18:18

VU+ has never "officially" supported ALSA on their hardware, drivers are not installed by default.

 

Kodi has the same issues because of this...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: play audio using alsa device (big probleme with Vu+ Model) #7 FRAP

  • Senior Member
  • 302 posts

+23
Neutral

Posted 2 March 2021 - 16:30

Hello excuse me if I am not writing in the appropriate topic. I installed the development version. When I enable the Signal Search plugin and select my tuner to scan channels I get a crash

Attached Files


Alcohol for wimps. Strong people enjoy depression.


Re: play audio using alsa device (big probleme with Vu+ Model) #8 Dimitrij

  • PLi® Core member
  • 7,761 posts

+252
Excellent

Posted 2 March 2021 - 16:58

 File "/usr/lib/enigma2/python/Plugins/SystemPlugins/Satfinder/plugin.py", line 113, in newConfig
  File "/usr/lib/enigma2/python/Plugins/SystemPlugins/Satfinder/plugin.py", line 163, in createSetup
ValueError: invalid literal for int() with base 10: ''

First disable tuners when in not use,
 


Duo 4K/Lunix3-4K/Solo 4K





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users