Jump to content


Photo

OpenWebif configuration no longer display the URL to call.


  • Please log in to reply
12 replies to this topic

#1 Pr2

  • PLi® Contributor
  • 4,752 posts

+197
Excellent

Posted 20 April 2021 - 12:56

Hi,

 

if you go into:

 

Menu - Plugins - OpenWebif configuration

 

At the bottom of the configuration screen there is: OpenWebif url:

 

For me this information remains empty but it should display the full url to call to access the box OpenWebif internally.

 

Does others have the same issue?

 

Thanks,

 

Pr2

 

 


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: OpenWebif configuration no longer display the URL to call. #2 foxbob

  • Senior Member
  • 516 posts

+17
Neutral

Posted 20 April 2021 - 16:03

And I also have

 

Attached Files



Re: OpenWebif configuration no longer display the URL to call. #3 ccs

  • Senior Member
  • 174 posts

+5
Neutral

Posted 20 April 2021 - 16:11

Same on OpenViX.


test


Re: OpenWebif configuration no longer display the URL to call. #4 WanWizard

  • PLi® Core member
  • 58,392 posts

+1,273
Excellent

Posted 20 April 2021 - 16:47

self["lab1"] = Label("%s\n%s://%s:%d" % (_("OpenWebif url:"), owif_protocol, ip, owif_port))

It was changed 29 days ago, in https://github.com/E...327066e3223a417

 

I think the "\n" causes the text to wrap, and since there is only space for one line in the skin, the rest is not displayed. I've asked the author to remove it.


Edited by WanWizard, 20 April 2021 - 16:52.

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: OpenWebif configuration no longer display the URL to call. #5 littlesat

  • PLi® Core member
  • 53,183 posts

+614
Excellent

Posted 20 April 2021 - 20:05

Again a config screen where it could be considered to move this info to the description instead of having a custom field and where we have an issue when there were descriptions here..... just like the address on the hdmi cec screen...
And maybe our default skin has two lines available....

Edited by littlesat, 20 April 2021 - 20:06.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenWebif configuration no longer display the URL to call. #6 WanWizard

  • PLi® Core member
  • 58,392 posts

+1,273
Excellent

Posted 20 April 2021 - 21:14

This is OWIF code, we have no control / input over it. And no, our skin doesn't have two lines available, that is the problem, the second line is not visible.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: OpenWebif configuration no longer display the URL to call. #7 Matrix10

  • Senior Member
  • 326 posts

+25
Good

Posted 1 May 2021 - 22:42

Why don't you fix this

People think their webif doesn't work.

 

<screen name="OpenWebifConfig" position="fill" title="OpenWebif Configuration" flags="wfNoBorder">
<panel name="PigTemplate"/>
<widget name="config" position="780,100" size="1110,912" itemHeight="38" font="Regular;28" scrollbarMode="showOnDemand"/>
<widget name="lab1" position="780,935" halign="center" size="1110,80" zPosition="1" font="Regular;30" valign="top" transparent="1"/>
</screen>



Re: OpenWebif configuration no longer display the URL to call. #8 Matrix10

  • Senior Member
  • 326 posts

+25
Good

Posted 1 May 2021 - 22:53

I would ask those who are constantly changing skin coding in images
Pli / VIX /Oe-A
not to make unnecessary changes.
 
It becomes tedious to update skins for stupid coding changes.
I have to update thirty coding skins on our server as well.
Totally unnecessary.


Re: OpenWebif configuration no longer display the URL to call. #9 krimesis

  • Senior Member
  • 125 posts

0
Neutral

Posted 1 May 2021 - 23:05

I would ask those who are constantly changing skin coding in images
Pli / VIX /Oe-A
not to make unnecessary changes.

It becomes tedious to update skins for stupid coding changes.
I have to update thirty coding skins on our server as well.
Totally unnecessary.

Indeed.

Re: OpenWebif configuration no longer display the URL to call. #10 Pr2

  • PLi® Contributor
  • 4,752 posts

+197
Excellent

Posted 2 May 2021 - 09:00

We are not responsible for Openwebif changes you have to complain on the Openwebif GitHub.
Openwebif is an independent project used by several images.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: OpenWebif configuration no longer display the URL to call. #11 Matrix10

  • Senior Member
  • 326 posts

+25
Good

Posted 2 May 2021 - 09:58

We are not responsible for Openwebif changes you have to complain on the Openwebif GitHub.
Openwebif is an independent project used by several images.

 

It is not directly related to the Pli team
but my general appeal to everyone who works on images and plugins to take care of coding changes and skins.
Namely, in recent months there have been several changes that are not in line with skin coding.
On the other hand, they were not needed because they did not contribute to any important improvement.
So this is a general request to take care of that.
Making some artificial changes after a decade , does not make sense if it does not contribute to anything.

Edited by Matrix10, 2 May 2021 - 09:59.


Re: OpenWebif configuration no longer display the URL to call. #12 Pr2

  • PLi® Contributor
  • 4,752 posts

+197
Excellent

Posted 2 May 2021 - 11:22

Yes but on the other side we cannot stop developing or improve stuff just because "skinners" need to adapt there skins to follow the evolution. :-)


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: OpenWebif configuration no longer display the URL to call. #13 Matrix10

  • Senior Member
  • 326 posts

+25
Good

Posted 2 May 2021 - 11:39

Yes but on the other side we cannot stop developing or improve stuff just because "skinners" need to adapt there skins to follow the evolution. :-)

 
We may have different opinions.
Unfortunately, all changes are made without a serious opinion of those on whom
these changes relate.Skinners.
 
I write about unnecessary changes and not about those that contribute to something.
In the world of skins, we almost don't have any significant improvements
expanding opportunities over the last nearly a decade.
These are changes that have not contributed much but have only replaced the existing possibilities.
 
I don’t know if it’s an improvement if you replace one line unnecessarily with two
or replace the OK button with two green and OK buttons.
I guess one is enough
Just to name a couple.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users