Jump to content


Photo

High load on VU+ Solo4


  • Please log in to reply
16 replies to this topic

#1 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 3 May 2021 - 08:44

Why does the Solo4K have such a high load with OpenPLi? I checked on version 8.0, 7.3 and 6.2 (installed without restoring settings).
Bare OpenPLi, without channel list, without any plugin or settings, top shows me the load on the level 1.3-1.8,
while on the other stb (for example VU zero) the load does not exceed 0.2

 

Mem: 237904K used, 670996K free, 364K shrd, 8052K buff, 95700K cached
CPU:   0% usr   0% sys   0% nic  99% idle   0% io   0% irq   0% sirq
Load average: 1.60 1.58 1.19 2/132 2743
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
 1143     1 root     S     550m  62%   0% /usr/bin/dvb_server
 1407  1403 root     S     140m  16%   0% /usr/bin/enigma2
 1466  1463 root     R     2748   0%   0% top
 1145     1 root     S     472m  53%   0% /usr/bin/init_client /lib/modules/3.14
 1367     1 root     S    36436   4%   0% /usr/sbin/smbd
 1370  1367 root     S    34888   4%   0% {smbd-notifyd} /usr/sbin/smbd
 1371  1367 root     S    34880   4%   0% {cleanupd} /usr/sbin/smbd
 1462  1461 root     S    25332   3%   0% /bin/login
 1372     1 root     S    25208   3%   0% /usr/sbin/nmbd
 1463  1462 root     S     7448   1%   0% -sh
 1330     1 root     S     4324   0%   0% /usr/libexec/bluetooth/bluetoothd
 1394     1 avahi    S     3308   0%   0% avahi-daemon: running [vusolo4k.local]
 1395  1394 avahi    S     3176   0%   0% avahi-daemon: chroot helper
  749     1 root     S     3024   0%   0% /sbin/udevd -d
 1338     1 root     S     2872   0%   0% /usr/sbin/inetd
 1358     1 root     S     2820   0%   0% /usr/sbin/rpc.mountd
 1461  1338 root     S     2748   0%   0% telnetd
 1325     1 rpcuser  S     2716   0%   0% /usr/sbin/rpc.statd
 1383     1 root     S     2656   0%   0% /sbin/syslogd -n -O /var/log/messages
 1386     1 root     S     2656   0%   0% /sbin/klogd -n

Edited by pepinoogorino, 3 May 2021 - 08:52.


Re: High load on VU+ Solo4 #2 Trial

  • Senior Member
  • 1,056 posts

+31
Good

Posted 3 May 2021 - 09:05

Hi,

is someone streaming from your box? nic  99% is interesting. Take a look with netstat.

 

Ralf


Edited by Trial, 3 May 2021 - 09:06.


Re: High load on VU+ Solo4 #3 Dimitrij

  • PLi® Core member
  • 7,665 posts

+248
Excellent

Posted 3 May 2021 - 09:17

openpli develop lunix3-4k

lunix3-4k login: root
root@lunix3-4k:~# top
Mem: 1304620K used, 758344K free, 408K shrd, 3708K buff, 114072K cached
CPU:   0% usr   4% sys   0% nic  95% idle   0% io   0% irq   0% sirq
Load average: 1.17 1.19 1.18 2/117 1412

 


Duo 4K/Lunix3-4K/Solo 4K


Re: High load on VU+ Solo4 #4 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 3 May 2021 - 09:17

No one. As I wrote, stb is right after the start, the only active connection on netstat is mine with telnet.

BTW: I can't edit the previous post anymore, but one of the lines is slightly cut off:

1145     1 root     S     472m  53%   0% /usr/bin/init_client /lib/modules/3.14.28-1.8/extra/brcmfb.ko

 



Re: High load on VU+ Solo4 #5 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 3 May 2021 - 09:19

@Dimitrij
And this high load does not seem strange to you? Why is the vuzero point so low?



Re: High load on VU+ Solo4 #6 Dimitrij

  • PLi® Core member
  • 7,665 posts

+248
Excellent

Posted 3 May 2021 - 11:21

@Dimitrij
And this high load does not seem strange to you? Why is the vuzero point so low?

I don't know what the problem is and if it was like this before.

But it doesn't bother me.


Duo 4K/Lunix3-4K/Solo 4K


Re: High load on VU+ Solo4 #7 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 3 May 2021 - 11:48

High load with low cpu usag is usually a large iowait.
Just because you don't see the problem does mean it isn't there.

 



Re: High load on VU+ Solo4 #8 WanWizard

  • PLi® Core member
  • 58,033 posts

+1,255
Excellent

Posted 3 May 2021 - 13:17

My VU+ Duo 4K:

Mem: 497576K used, 70368K free, 64132K shrd, 18024K buff, 187376K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 0.24 0.22 0.15 3/167 12761

so not generically OpenPLi related, but something local?

 

But: my SF8008 reports

Mem: 443564K used, 505424K free, 396K shrd, 20228K buff, 97568K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 12.09 12.16 12.17 2/203 17730

while it is absolutely doing nothing. Which begs the question how reliable this data is...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: High load on VU+ Solo4 #9 Pr2

  • PLi® Contributor
  • 4,707 posts

+194
Excellent

Posted 3 May 2021 - 16:59

VU+ Solo 4K watching TV with OScam running:

 

Mem: 415104K used, 493796K free, 1572K shrd, 8776K buff, 111884K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 0.00 0.01 0.05 2/139 30022

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: High load on VU+ Solo4 #10 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 4 May 2021 - 00:01

 

VU+ Solo 4K watching TV with OScam running:

Mem: 415104K used, 493796K free, 1572K shrd, 8776K buff, 111884K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 0.00 0.01 0.05 2/139 30022
It looks good. Which version of OpenPLi? Are you using a disk?

 



Re: High load on VU+ Solo4 #11 Pr2

  • PLi® Contributor
  • 4,707 posts

+194
Excellent

Posted 4 May 2021 - 12:31

8.0 develop yes I have an internal SSD.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: High load on VU+ Solo4 #12 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 4 May 2021 - 22:09

@Pr2
Uptime?



Re: High load on VU+ Solo4 #13 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 8 May 2021 - 20:41

@Pr2
After several hours, the load decreases to the level of 0.5-0.7, but it does not want to drop any lower.
I also changed the image to the last development one. It is the same with the load :/

 



Re: High load on VU+ Solo4 #14 catastrofus

  • Senior Member
  • 2,943 posts

+35
Good

Posted 8 May 2021 - 21:33

It's a dual core, so what's your problem?


2 x ultimo4k (dvb-c fbc + 1 dvb-s2, 8.0r) + een et10k (geen tuners en dus fallbackclient, develop) met een Synology ds214+ (2 x 6 TB) ziggo oost (voormalig @Home) + A1/A2/A3/HB (TechniSat)
 


Re: High load on VU+ Solo4 #15 catastrofus

  • Senior Member
  • 2,943 posts

+35
Good

Posted 8 May 2021 - 21:44

1 of mine Ultimo4k's (4 cores) reports:

 

root@panoramix:~# uptime
 22:41:57 up 20 min,  load average: 1.08, 1.01, 0.76
root@panoramix:~#


 


Edited by catastrofus, 8 May 2021 - 21:44.

2 x ultimo4k (dvb-c fbc + 1 dvb-s2, 8.0r) + een et10k (geen tuners en dus fallbackclient, develop) met een Synology ds214+ (2 x 6 TB) ziggo oost (voormalig @Home) + A1/A2/A3/HB (TechniSat)
 


Re: High load on VU+ Solo4 #16 Pr2

  • PLi® Contributor
  • 4,707 posts

+194
Excellent

Posted 8 May 2021 - 21:54

22:53:03 up  3:51,  load average: 1.03, 1.06, 1.12
 

But what is your problem why are you focusing on this?  Is your box slow?


Edited by Pr2, 8 May 2021 - 21:55.

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: High load on VU+ Solo4 #17 pepinoogorino

  • Senior Member
  • 64 posts

+2
Neutral

Posted 9 May 2021 - 20:03

I already know what causes this CPU load - the heads.
Currently, I have four active unicable heads on one input and a second input configured as a classic, single one. In addition, the Solo4K also has an additional DVB-T/C head.

Disabling each of them reduces the number of visible /usr/bin/dvb_server processes and reduces the CPU load.
Interestingly, if we do nothing, the number of /usr/bin/dvb_server processes drops to one after several hours.

 


Edited by pepinoogorino, 9 May 2021 - 20:04.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users