Springen naar inhoud


Foto

Subtitles not shown on HiSil receiver with standard player (MKV files)


  • Please log in to reply
Er zijn 37 reacties in dit onderwerp

#1 doglover

  • Rytec EPG Team
  • 15040 berichten

+519
Excellent

Geplaatst op 30 mei 2021 - 07:58

Subtiles embedded in mkv files (as srt) are not shown on a HiSil receiver (Maxytec Multibox SE)

Update 30-05-2021

The same files play on a HD2400 (mipsel) perfectly with subtitles.

 

Using the exteplayer3 bring back the subtitles. So there is a workaround.

 

Channels from the bouquetlist play correctly on the Multobox SE (with subtitles)


Veranderd door doglover, 30 mei 2021 - 08:29

~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #2 littlesat

  • PLi® Core member
  • 53323 berichten

+622
Excellent

Geplaatst op 30 mei 2021 - 09:16

Looks like the hisi Player does not offer those subs...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #3 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 11:55

try build Hisi player with patch.

If it works, I can create it there as a request.

Bijgevoegde Bestanden



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #4 doglover

  • Rytec EPG Team
  • 15040 berichten

+519
Excellent

Geplaatst op 30 mei 2021 - 12:31

I cannot build an image.  So, I cannot test this.

(If I set-up a system, I probably could)


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #5 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 13:11

Maybe
WanWizard would like to build it into develop like this?
It sure is easier than if I let the image come to you now.
Let's see if someone answers.
greetings



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #6 WanWizard

  • PLi® Core member
  • 60087 berichten

+1368
Excellent

Geplaatst op 30 mei 2021 - 13:34

Isn't servicehisilicon part of the BSP?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #7 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 13:43

The Zgemma service Hisilicon is used

 

https://github.com/v...i3798mv.inc#L20

 

https://github.com/z...icehisilicon.bb

 

Rebuild in Progress, but of course that takes many time for me.
If it works, you could generally change it for all Hisi boxes at Zgemma.


Veranderd door rantanplan, 30 mei 2021 - 13:48


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #8 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 16:42

@doglover

 

try to check update with this ipk

Bijgevoegde Bestanden



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #9 doglover

  • Rytec EPG Team
  • 15040 berichten

+519
Excellent

Geplaatst op 30 mei 2021 - 17:05

Installed.  No errors.

But you say this fixes the subtitles. 

 

It fixed the showing of the .eit files for mkv's both in the GUI and OWIF.  Still no subtitles.

I think this fix ended-up in the wrong thread.

 

Thanks in each case for this fix.


Veranderd door doglover, 30 mei 2021 - 17:06

~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #10 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 19:14

ok, then I have probably misunderstood the 'subtitle'.
I thought it was actually referring to lack of EPG/.eit.
So fixed one problem with (eit)?
But there is one more problem with the subtitles.
I'll have a look



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #11 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 30 mei 2021 - 20:31

Next ipk for Test

 

 

Bijgevoegde Bestanden



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #12 doglover

  • Rytec EPG Team
  • 15040 berichten

+519
Excellent

Geplaatst op 31 mei 2021 - 07:01

.eit info shown.

subttiles shown.  (after manually selecting)

 

However still one problem. The subtitle track is not automatically selected.

I have checked the settings for auto language selection and these are set.

It is possible to select the subtitle manually.  (the track is recognized).  And then is displayed properly.

PS:  I should have mentioned this before.  This problem(?) existed from the beginning.


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #13 Dimitrij

  • PLi® Core member
  • 8078 berichten

+260
Excellent

Geplaatst op 31 mei 2021 - 07:31

Maybe

https://github.com/O...7bdb85ccc743775


Duo 4K/Lunix3-4K/Solo 4K


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #14 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 31 mei 2021 - 09:06

Just to be on the safe side ...
The second variant leads almost completely to success?
The first variant didn't show any subtitles yet, right?


Dimitrj
You mean take over the commit on the Hisiplayer?
I don't think this is so straightforward.
The problem is the completely missing 'Auto' routine in Hisi-player. That was not taken over.
It's not that simple in terms of structure, but it should work too.
Actually, someone would just have to sit down with the box, because it will certainly lead to some errors at the beginning.
Which Hisi Box should be irrelevant.
Whereby a few decided in a completely incomprehensible way to integrate the Hisiplayer closed source.

 



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #15 Dimitrij

  • PLi® Core member
  • 8078 berichten

+260
Excellent

Geplaatst op 31 mei 2021 - 09:29

The problem is much more complicated from my point of view.

This is a third-party application, wasting time and effort on it ...

Why couldn't the standard Enigma functions be used?


Veranderd door Dimitrij, 31 mei 2021 - 09:29

Duo 4K/Lunix3-4K/Solo 4K


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #16 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 31 mei 2021 - 09:38

I'm not so strict about that now.
Even disagree a little.

The Hisiplayer is an ffmpeg based solution of the gst based solution (servicemp3).
From my point of view, both approaches should have been dealt with for a long time.
The outsourcing in pli of servicemp3 is a really good way to do this.

You can compare both variants wonderfully and optimize accordingly.
As long as there are open sources, you should do this in your own interest and learn from them.

We can also teach the Hisiplayer the interface gst, then you would have a double solution without using the service app.
Everything works.
But one solution is enough for me.
ffmpeg is perfectly fine and seems to be prioritized over and over again.

Perhaps pli should bring servicehisilicon into its own git. Anyway, all Hisi boxes use the engine and are currently using Zgemma.

I think Zgemma's submission is very good.
Adjustments that we make to servicemp3 can also be ported there. That's nothing bad.

greetings



Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #17 doglover

  • Rytec EPG Team
  • 15040 berichten

+519
Excellent

Geplaatst op 31 mei 2021 - 09:48

Just to be on the safe side ...
The second variant leads almost completely to success?
The first variant didn't show any subtitles yet, right?
 

 

Yes It worked. And indeed the first variant did not show the subtitles.

The only thing missing is the automatic selection of the subtitle.


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #18 Dimitrij

  • PLi® Core member
  • 8078 berichten

+260
Excellent

Geplaatst op 31 mei 2021 - 09:57

 

Perhaps pli should bring servicehisilicon into its own git. Anyway, all Hisi boxes use the engine and are currently using Zgemma.

This is what I wanted to say ;) .

In this case, it can be improved without depending on anyone.


Duo 4K/Lunix3-4K/Solo 4K


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #19 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 31 mei 2021 - 09:58

@doglover

:thumbs-up: ok.

The thing with the automatic language selection is Cosmetic, which can take a while.
I have to see if I can do it, there are a few additional things to consider.
Half of it has already been integrated.

greetings


Veranderd door rantanplan, 31 mei 2021 - 09:58


Re: Subtitles not shown on HiSil receiver with standard player (MKV files) #20 rantanplan

  • Senior Member
  • 835 berichten

+38
Good

Geplaatst op 31 mei 2021 - 10:05

@Dimitrj

 

Of the many manufacturers, Zgemma is one of the few who are interested in cooperation.
This is exemplary compared to others who only help themselves.
They also cater to the different demands of image builders, which is why there is also a separate pli branch for servicehisilicon.
So it's fair to give back inew mprovements.




3 gebruiker(s) lezen dit onderwerp

0 leden, 3 bezoekers, 0 anonieme gebruikers