Jump to content


Photo

Openpli 8 and LG OLED C8 CEC issue


  • Please log in to reply
7 replies to this topic

#1 Ivan1981

  • Member
  • 7 posts

0
Neutral

Posted 24 July 2021 - 08:06

Hi guys, I'm facing this annoying problem on openpli 8.0, I'm ok on openatv 6.4 to be clear.
I'm not able to turn receiver on (zgemma h7) if I turn off the TV while I'm watching another source (like the TV channels, in the log attached) and then turn TV on. The receiver turns correctly on if I turn the TV off while I'm watching something within it and then I turn the TV on again. Thank you in advance for your help, attached is a log with this second scenario first and after the first scenario (the one that makes me mad).

Attached Files



Re: Openpli 8 and LG OLED C8 CEC issue #2 Pr2

  • PLi® Contributor
  • 5,132 posts

+209
Excellent

Posted 24 July 2021 - 10:53

Sorry your description is not 100% clear to me. But I guess that you means that when turning on the Zgemma it doesn't switch to the proper HDMI entry on your TV. So I guess that if you use your TV RCU and force the right HDMI entry manually you have the Zgemma image on your TV?

 

You need unfortunately to play with the different HDMI-CEC possible option and find the one that works properly with your TV.

The problem is that changing the parameters on the fly is not the best way to find the proper working solution.  You can play with the speed for sending command or the fact to repeat the CEC message.

 

So it is sometimes good to perform a cold start (power unplug) from both TV and Zgemma to validate your HDMI setup.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Openpli 8 and LG OLED C8 CEC issue #3 Ivan1981

  • Member
  • 7 posts

0
Neutral

Posted 24 July 2021 - 11:34

I try to explain it better:
Scenario 1: TV on, receiver on. I'm watching something on receiver, everything is fine. I turn off TV, receiver turns itself off. I turn TV on, the receiver turns on. Everything is ok
Scenario 2: TV is on, receiver is on. I'm watching something on receiver and everything is fine. I switch to another HDMI port or to the TV channels. The receiver is still on but it's not currently on screen because there is another source. I turn TV off. The receiver correctly turns itself off. I turn TV on, the receiver doesn't turn itself on, even after manually switch to its HDMI port with the remote. The only way to turn it on is with its remote.

Re: Openpli 8 and LG OLED C8 CEC issue #4 Pr2

  • PLi® Contributor
  • 5,132 posts

+209
Excellent

Posted 24 July 2021 - 12:12

OK thanks now the explanation is really clear.

I guess that the TV is only sending the up signal on the latest HDMI that you use (which can sound logical on its own). What you are expecting is that your TV turn on every device that is connected on your HDMI entry.

Don't you have an option in the TV to tell it to always start on a particular HDMI entry?  On my Sony TV, I can define the TV button to switch to the HDMI-1 and not to the build in tuner of the TV.

There is also an option in the HDMI CEC screen to tell the STB to check for other connected devices (turn the expert mode into OpenPLi to have full access to every possible options).


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Openpli 8 and LG OLED C8 CEC issue #5 Jork

  • Senior Member
  • 598 posts

+11
Neutral

Posted 24 July 2021 - 12:17

HDMI-CEC had to switch on in settings this function "deep stand-by as normal stand-by".
Restart after that your complete set including tv.
That solved it for me for an LG TV.
Though the function doesn't seem to do what it says it does, it worked for this TV brand.
You can give it a try.

Edited by Jork, 24 July 2021 - 12:21.


Re: Openpli 8 and LG OLED C8 CEC issue #6 Ivan1981

  • Member
  • 7 posts

0
Neutral

Posted 24 July 2021 - 16:10

Already on. I've tried pretty much every combination in these months

Re: Openpli 8 and LG OLED C8 CEC issue #7 Ivan1981

  • Member
  • 7 posts

0
Neutral

Posted 24 July 2021 - 16:57

What I don't understand is the reason openatv 6.4 with pretty much the same configuration works perfectly. This issue has started with openpli 7.0

Re: Openpli 8 and LG OLED C8 CEC issue #8 Pr2

  • PLi® Contributor
  • 5,132 posts

+209
Excellent

Posted 24 July 2021 - 17:32

Because OpenATV is may be using some other default values.

And please consider to perform a cold start of all your installation TV and STB (and amplifier/soundbar) because HDMI-CEC dislike changing on the fly the parameters.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 



3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users